[Stable Update] 2020-09-11 - Kernels, Gnome 3.36.6, MHWD, Pamac, VirtualBox

Got a signature error with updating mhwd. Refreshed my keys, got one error, but the update worked afterwards.

Linux54, manjaro gnome vanilla

I’ve got this error:
==> WARNING: Possibly missing firmware for module: xhci_pci
in fact xhci_pci is regarding to USB 3.x controller but after reboot I couldn’t use my keyboard at the login screen so new update seems useless for me. I hope new patch comes. Maybe problem is coming from different cause.

Install the firmware from AUR upd72020x-fw or wait unit manjaro developers patch this in the next stable Kernel (it’s exist also on the 5.9 RC5)

1 Like

I did this: did not updated linux-latest-ndiswrapper in pamac-gui and the update process worked. I marked it not to update. If you need ndiswrapper keep using linux57.

1 Like

In my case, I found that linux-latest-ndiswrapper wasn’t a dependency of any other package on my computer:

$ pactree -r linux-latest-ndiswrapper
linux-latest-ndiswrapper

So I simply removed linux-latest-ndiswrapper from my computer and ran an ordinary update:

sudo pacman -R linux-latest-ndiswrapper
sudo pacman -Syyu

After rebooting, all is well.

I see that @philm maintains linux-latest-ndiswrapper. Perhaps he will fix this problem for users who actually need the package.

3 Likes

the N00b way is to run manjaro-settings-manager, but take a backup first:

:man_shrugging:

1 Like

Did you install/compile your own version of CUPS?

If yes:

  • remove that and install the standard one if the bug why you did so is incorporated into the current version
    OR
  • File a bug with the package maintainer.

If no: open a new issue here and provide more info.

1 Like

Bug has been filed already just be patient and use the workaround in the meantime…

1 Like

I ardently use the 4.4. I read that the driver has to be removed (if I read correctly)…this would render the 4.4 unusable…any workarounds that would satisfy both paths: updating and using the 4.4?
Thanks
Melissa

This worked for me, thanks. Though I found that a reboot wasn’t necessary.

1 Like

If 4.4 means you’re talking about the nVidia drivers: I had no problems just staying on the 440 line…

2 Likes

Thanks, everything OK!!!

Hello Fabby,

Thanks for your reply. I just use the CUPS packages provides by Manjaro Team so, following your advice, I opened a new issue here.

Have a nice day.
Kind regards.

This ISO now works on Ventoy which is cool.

It cannot be installed easily without mouse. Current bluez won’t connect to wireless mouse (known issue). Keyboard time? Trying to downgrade to bluez-git before the actual installation is wow, so hard. Try to add AUR, then install the package, then reset the bluetooth connection (which is claming to be connected but it’s not). Keyboard control is terrible, you don’t see what object is selected, Ctrl-Tab doesn’t work, Ctrl-PgUp/Down doesn’t overwrite inner UI objects so it works only sometimes, no “Alt keys”, no Enter as default action (Space needs to be used for buttons even if focused and selected). I’d think Linux would be excellent in this, but it’s opposite.

Manjaro has the best partitioning, but i couldn’t choose partition for EFI. I would like to use one EFI for Windows, one EFI for Linux.

1 Like

Hello, after updating yesterday I couldn’t login. I followed the known issues advice (adding systems.unit=rescue.target in the boot options) but I get the error message “cannot open access to consol, the root account is locked” afterwards. How do I solve this?

I am having two problems with the update (one of which I solved and will post below this) and this one I haven’t figured out. For some reason after the update my system will never go up from it’s idle speed (800Mhz) to it’s turbo speed (3.3 to 3.6Ghz). I’ve checked the speed numbers using a number of ways (with both tools like turbostat and cpupower as well as empirically with building code and using the web browser). The cpu performance profile/governor is set to performance and cpupower-gui says that the minimum speed (800Mhz) and the maximum speed (2.7Ghz) are correct. At this point I’m not sure what to do next.

The second problem was that tigervnc broke because it included references to selinux specific packages and directories. This was broken in upstream version 1.11.0-2 and is fixed by picking up the 1.11.0-4 package from Arch. More details are in the arch Linux forum post titled " TigerVNC does not start after update" (unfortunately I can’t link to it).

see this

4 Likes

Adding intel_pstate=active to the kernel command line worked. Thanks for a simple fix!
Also worth noting that you can get this change to be permanent by editing the /etc/default/grub file and adding intel_pstate=active to the GRUB_CMDLINE_LINUX_DEFAULT variable.

2 Likes

can you report

inxi -MCza
1 Like