[Stable Update] 2020-09-11 - Kernels, Gnome 3.36.6, MHWD, Pamac, VirtualBox

Sure :slight_smile: First I just uninstalled the nvidia-340 driver with pacman (not sure if you need to do this).

Then I used mhwd to find my driver:

mhwd --listinstalled

and then I just used the remove command with sudo:

sudo mhwd --remove pci video-nvidia-340xx

I’m also a total noob, so don’t know if you need to do these steps at all, but at least it worked for me :slight_smile:

Habe auch Probleme mit dem Update. Kernel ist 5.8.6.

Warnung: Kann “linux58-ndiswrapper” nicht auflösen (eine Abhängigkeit von “linux-latest-ndiswrapper”)
:: Das folgende Paket kann aufgrund nicht auflösbarer Abhängigkeiten nicht aktualisiert werden:
linux-latest-ndiswrapper

linux58-ndiswrapper ist nicht installiert und auch nicht im Repro verfügbar, dafür aber linux57-ndiswrapper.

Gruß

Boot with Kernel 5.4
Went into tty - pamac checkupdates -a and pamac update all went fine
Shut down- Boot up the new installed Kernel, 5.8.6-1
check:
sudo journalctl -p err --since today no errors

:blush: Thank you

I have Laptop ASUS Vivobook X556UQK, with manjaro gnome working fine, and I am trying to install Manjaro 20.1 Mikah KDE Plasma from scratch, and I have a problem with the keyboard.

Boot from a pendrive and In the first screen, the keyboard works perfect, but when I go to kde plasma to continue with the installation only the function keys work (ej fn+f2 wifi on, etc) but non other keystroke or a sigle key or number, cannot type anything in the console or any text box.

The mouse works perfectly, I try to go to settings to change the keyboard settings, but I still can’t write even though I have tried various settings.

Any suggestion? Does anyone else have this problem?

maybe this is the problem:

https://bbs.archlinux.org/viewtopic.php?id=257963

External Keyboard? Otherwise after install, install 5.4 Kernel and Test

See post #14 in the link for the workaround. It did the trick for my Asus laptop. There’s no kernel patch yet, afaik.
You could also install the 5.4 LTS kernel (use on-screen keyboard for that).

EDIT: @philm You might wanna look into that. It has been reported here and on the arch forum not only by Asus users but also by Acer users. Affected are all 5.8 and 5.9 kernels that I have tried so far. No problems reported with linux54 LTS.

Here’s the topic that I opened a couple weeks ago in order to find a solution:

I also tried a workaround using an udev rule - which is working for me. No idea how to fix that stuff on the kernel side.

1 Like

Got a signature error with updating mhwd. Refreshed my keys, got one error, but the update worked afterwards.

Linux54, manjaro gnome vanilla

I’ve got this error:
==> WARNING: Possibly missing firmware for module: xhci_pci
in fact xhci_pci is regarding to USB 3.x controller but after reboot I couldn’t use my keyboard at the login screen so new update seems useless for me. I hope new patch comes. Maybe problem is coming from different cause.

Install the firmware from AUR upd72020x-fw or wait unit manjaro developers patch this in the next stable Kernel (it’s exist also on the 5.9 RC5)

1 Like

I did this: did not updated linux-latest-ndiswrapper in pamac-gui and the update process worked. I marked it not to update. If you need ndiswrapper keep using linux57.

1 Like

In my case, I found that linux-latest-ndiswrapper wasn’t a dependency of any other package on my computer:

$ pactree -r linux-latest-ndiswrapper
linux-latest-ndiswrapper

So I simply removed linux-latest-ndiswrapper from my computer and ran an ordinary update:

sudo pacman -R linux-latest-ndiswrapper
sudo pacman -Syyu

After rebooting, all is well.

I see that @philm maintains linux-latest-ndiswrapper. Perhaps he will fix this problem for users who actually need the package.

3 Likes

the N00b way is to run manjaro-settings-manager, but take a backup first:

:man_shrugging:

1 Like

Did you install/compile your own version of CUPS?

If yes:

  • remove that and install the standard one if the bug why you did so is incorporated into the current version
    OR
  • File a bug with the package maintainer.

If no: open a new issue here and provide more info.

1 Like

Bug has been filed already just be patient and use the workaround in the meantime…

1 Like

I ardently use the 4.4. I read that the driver has to be removed (if I read correctly)…this would render the 4.4 unusable…any workarounds that would satisfy both paths: updating and using the 4.4?
Thanks
Melissa

This worked for me, thanks. Though I found that a reboot wasn’t necessary.

1 Like

If 4.4 means you’re talking about the nVidia drivers: I had no problems just staying on the 440 line…

2 Likes

Thanks, everything OK!!!

Hello Fabby,

Thanks for your reply. I just use the CUPS packages provides by Manjaro Team so, following your advice, I opened a new issue here.

Have a nice day.
Kind regards.

This ISO now works on Ventoy which is cool.

It cannot be installed easily without mouse. Current bluez won’t connect to wireless mouse (known issue). Keyboard time? Trying to downgrade to bluez-git before the actual installation is wow, so hard. Try to add AUR, then install the package, then reset the bluetooth connection (which is claming to be connected but it’s not). Keyboard control is terrible, you don’t see what object is selected, Ctrl-Tab doesn’t work, Ctrl-PgUp/Down doesn’t overwrite inner UI objects so it works only sometimes, no “Alt keys”, no Enter as default action (Space needs to be used for buttons even if focused and selected). I’d think Linux would be excellent in this, but it’s opposite.

Manjaro has the best partitioning, but i couldn’t choose partition for EFI. I would like to use one EFI for Windows, one EFI for Linux.

1 Like