[Stable Update] 2020-08-22 - Kernels, Deepin, KDE-git, Firefox, Pamac, Nvidia 450, KDE Apps 20.08

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed


Pamac Update Indicator is black/invisible/blurry

See here for more information. Nothing to be concerned about.

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

telegram is not following gtk theme anymore

Settings > Advanced > System integration > Use system window frame

LibreOffice Fresh (at least Writer) is generally unresponsive (tab & Enter keys not working and other issues)

Leave all configuration files, extensions, etc. in place. Replace LibreOffice Fresh with LibreOffice Still.


Older issues

(2020-05-19) systemd 245.5 and old Plymouth

If you have an older Manjaro installation from 2017 or so, you might still have Plymouth installed. If you hadn’t updated it from AUR, it is recommended to remove Plymouth before you attempt to update systemd. If for some reason you updated already and now have issues, login to a TTY and disable Plymouth:

  • Ctrl + Alt + F3 and login
  • sudo pacman -R plymouth
  • you may want to check if the wanted display manager still works and enable its service if needed.

For more details and possible further steps on Plymouth removal see Plymouth - Manjaro Linux In particular you need to remove the “plymouth” hook from /etc/mkinitcpio.conf and rebuild your initramfs.

Search the forum for additional Plymouth troubleshooting. 0.9.4.r269.g23afdeb-2 should fix the issue.

(2020-04-19) System with amdgpu won’t reboot or power off correctly

This was a kernel regression and has been patched in 5.4.33-2, 5.5.18-2, and 5.6.5-2. Check again for updates.


Report any AUR breakage here.

2 Likes

Smallish update, no issues. Kernel 5.8, Cinnamon DE, AMD video.

The update went fine.

But I had to install Nvidia 450xx driver manually.
Uninstall driver 440xx, reboot and then install driver 450xx.

Thanks!

how you uninstalled and installed manualy?

After rebooting and entering my password in sddm nothing happened, the system just froze. Rebooted via TTY again the system froze so I had to use SYSRQ REISUB and everything seems ok now.

Manjaro KDE Linux 5.7.15-1-MANJARO

2 Likes

When trying to run ksystemlog I received an error.

ksystemlog: /usr/lib/libsystemd.so.0: version `LIBSYSTEMD_246’ not found (required by ksystemlog)

Looking at the file.
lrwxrwxrwx 1 root root 20 Aug 16 03:29 /usr/lib/libsystemd.so.0 -> libsystemd.so.0.28.0

Checking a virtual machine of Manjaro ksystemlog and it is working properly without today’s update.
After the update ksystemlog is getting the error above.

Installed:
systemd 245.7-2 system and service manager
systemd-libs 245.7-2

No problems with the update on three kde - computers :grinning:

Thank´s to the manjaro - team

regards
caho

The Manjaro Wiki is your friend: Configure Graphics Cards - Manjaro Linux

Auto install open source driver, reboot and then auto install Nvidia driver.

Hi,

OS up to date, so far it works. I solved a sound issue by installing the 5.8 kernel this week.

update went well, no problems after reboot but nvidia is still 440.100 although the update claimed it had upgraded. don’t know what’s going on. it works so i’m not really afraid but nvidia didn’t upgraded.

A post was merged into an existing topic: Installing Nvidia 450.xx drivers after 2020-08-22 stable update

for me also same error and wiki my friend doesnt help

Update went well. But I can’t seem to install video-hybrid-intel-nvidia-450xx-prime so I had to revert to 440xx again

Stuck with this:

sudo mhwd -i pci video-hybrid-intel-nvidia-440xx-prime
Dependencies to install: video-modesetting
Proceed with installation? [Y/n]

It just stays there after pressing Enter. Can’t seem to download the driver. Interestingly, when trying to install the 440 hybrid driver again, the same problem pops up so I had to use timeshift to go back to the snapshot before this update.

Weirdly enough I can download and install the non-hybrid 450xx (and 440xx) driver which I’m currently using right now.

for That if your in Xfce open a terminal
if you are in gnome or KDE , open TTY ( Ctrl + Alt + F2 to F7 and login )
and close your gnome / Kde session

*** only out of your session ***

for PCI nvidia card only

sudo mhwd pci -i video-nvidia-450xx 

if hybrid nvidia cards

28 posts were split to a new topic: Installing Nvidia 450.xx drivers after 2020-08-22 stable update

XFCE; Kernel 5.8.1; Vega64;
(still holding back to wine 5.8, since 5.9 up to 5.14 is just garbage and doesn’t work at all)

Update itself went fine. No new problems yet detected :stuck_out_tongue:

Why is everyone flagging everything, it stops now or it will be disabled permanently.

3 Likes
 gdm.service - GNOME Display Manager
 Loaded: loaded (/usr/lib/systemd/system/gdm.service; enabled; vendor preset: disabled)
 Active: active (running) since Sat 2020-08-22 16:17:36 EEST; 40s ago

Main PID: 1187 (gdm)
Tasks: 3 (limit: 19054)
Memory: 5.7M
CGroup: /system.slice/gdm.service
└─1187 /usr/bin/gdm

Aug 22 16:17:36 eli systemd[1]: Starting GNOME Display Manager…
Aug 22 16:17:36 eli systemd[1]: Started GNOME Display Manager.
Aug 22 16:17:53 eli gdm-password][1481]: gkr-pam: unable to locate daemon control file
Aug 22 16:17:53 eli gdm-password][1481]: gkr-pam: stashed password to try later in open session
Aug 22 16:17:53 eli gdm-password][1481]: pam_unix(gdm-password:session): session opened for user andrito by (uid=0)
Aug 22 16:17:53 eli gdm-password][1481]: gkr-pam: gnome-keyring-daemon started properly and unlocked keyring

Apparmor fails to start after the update. Dont currently have time to troubleshoot it, and had to perform a rollback for now.