[Stable Update] 2020-08-22 - Kernels, Deepin, KDE-git, Firefox, Pamac, Nvidia 450, KDE Apps 20.08

This is known and ‘harmless’

EDIT: I did some tests and if I delete the file /etc/grub.d/60_memtest86+ then this error message disappear when I update-grub

1 Like

After a few days of usage, I had to revert to nvidia-440xx. With nvidia-450xx I had random compositor crashes, especially after resuming from suspend. I had to loginctl terminate in tty to get back into my kde DE.
No issues with 440xx.
5.7 kernel, didn’t try 5.8

Kernel 5.8.1-3 causes notable performance drop (~10%) in Superposition benchmark.
Restarting pulse audio service causes sound device list to be empty.

One additional regression of this update. My laptop idles warmer (temperatures of CPU cores) by 5-8C. Before the update the temperature was in range 37-39C, now it is in range 43-45C. I am on kernel 4.19. An update several months ago warmed up my CPU on kernel 5; because of that I switched to 4.19. Unfortunately we have the same issue for this kernel too. My CPU is i7-8750H, and it was great to be able to run Manjaro so cool. Not anymore.

Just a short note on the xhci_pci issue with all kernels 5.8.n, where n=0 to 3 (the latter in Testing).

The good news: Things seem to work even with the warning cited above in my original post.

The bad news: Kernels 5.8 are really misbehaving. For my hardware, the issue is twofold:

My chipset is an Intel Series 7/C210 and C216, which was the first xhci (USB 3.0) Intel built without relying on third-party (Renesas). [Only the previous Intel Series 6 relied on Renesas USB 3.0.]

Now, for kernels 5.7, the kernels pulled in the xhci and xhci_pci drivers - all fine. But kernels 5.8 pull in xhci, xhci_pci AND xhci_pci-renesas - funny thing. And the xhci_pci-renesas is the one that generates the mkinitcpio warning.

I did an additional check: openSUSE Tumbleweed with 5.8.0 pulls in the Renesas driver, too.

This happens also on Testing with a new linux-firmware I was brought today.

Remark: I am citing the driver names out of the top of my head, might be incorrect.

1 Like

see this topic

Thanks for referring to that source. My point is an additional one: As far as I understand Intel‘s technical website, my chipset Intel Series 7 is NOT related to anything Renesas. Looking at my machine in Windows confirms this. Linux 5.7 didn‘t load the Renesas thingy - okay, while 5.8 does - a misbehavior to my understanding. Hope the Kernel developers will do a clean-up of those regressions …

Edit: Oh, I might be totally wrong, cannot exclude this!

I’ve updated to Nvidia 450 on Manjaro KDE, and there is an issue: the KDE compositor crashes every time after suspend on kernel 5.8. Sometimes switching to Xrender and back makes it come back to life, but other times only reboot helps. Also sometimes the computer fails to wake up at all and gets stuck on a black screen, so that I have to kill the xorg.

Meanwhile, this driver does not seem to have this issue on kernel 5.7.15. Nvidia 440 on 5.8 before the update also worked fine.

I’m still trying to track this down, but I figured I would throw this out here for now. After this update anytime I reboot my machine the keyboard mode gets set to unicode instead of raw causing the alt-arrow keys to cycle tty instead of doing the right thing in the applicaiton/desktop. Going to rollback kernel and video drivers to see if that helps. Workaround is to run sudo kbd_mode -s

Kernel 5.8
NVidia 450 Prime

Update: I uninstalled ALL video drivers then re-installed video-modesetting and nvidia prime 440 and the problem seems to have gone away. That being said, when I run sudo kbd_mode it says that the “The keyboard is in some unknown mode”.

How is an application completely not showing nor starting up a “minimal” issue?

Could you give an example when the issue is critical, according to you?


It is minimal as in it is not breaking the system and logs are still available through other ways. Minimal issue.

as someone who used the log gui previously I found this page helpful.
I now find filtering in terminal better.


Gee yeah, why should I even use a desktop environment at all? [/sarcasm]

1 Like

EDIT: I had the hiccup with the Nvidia 440xx/450xx drivers which was easy enough to rectify.

However, I now have an issue with SDDM and it fails to start


Just a note that for the 5.8 kernel, there was a major driver reorganization. As part of that, the Renesas host driver was split into its own module which, until Manjaro 5.8.3-2, was not being initialized properly at boot time.

Perhaps this driver reorg also affected the Intel driver??

1 Like

I updated to 450xx drivers and use kernerl 5.8 with Plasma. I don’t have those issues you mentioned, so this is maybe specific to your hardware or configs.

But I do have this:

with 5.8. So far, I didn’t detect anything malfunctioning because of that.

1 Like

Am using Manjaro I3wm edition on 3 machines and update went well on 2 of them.
Thinkpad X230 was showing black screen after reboot following the update.

Had to chroot into encrypted installation and apply pacnew files for /etc/lightdm/lightdm.conf and /etc/security/pam_env.conf .
Then with the help of “lightdm --test-mode – debug” found out that the “lightdm-gtk-greeter” is missing and after installing that I could login again.

1 Like

Audio problems with both my old desktop and new laptop (T495).
The audio output is missing, requiring me to go to the terminal and type:
“pulseaudio -k” to get them back.

Also, on my T495 laptop I have a backlight issue (upon start, the backlight defaults to the max value, the previous value is not saved), however that issue appeared with the update before this one.

systemctl status systemd-backlight@backlight:amdgpu_bl0
● systemd-backlight@backlight:amdgpu_bl0.service - Load/Save Screen Backlight Brightness of backlight:amdgpu_bl0
Loaded: loaded (/usr/lib/systemd/system/systemd-backlight@.service; static)
Active: active (exited) since Thu 2020-09-03 12:08:09 CEST; 4min 9s ago
Docs: man:systemd-backlight@.service(8)
Process: 907 ExecStart=/usr/lib/systemd/systemd-backlight load backlight:amdgpu_bl0 (code=exited, status=0/SUCCESS)
Main PID: 907 (code=exited, status=0/SUCCESS)

sep 03 12:08:09 t495 systemd[1]: Starting Load/Save Screen Backlight Brightness of backlight:amdgpu_bl0…
sep 03 12:08:09 t495 systemd-backlight[907]: amdgpu_bl0: Saved brightness 4072 too high; decreasing to 255.
sep 03 12:08:09 t495 systemd[1]: Finished Load/Save Screen Backlight Brightness of backlight:amdgpu_bl0.

I think it is useful to report that after the update, at shutdown or restart, these 3 error lines appear for a very short time (I had to take a photo to my monitor).

sd-unmount[2506]: Failed to unmount /oldroot: Device or resource busy`
sd-unmount[2507]: Failed to unmount 20: No such file or directory`
shutdown[1]: Failed to finalize file systems, ignoring`

For me, a harmless problem, already discussed here. :arrow_down:

The laptop works ok.
4.19 Kernel.

This is normal. I see those warnings everyday. All distros have them. They shouldn’t have any bad effects.