[Stable Update] 2020-03-03 - Kernels, KDE-git, Asian-Input-Support, Firefox-Dev, LibreOffice, Wine

Hello community,

here is another Stable Update for you:


Check out the new devices our Partner Shop from Belgium has to offer!

Some feature-updates:

  • Kernels got updated
  • LibreOffice is now at 6.4.1
  • Firefox-Dev has a new developer version
  • Pamac 9.4 got some more fixes added its latest RC
  • Wine is now at 5.3
  • libglvnd got updated to 1.3.1
  • latte-dock is now at 0.9.9
  • More work went into UKUI
  • We added some meta-packages to make input ways for Asian languages easier
  • A lot of python and haskell updates

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our current 19.0.2 ISOs and give us the needed feedback. You might also want to give our latest spin with NX-Desktop a try ...

As always we appreciate your input and feedback for the updates.


Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

wget https://pkgbuild.com/~eschwartz/repo/x86_64-extracted/pacman-static
chmod +x pacman-static
sudo ./pacman-static -Syyu

Our current supported kernels

  • linux316 3.16.82
  • linux44 4.4.215
  • linux49 4.9.215
  • linux414 4.14.172
  • linux419 4.19.107
  • linux54 5.4.23
  • linux55 5.5.7
  • linux56 5.6-rc3
  • linux419-rt 4.19.106_rt44
  • linux54-rt 5.4.22_rt13

Package Changes (Sun Mar 1 13:56:58 CET 2020)

  • stable community x86_64: 1187 new and 1233 removed package(s)
  • stable core x86_64: 23 new and 21 removed package(s)
  • stable extra x86_64: 290 new and 283 removed package(s)
  • stable multilib x86_64: 6 new and 6 removed package(s)

A detailed list of all package changes can be reviewed here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

19 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed


Older issues

(2020-02-14) Can't boot into a graphical session anymore

[Stable Update] 2020-02-10 - Kernels, KDE Apps, Gnome Settings

We deeply apologize for the inconvenience this error may have caused.

Even if your graphical session is broken, you should still be able to access a TTY session with CTRL+ALT+F3 (and other similar key combinations), where you can then run sudo pacman -Syyu.

several flatpaks have issues to get a secure connection

This is a known bug and related to p11-kit update to 0.23.19. With 0.23.20-1 that issue is fixed. Please update to that version as soon our mirrors synced.

wpa_supplicant update broke Wifi for Broadcom

By enabling new features in revision 4 of v2.9 by Arch a connection with a Broadcom Wifi card was not possible anymore. This is a known bug. Either try to downgrade to revision 3 or upgrade to revision 5.

sudo pacman -U https://archive.archlinux.org/packages/w/wpa_supplicant/wpa_supplicant-2%3A2.9-3-x86_64.pkg.tar.xz
sudo pacman -U https://archive.archlinux.org/packages/w/wpa_supplicant/wpa_supplicant-2%3A2.9-5-x86_64.pkg.tar.zst

(From Arch Linux) rsync compatibility

(2020-01-15, by Christian Hesse)
(This is relevant on Manjaro, as Manjaro imports rsync package directly from Arch Linux.)

Our rsync package was shipped with bundled zlib to provide compatibility with the old-style --compress option up to version 3.1.0. Version 3.1.1 was released on 2014-06-22 and is shipped by all major distributions now.

So we decided to finally drop the bundled library and ship a package with system zlib . This also fixes security issues, actual ones and in future. Go and blame those running old versions if you encounter errors with rsync 3.1.3-3 .

Source: https://www.archlinux.org/news/rsync-compatibility/

Weird font glitches (see screenshots below).

If you have weird glitches like below...

Screenshots


string3
strings%20mismatch

... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.


Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

you kept the setup instructions for Stable-Staging in this post @philm

1 Like

Fixed.

1 Like

So far, everything is working perfectly.

CPU: Intel Core i5 M 480
Kernel: 5.4.23-1-MANJARO x86_64
Manjaro Stable 19.0.2 Kyria

After removing orphans:

Packages (3) python-zipp-3.0.0-1  python-importlib-metadata-1.5.0-1  python-more-itertools-8.2.0-1

and re-booting, no immediate breakage.

When I attempt to upgrade, I got this alert:

looking for conflicting packages...
:: gtk3 and gtk3-classic are in conflict (gtk3-print-backends). Remove gtk3-classic? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: gtk3 and gtk3-classic are in conflict

I don't want to replace gtk3-classic (the one without CSD) with the straight gtk3: what can I do?

EDIT: I solved.

Since gtk3-classic was moved to AUR, i opened pamac and i upgraded it manually/separately from the rest of available updates: all seems to went well.

Where can i find 19.0.2 ISOs or maybe you are still building them?

1 Like

Thank you for fixing the Julia issue....

Cinnamon + Kernel 5.5 + Intel video update went fine.

I have a BCM43142, updated to revision 5 and it works fine

Edit: After publishing the post. Manjaro offered me update revision 7 and it works fine too.

Didn't get an update, when shall I get it?

You'll get it as soon as your mirror(s) sync:
https://repo.manjaro.org/

1 Like

How do you detect orphaned packages?

Soweit hier auf Xfce alles gut, aber ich habe jetzt mit dem matcha-sea-theme genau wieder das gleiche Problem, wie schon vor einigen Monaten:

Gemeint sind die Symbole in derSeitenleiste (dunkel auf dunkel). Irgendwann wurde das Theme dann mal auf ne hellere Hintergrundfläche geändert, um die Symbole wieder sichtbar werden zu lassen, aber das wurde mit dem letzten Update wohl wieder verworfen ...

ansonsten alles gut, thx for the good work!

To check them:

pacman -Qdtq

To remove them:

sudo pacman -R $(pacman -Qdtq)

But in my humble opinion, is better to firstly check listed packages, by using pacman -Qi $packagename.

3 Likes

It can take several hours to get updates, depending on the mirror.

1 Like

Yea, I have the same problem with Thunar - dark background with dark symbols.

The only issue I have noticed so far is that the trashcan in Latte dock, you can't right click on it anymore and select, empty, etc.

3 Likes

https://forum.manjaro.org/c/deutsch

1 Like

Forum kindly sponsored by