[Stable Update] 2019-11-23 - Kernels, Mesa 19.2.6

Hello community,

I am happy to announce another Stable Update.


Might be just over the top, but Windows 10 ARM runs well on a Pinebook Pro with Manjaro as host

With this we have new Mesa drivers and latest Kernels. Grub should now auto-update with the new alpm-hook.

Some feature-updates:

  • Latest Kernel updates
  • Mesa is at 19.2.6

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-vanilla, which we build on a regular basis against kde-git master packages.

As always we appreciate your input and feedback for the updates.


Our current supported kernels:

  • linux316 3.16.76
  • linux44 4.4.202
  • linux49 4.9.202
  • linux414 4.14.155
  • linux419 4.19.85
  • linux53 5.3.12
  • linux54 5.4.0-rc7 (not all modules build yet!)
  • linux419-rt 4.19.72_rt26
  • linux52-rt 5.2.21_rt13

Package Changes (Wed Nov 13 11:48:51 CET 2019)

  • stable community x86_64: 1 new and 1 removed package(s)
  • stable core x86_64: 6 new and 6 removed package(s)
  • stable extra x86_64: 60 new and 60 removed package(s)
  • stable multilib x86_64: 5 new and 5 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-11-14           2019-11-23
-------------------------------------------------------------------------------
               gnome-layout-switcher                0.5-1                0.6-1


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-11-14           2019-11-23
-------------------------------------------------------------------------------
                            linux414           4.14.154-1           4.14.155-1
                    linux414-headers           4.14.154-1           4.14.155-1
                            linux419            4.19.84-1            4.19.85-1
                    linux419-headers            4.19.84-1            4.19.85-1
                             linux53             5.3.11-1             5.3.12-1
                     linux53-headers             5.3.11-1             5.3.12-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-11-14           2019-11-23
-------------------------------------------------------------------------------
                   libva-mesa-driver           19.2.4-0.1           19.2.6-0.1
                  linux414-acpi_call            1.1.0-126            1.1.0-127
                   linux414-bbswitch              0.8-126              0.8-127
                linux414-broadcom-wl     6.30.223.271-126     6.30.223.271-127
                linux414-ndiswrapper              1.62-21              1.62-22
               linux414-nvidia-340xx           340.107-85           340.107-86
               linux414-nvidia-390xx            390.132-3            390.132-4
               linux414-nvidia-418xx            418.113-2            418.113-3
               linux414-nvidia-430xx             430.64-1             430.64-2
               linux414-nvidia-435xx            435.21-11            435.21-12
               linux414-nvidia-440xx             440.31-2             440.31-4
                   linux414-nvidiabl             0.88-126             0.88-127
                      linux414-r8168           8.047.04-8           8.047.04-9
                   linux414-tp_smapi              0.43-18              0.43-19
                linux414-vhba-module          20190831-11          20190831-12
   linux414-virtualbox-guest-modules             6.0.14-5             6.0.14-6
    linux414-virtualbox-host-modules             6.0.14-5             6.0.14-6
                        linux414-zfs              0.8.2-8              0.8.2-9
                  linux419-acpi_call             1.1.0-74             1.1.0-75
                   linux419-bbswitch               0.8-74               0.8-75
                linux419-broadcom-wl      6.30.223.271-73      6.30.223.271-74
                linux419-ndiswrapper              1.62-23              1.62-24
               linux419-nvidia-340xx           340.107-73           340.107-74
               linux419-nvidia-390xx            390.132-3            390.132-4
               linux419-nvidia-418xx            418.113-2            418.113-3
               linux419-nvidia-430xx             430.64-2             430.64-3
               linux419-nvidia-435xx            435.21-13            435.21-14
               linux419-nvidia-440xx             440.31-3             440.31-4
                   linux419-nvidiabl              0.88-73              0.88-74
                      linux419-r8168           8.047.04-9          8.047.04-10
                  linux419-rtl8723bu   4.3.9.3.13200.0-57   4.3.9.3.13200.0-59
                   linux419-tp_smapi              0.43-23              0.43-24
                linux419-vhba-module          20190831-13          20190831-14
   linux419-virtualbox-guest-modules             6.0.14-5             6.0.14-6
    linux419-virtualbox-host-modules             6.0.14-5             6.0.14-6
                        linux419-zfs              0.8.2-9             0.8.2-10
                   linux53-acpi_call             1.1.0-12             1.1.0-13
                    linux53-bbswitch               0.8-12               0.8-13
                 linux53-broadcom-wl      6.30.223.271-12      6.30.223.271-13
                 linux53-ndiswrapper              1.62-12              1.62-13
                linux53-nvidia-340xx           340.107-12           340.107-13
                linux53-nvidia-390xx            390.132-3            390.132-4
                linux53-nvidia-418xx            418.113-2            418.113-3
                linux53-nvidia-430xx             430.64-1             430.64-2
                linux53-nvidia-435xx            435.21-11            435.21-13
                linux53-nvidia-440xx             440.31-3             440.31-4
                    linux53-nvidiabl              0.88-12              0.88-13
                       linux53-r8168          8.047.04-12          8.047.04-13
                   linux53-rtl8723bu     4.3.9.3.13200-12     4.3.9.3.13200-13
                    linux53-tp_smapi              0.43-12              0.43-13
                 linux53-vhba-module          20190831-12          20190831-13
    linux53-virtualbox-guest-modules             6.0.14-8             6.0.14-9
     linux53-virtualbox-host-modules             6.0.14-8             6.0.14-9
                         linux53-zfs             0.8.2-12             0.8.2-13
                                mesa           19.2.4-0.1           19.2.6-0.1
                          mesa-vdpau           19.2.4-0.1           19.2.6-0.1
                         opencl-mesa           19.2.4-0.1           19.2.6-0.1
                        vulkan-intel           19.2.4-0.1           19.2.6-0.1
                   vulkan-mesa-layer           19.2.4-0.1           19.2.6-0.1
                       vulkan-radeon           19.2.4-0.1           19.2.6-0.1


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-11-14           2019-11-23
-------------------------------------------------------------------------------
             lib32-libva-mesa-driver           19.2.4-0.1           19.2.6-0.1
                          lib32-mesa           19.2.4-0.1           19.2.6-0.1
                    lib32-mesa-vdpau           19.2.4-0.1           19.2.6-0.1
                  lib32-vulkan-intel           19.2.4-0.1           19.2.6-0.1
                 lib32-vulkan-radeon           19.2.4-0.1           19.2.6-0.1
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

11 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed


System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.


xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.


Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.


Pamac-Qt is not compatible to 9.0 API of Pamac


gnome-shell-extension-desktop-icons

the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

2 Likes

from new zealand. i see someone has installed the updates. i haven't yet as the mirrors in nz haven't synced

just got the updates installed. no problem at all. thanks guys

below is my hardware list

System:    Host: johns-pc Kernel: 5.3.12-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.3-x86_64 root=UUID=2132b488-639e-409e-b44b-56f27164c8f3 rw quiet apparmor=1 
           security=apparmor resume=UUID=db7dfbb7-320e-418f-b143-7725ee5744e1 udev.log_priority=3 modprobe.blacklist=radeon 
           amdgpu.dcfeaturemask=0x4 
           Desktop: KDE Plasma 5.17.3 tk: Qt 5.13.2 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Acer product: Aspire A315-21G v: V1.12 serial: <filter> 
           Mobo: SR model: Squirtle_SR v: V1.12 serial: <filter> UEFI [Legacy]: Insyde v: 1.12 date: 06/19/2018 
Battery:   ID-1: BAT1 charge: 36.8 Wh condition: 36.8/37.0 Wh (99%) volts: 8.7/7.7 model: PANASONIC AP16M5J type: Li-ion 
           serial: <filter> status: Full 
           Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard serial: <filter> charge: 55% (should be ignored) 
           rechargeable: yes status: Discharging 
CPU:       Topology: Dual Core model: AMD A9-9420e RADEON R5 5 COMPUTE CORES 2C+3G bits: 64 type: MCP arch: Excavator 
           family: 15 (21) model-id: 70 (112) stepping: N/A microcode: 6006705 L2 cache: 1024 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 7188 
           Speed: 1190 MHz min/max: 1200/1800 MHz boost: enabled Core speeds (MHz): 1: 1238 2: 1287 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Stoney [Radeon R2/R3/R4/R5 Graphics] vendor: Acer Incorporated ALI 
           driver: amdgpu v: kernel bus ID: 00:01.0 chip ID: 1002:98e4 
           Device-2: AMD Jet PRO [Radeon R5 M230 / R7 M260DX / Radeon 520 Mobile] vendor: Acer Incorporated ALI driver: N/A 
           bus ID: 01:00.0 chip ID: 1002:6665 
           Display: x11 server: X.Org 1.20.5 driver: amdgpu FAILED: ati unloaded: modesetting alternate: fbdev,vesa 
           compositor: kwin_x11 resolution: 1366x768~60Hz 
           OpenGL: renderer: AMD STONEY (DRM 3.33.0 5.3.12-1-MANJARO LLVM 9.0.0) v: 4.5 Mesa 19.2.6 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
           bus ID: 00:01.1 chip ID: 1002:15b3 
           Device-2: Advanced Micro Devices [AMD] Family 15h Audio vendor: Acer Incorporated ALI driver: snd_hda_intel 
           v: kernel bus ID: 00:09.2 chip ID: 1022:157a 
           Sound Server: ALSA v: k5.3.12-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI driver: r8169 
           v: kernel port: 2000 bus ID: 02:00.1 chip ID: 10ec:8168 
           IF: enp2s0f1 state: down mac: <filter> 
           Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Lite-On driver: ath10k_pci v: kernel 
           port: 2000 bus ID: 03:00.0 chip ID: 168c:0042 
           IF: wlp3s0 state: up mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 74.07 GiB (8.0%) 
           ID-1: /dev/sda vendor: Western Digital model: WD10SPZX-21Z10T0 size: 931.51 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 1A02 scheme: MBR 
Partition: ID-1: / raw size: 922.71 GiB size: 907.23 GiB (98.32%) used: 74.07 GiB (8.2%) fs: ext4 dev: /dev/sda1 
           ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap swappiness: 60 (default) cache pressure: 100 (default) 
           dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 34.8 C mobo: N/A gpu: amdgpu temp: 34 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 187 Uptime: 4m Memory: 7.31 GiB used: 1.05 GiB (14.4%) Init: systemd v: 242 Compilers: gcc: 9.2.0 
           Shell: bash v: 5.0.11 running in: konsole inxi: 3.0.36 

I have updated the system with pacman -Syyu and all went fine.
The second computer also updated correctly.

Updated in TTY no problem found.

Updated via Pamac and no issues whatsoever on XFCE, AMDGPU, Kernel 5.3.

XFCE, Kernel 414, I updated few minutes ago and all seems fine.
However, why we didn't received also these updates from 14 November 2019? [Unstable Update] 2019-11-14 - Python 3.8, ICU and Poppler rebuilds - BREAKAGE expected! and from today? [Testing Update] 2019-11-23 - Python 3.8, ICU and Poppler rebuilds - BREAKAGE expected! too many breakages? (I think that a lot of packages needs to be rebuilt, I think about python especially: on my system I have a lot of dependencies and sub-dependencies on python: i fear a mess about).
Well, on the stable branch, in facts, is ok to wait for major updates and fixes about, I'm ok with this :slight_smile:

No problems on 2 KDE machines, thank you.

1 Like

Edit: I resolved my issues. Update works fine; and in both kernels.

For me, the update got caught in an infinite loop and I had to shutdown. Upon reboot no kernel found (4.19 LTS and Nvidia 440xx). I had the 5.3 kernel installed, though it was unable to boot completely prior to update...(I think maybe a network issue--don't really know) anyway, I was able to open a TTY and roll back using Timeshift. Timeshift is awesome.

No problems on KDE machine.
Thank you.

1 Like

Updated KDE system with no issue. Thank you team Manjaro.

One question: does anyone know if it is safe to remove the "AMD_DEBUG=nongg,nodma" when using my rx 5700 xt or should i still keep these until later kernel/mesa?

Is there anything that needs to be changed in a config file or elsewhere for alpm-hook to be active?

No user action is required.

This is worrying

==> Image generation successful
(4/7) Updating Grub-Bootmenu
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.3-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-5.3-x86_64.img
Found initrd fallback image: /boot/initramfs-5.3-x86_64-fallback.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
**/usr/bin/grub-probe: warning: unknown device type nvme0n1.**

done

nvme0n1 is my OS drive.

You can ignore that message, see

3 Likes

I guess if they are updates from Unstable and Testing, then this is why we don't have them in Stable.

Manjaro team THANK YOU for including Dynamic Wallpaper Editor. I did not know it exist, now I am playing with it. Before I have to use some scripts to change wallpapers periodically! :heart_eyes:

5 Likes

The update caused no issues. Following the previous update, Nvivdia drivers version 435 are used to enable kernel 4.14 and 4.19 to boot. Can anyone confirm if with this update version 440 is compatible with 4.14 and 4.19.

Kind Regards.

Sudhir

I am running nVidia 440 with kernel 4.19 without any issues.

Update went fine. Updated via TTY on a Gnome install.

1 Like

Forum kindly sponsored by