[Stable Update] 2019-10-28 - Firefox, KDE Frameworks, KDE Plasma, LibreOffice, VirtualBox, Mesa

A post was split to a new topic: Problem after update on Plasma - desktop freeze, network frenzy

3 posts were split to a new topic: Key missing, can't update packages

Hibernate still broken on 5.3.

Snapper breaks with btrfs-progs, so I downgraded it.

Also the firefox breaks profiles, so I downgraded it for now.

1 Like

My Manjaro XFCE never started with the 5.3.
error with Lightdm

1 Like

I pushed a new firefox ...

15 Likes

This update is:

  1. Far from Stable

  2. Regressed in many areas, especially in regards to reliability, this links back to comment No.1

  3. Seems to have some great new features in the newer Manjaro KDE release, but, none of them seem to actually function properly, like the Night Colour mode/feature, it simply doesn't work, and, this is upgrading from a fresh install.....

  4. Needs a lot of work, bug fixing, and should really be set back to Unstable because it is NOT ready for prime time.

  5. Showing a clear need for more mature rounds and in-depth amounts of testing before a release is greenlit as Stable, if it isn't as reliable as the previous version that was in use before the update was installed then it shouldn't be pushed out, we should be working towards better reliability and stability.

I hope you can take value in my honest and constructive criticism.

11 Likes

I also found snapper breaks with btrfs-progs 5.3.1 provided by the Manjaro mirrors. However, btrfs-progs-git from the AUR works fine with snapper if you are like me and performed a fresh installation today preventing a downgrade from the pacman cache.

For maintainers reading, the specific error I get when running snapper --anything is:
snapper: symbol lookup error: /usr/lib/libbtrfs.so.0: undefined symbol: write_raid56_with_parity

The issue is known to btrfs-progs see here and here and seems to have already been fixed with 5.3.1 which is why I'm confused as to why its not working still.

1 Like

Night colour works fine for me. It looks as if someone had replaced the fluorescent tube in my laptop screen with a tungsten filament light. If you can't get it working, perhaps open a new thread about it... :man_shrugging:

2 Likes

So far so good. I have not been able to test alot because of a FreeNAS accident I hope I can recover my data. Anyway thanks for your hard work Manjaro you an awesome team of individuals coming together to make something truly great.

Other interesting Firefox issue is that it requires an html import on the backup yet saves in its' native
json format.

Select Import and Backup > Restore > Choose File and you can select the json backup.

I did not need to enter in terminal firefox --allow-downgrade with this latest Firefox push. Firefox opened normally after clicking the icon with no "create a new profile" warning.

Thank you for the quick turnaround!

2 Likes

i was trying to use paccheck from pacutils to verify my whole installation and i got the error:

paccheck: error while loading shared libraries: libalpm.so.11: cannot open shared object file: No such file or directory

i tried both:

sudo paccheck --md5sum --quiet
sudo paccheck --sha256sum --quiet

the same result

hint: i think i remember libalpm v12.0.0 being installed or updated. also pacman 5.2.0

1 Like

Maybe create a topic to troubleshoot.

Forgot to do the fix for Firefox before doing the upgrade, but was easily fixed.

2 posts were split to a new topic: problem copying files to the second user KDE

Got an orphan:

$ pacman -Qdt
kjsembed 5.63.0-1

Also, I thought I noticed this on testing, but I can definitely confirm on stable, the CPU Load Monitor plasmoid configuration was changed to show only overall load. I switched it back to show all four cores as well as the system load.

Hello, I updated two systems just now (an old Desktop PC and a new laptop). The laptop update went through just fine. The Desktop update though gives me a black screen on startup. If it's relevant I have nvidia graphics on the laptop and AMD graphcis on the desktop. What can I do to find out what the problem is with the Desktop PC?

Which desktop environment do you use and can you switch to a TTY? CTRL+ALT+F3

Forum kindly sponsored by