[Stable Update] 2019-10-28 - Firefox, KDE Frameworks, KDE Plasma, LibreOffice, VirtualBox, Mesa

Hello community,

I am happy to announce another Stable Update. Mostly we have updates for Juhraya 18.1.2 release.

Update news

This update holds the following changes:

  • For KDE fans we have more or less a double feature of Plasma. First we have the official Plasma 5.17.1 release. Then we updated our KDE-Dev packages to their latest git-snapshots.
  • KDE Frameworks is now at 5.63
  • LibreOffice got updated to 6.2.8
  • AMD FOSS drivers got renewed to 19.1.0
  • Firefox is now at 70.0
  • Virtualbox got updated to 6.0.14
  • We worked hard to get Pamac compatible with pacman 5.2
  • Octopi got patched by us to work with Pacman 5.2
  • Mesa is now at 19.2.2
  • Nvidia 440.26 driver got added to mhwd
  • Fixes for Intel within Xorg-Server
  • The usual updates and improvements and upstream package renewals
  • Manjaro 18.1.2 got released! Please test and give us feedback: gnome, kde, xfce
  • Latest efforts by KDE can be reviewed via our current KDE-Dev ISO or current KDE-Vanilla ISO

Give us the usual feedback and let us know what you think about this update.

Current supported Kernels

  • linux316 3.16.75
  • linux44 4.4.197 (no legacy nvidia-340 module!)
  • linux49 4.9.197
  • linux414 4.14.150
  • linux419 4.19.80
  • linux52 5.2.21 [EOL] (no catalyst module!)
  • linux53 5.3.7 (no catalyst module!)
  • linux54 5.4.0-rc4 (not all modules build yet!)
  • linux419-rt 4.19.72_rt26
  • linux52-rt 5.2.21_rt13

Package Changes (Sun Oct 27 11:38:57 CET 2019)

  • stable community x86_64: 992 new and 956 removed package(s)
  • stable core x86_64: 39 new and 41 removed package(s)
  • stable extra x86_64: 619 new and 759 removed package(s)
  • stable multilib x86_64: 23 new and 20 removed package(s)

A detail list of package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Firefox 70.0 wants to create a new profile

(Should not be needed anymore with firefox 70.0-1.1 .)

Since Manjaro sometimes updates packages before Arch does it might come in rare cases that Firefox wants to create a new profile. You can avoid that by starting Firefox once within a terminal the following way (see also here):

firefox --allow-downgrade

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.

xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.

Replace linux51 with community/linux-latest ?

linux51 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.

Pamac-Qt is not compatible to 9.0 API of Pamac


the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

unplugging secondary monitor doesn't update the screen on Plasma 5.17

Due to a regression in Plasma 5.17 (still not fixed) unplugging the secondary monitor doesn't trigger any reaction and Plasma still outputs the screen to the non-existing screen. The temporary workaround is to refresh monitor state manually with xrandr in the terminal, so, for example, we can run: xrandr -q to trigger the recognition that the secondary monitor is not there. The bug is already submitted, alas not much is happening with it at the moment:



Firefox update creates a new profile, so it is a good idea to export the bookmarks to HTML before.
All other updates went fine.


An inconvenience: Firefox created a new profile, says this version is older than the one previously running. Fortunately, I managed to sync most of the settings from another PC which I haven't yet updated (and probably won't before this is fixed).

And another thing: should I downgrade fontconfig ?


This Firefox thing really bugs me, i have in /var/cache/pacman/pkg/firefox*
21.10.2019 18:12 /var/cache/pacman/pkg/firefox-70.0-1-x86_64.pkg.tar.xz &
23.10.2019 13:41 /var/cache/pacman/pkg/firefox-70.0-0-x86_64.pkg.tar.xz,
and pacman.log says : [2019-10-28 13:38] [ALPM] upgraded firefox (70.0-0 -> 70.0-1)
but when i open firefox it is 70.0.0 and wanted to create new profile.


This is not an inconvenience but a big problem. Firefox never needed a new profile to run. I had 70.0 installed and running perfectly. But now the "new" version 70.0-1 needs a new profile? Why?

I have four different profiles and I do not want to reconfigure everything again.


For Firefox, to keep the old profile, run from terminal:
firefox --allow-downgrade


basically the same but well ¯_(ツ)_/¯


Same issue with Firefox on my side.

It says it updates FF to 70.0.1, but it doesn't.

Opening Firefox shows the dialog to create a new profile or quit because of old version. Still Firefox 70.0.0 in the repos (uninstalling/reinstalling Firefox).

1 Like

Does this have any influence on later updates? Does it just allow Firefox to continue with the old profile or will there be a problem with it later on?

I did this and I haven't had any problem. Still I don't understand why this happens if there's no real downgrade!

No problems at all.

Edited as the explanation was incomplete and misleading a bit:
The --allow-downgrade refers to the use an older profile created with a higher version of Firefox on a new Firefox installed to a version bellow, not the reverse.

If you don't have other devices running Firefox and you can't sync settings and bookmarks, then I can see it being a bit more than an inconvenience. A major pain in the butt, to be precise.

Luckily, in my case, it took about 15-20 minutes to restore everything. That's why I classified it as an inconvenience.


Most likely firefox-70.0-0 was using a newer snapshot of firefox as Arch with 70.0-1 had.

After the update, running firefox --version outputs "Mozilla Firefox 70.0"

However, package info in Pamac says "Firefox (firefox) 70.0-1":

1 Like

Firefox 70.0-0 was build by us and 70.0-1 by Arch. So I've to check why the same version is not the same version after all.


Modifier only shortcut for krunner stops working with Plasma 5.17. See https://bugs.kde.org/show_bug.cgi?id=413070 how to fix it.

So the problem is that firefox doesn't manage the upgrade of the profiles automatically?

the number after "-" is just a package versioning (internal to manjaro/arch) it does not have any relation with the software versioning.

it's Firefox 70.0 like as the package say..

the firefox xx.yy-0 are usually package built by manjaro for fast update on all branches. and later replaced/upgraded by the usual xx.yy-1 package coming from arch.


Forum kindly sponsored by