[Stable Update] 2019-09-05 - Kernels, Mesa 19.1.5, XFCE 4.14, KDE, Nvidia 435xx, LibreOffice

Hello community,

I am happy to announce another Stable Update. Mostly we have Manjaro 18.1-rc10, Nvidia and KDE updates

Update news

This update holds the following changes:

  • Manjaro 18.1-rc10 got released. Please test and give us feedback.
  • Most of our Kernels got updated. Note that linux50-rt got dropped and RT-Kernel 5.2 series added
  • Nvidia drivers got extended to 418xx, 430xx and 435xx series
  • Mesa is now at 19.1.5
  • OnlyOffice got added by the community. Find out more here
  • Palemoon is now at 28.7.0
  • KDE-dev package updates to reflect the lates changes made by the KDE Dev-Team.
  • KDE Frameworks ships in version 5.61
  • First release of KDE Apps 19.08 series
  • Fixes to our tools and Calamares
  • cdemu is now at 3.2.3
  • Updates to Vulkan and AMD Vulkan drivers
  • Thunderbird is now at 68 series. Read the troubleshoot guide for issues you may have with your beloved extensions
  • XFCE packages got renewed. We also added some meta-transition packages, which drop our gtk3-builds.
  • LibreOffice is now at 6.3.0 and 6.2.6
  • Nvidia is now at 435.21. For GPU offload instructions, please see here.
  • Haskell and Firefox got updated to their latest releases
  • VIM got newer spell-check packages
  • Updates to certbot and our steam clients
  • Systemd got some fixes for dbus
  • The usual upstream updates including python and perl
  • Latest efforts by KDE can be reviewed via our current KDE-Dev ISO or current KDE-Vanilla ISO
  • Manjaro Juhraya ISOs got updated, including flatpak and snap support pre-activated. Office can be selected during installation between libreoffice-still or freeoffice: XFCE, KDE, Gnome

Give us the usual feedback and let us know what you think about this update.


Current supported Kernels

  • linux316 3.16.73
  • linux44 4.4.190 (no legacy nvidia-340 module!)
  • linux49 4.9.190
  • linux414 4.14.141
  • linux419 4.19.69
  • linux51 5.1.21 [EOL]
  • linux52 5.2.11 (no catalyst module!)
  • linux53 5.3-rc7 (not all modules build yet!)
  • linux419-rt 4.19.50_rt22
  • linux52-rt 5.2.10_rt5-1

Package Updates (Tue Sep 3 01:21:53 CEST 2019)

  • stable community x86_64: 1720 new and 1737 removed package(s)
  • stable core x86_64: 56 new and 59 removed package(s)
  • stable extra x86_64: 1149 new and 1168 removed package(s)
  • stable multilib x86_64: 42 new and 39 removed package(s)

A list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

35 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed


Changes made to Grub 2.04-6

Due to some bugs with the Fedora patches in regard of BTRFS we are using now the Ubuntu approach to hide the menu via GRUB_TIMEOUT.

These are the current options to style the timeout:

GRUB_TIMEOUT_STYLE=countdown
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT_STYLE=menu

You may want to double-check your settings in /etc/default/grub

We also provide a new package called grub-vanilla. Learn more about it here.


Thunderbird 68.0 disabled my extensions!

Thunderbird 68 changes the way extensions work in line with Firefox 68. This will mean incompatible extensions are disabled.

The Thunderbird developers have made it as easy as possible for extensions developers to update the extensions to get them working again.

However, it will take time for extensions to 1) be updated and 2) make their way onto AMO for download.

You have two basic choices:

  1. Add IgnorePkg = thunderbird to your /etc/pacman.conf until your "critical" extension is updated
  2. Keep checking for updates for your "critical" extension, and possibly pester the developer to update it

Option 2 is the more proactive.


pip behaves differently

Update: if you have issues and you don't want to help test things then just downgrade to 19.0.3:

sudo pacman -Syu python-pip python2-pip

With the 19.2.3-1.0 package, pip now includes by default the --user flag for all operations. 19.2.3-1.2 offers some fixes when using venv.

To revert to "normal" behaviour simply edit or remove /etc/pip.conf to remove user=yes.


Asian/CJK characters display as blocks

Install noto-fonts-cjk or another font of your choice. The problem seems related to a ttf-droid update.

https://bugs.archlinux.org/task/63205


libbloom>=1.6-2 update requires manual intervention

(Taken from Arch Linux website, 2019-07-11 by Felix Yan. Source: https://www.archlinux.org/news/libbloom16-2-update-requires-manual-intervention/)

The libbloom package prior to version 1.6-2 was missing a soname link. This has been fixed in 1.6-2, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libbloom: /usr/lib/libbloom.so.1 exists in filesystem

when updating, use

pacman -Suy --overwrite usr/lib/libbloom.so.1

to perform the upgrade.

tensorflow>=1.14.0-5 update requires manual intervention

From Konstantin Gizdov on August 20, 2019

The tensorflow packages prior to version 1.14.0-5 were missing some soname links. This has been fixed in 1.14.0-5, so the upgrade will need to overwrite the untracked soname links created by ldconfig. If you get an errors like so.

tensorflow: /usr/lib/libtensorflow.so.1 exists in filesystem
tensorflow: /usr/lib/libtensorflow_cc.so.1 exists in filesystem
tensorflow: /usr/lib/libtensorflow_framework.so.1 exists in filesystem

when updating, use

pacman -Suy --overwrite=usr/lib/libtensorflow.so.1,usr/lib/libtensorflow_cc.so.1,usr/lib/libtensorflow_framework.so.1

to perform the upgrade.

2 Likes

Huge update without issue. woohoo

P.S. some conky bug https://github.com/brndnmtthws/conky/issues/877 which is not related to Manjaro.

1 Like

No issues to report on all five machines. As always great job & thanks team manjaro.

Btw.. I use netzspielplatz .. works great :smile:

regards

Seems fine so far, but there was one error message:

[ALPM-SCRIPTLET] Unable to open directory usr/lib32/gio/modules: Fehler beim Öffnen des Ordners »usr/lib32/gio/modules«: Datei oder Verzeichnis nicht gefunden

No clue, but could it be that there is a / missing, like

/usr/lib32/...

instead of

usr/lib32/...

[edit]
I just found out that this error was already talked about in [Testing Update] 2019-08-23. steam-manjaro 1.0.0.61-5 doesn't seem to fix the problem.
No big deal for me. It just reminded me about the fact, that I have steam installed, even though I don't have any need for it. Uninstalled...
[/edit]

1 Like

Upgraded today, noticed some things:

  1. I don't have Nvidia card, but upgrade installed 3 x mhwd-nvidia packages. But I guess it's expected because these packages are a part of mhwd?

  2. Python was broken. Badly. I run one Python script (Rummage) on my system and after upgrade it didn't start because of many "resource not found" errors. I had to uninstall script, force reinstallations of python, pip, setuptools, wxpython and other modules. Then even pip was broken, so I had to uninstall and re-install it again. It worked, but Python script still didn't work. After one hour of re-installations I was finally able to fix it by re-installing wxpython via pip command line (doing so via pacman command line didn't work). It still ended with tons of build errors, but at least Python and its scripts work now, so I will leave everything as it is.

  3. I don't know if this upgrade caused it (or previous update did it earlier), but my .local/share/kservices5/ directory is gone. I know it existed before because I manually added some Dolphin service menus into it as per https://techbase.kde.org/Development/Tutorials/Creating_Konqueror_Service_Menus
    Now kf5-config --path services still returns .local/share/kservices5/ as my directory for service menus, but the directory doesn't exist. All previously added service menus still work in Dolphin, but I guess they won't work if I re-build service menus, so I'm not touching it.

1 Like

The only Thunderbird extension that died ded for me was FireTray - and I knew that was coming, since FIreTray was a dead project.

For those wanting hide-in-tray functionality, there's BirdTray, which is not an extension so it's not as likely to die with the meanderings of the Thunderbird API. It's on the AUR.

Everything else about this update was a sail across a glassy smooth lake.:blush:

1 Like

Smoooth

I've not yet applied this Stable Update to my Stable Lappy, but fwiw for my Testing Tower... as usual Testing branch has had several updates before this new Stable update occurred. None of those Testing updates did to me what you wrote; my /home/kdemeoz/.local/share/kservices5/ServiceMenus & its contents continues to exist & work just fine. Given what comes into Stable comes from Testing, i thought you might like to know of this.

No issues from the update,

expect Thunderbird breaking my theme.. :frowning:

Nvidia user here, updated from TTY, all good! Thanks for all the hard work! :relaxed:

The update had a size of 950MB.
I found a small problem: the update of console (bash) went into a white screen without characters.
Restarting the terminal corrects the problem.

Thanks!

My OS doesn't show any update. Is it normal?

Maybe your mirror hasn't synced yet.

 sudo pacman-mirrors --fasttrack

Update went fine on 2 differrent machines. Thanks for your work.

1 Like

i have the error message too but all went fine

1 Like

Those packages only ships a file that contains information for MHWD. There is no actual driver in it.

More specifically, it is a file that contains a list of devices that are considered compatible with a particular option. MHWD use it to know if it should offer you that option or not depending on your hardware.

2 Likes

Thanks for the update - no issues with the packages themselves, just a minor problem with Octopi/Pacman showing an empty "Outdated Version" column.

Only ever used stable and Octopi - so checking pacman -Ss wine also was showing the same package version. :confused:

multilib/wine 4.13-1 [installed]

Running sudo pacman -Syu revealed it needed to update archlinux-keyring-20190827-1 first and after a refresh in Octopi, sure enough, the package versions appeared:

multilib/wine 4.15-1 [installed: 4.13-1]

Likely not a fault of this update, but thought I'd mention as it confused me.

Thanks, it looks like it helped!

1 Like

Forum kindly sponsored by Bytemark