[Stable Update] 2019-08-13 - Kernels, XFCE 4.14, KDE, LibreOffice 6.3, Discord, Mesa

Hello community,

I am happy to announce another Stable Update. Mostly we have XFCE 4.14, LibreOffice 6.3 and Kernel updates with this one.

Update news

This update holds the following changes:

  • Most of the Kernels got updated to minigate CVE-2019-1125 “SWAPGS”
  • XFCE got updated to 4.14
  • Plasma got updated to version 5.16.4
  • Deepin got updated to version 5.0. For more details you can find here.
  • LibreOffice is now at 6.3.0
  • Mesa is now at 19.1.4
  • fpakman got some nice updates. We will rename it to bauh with the next update
  • Discord is now part of our official repositories
  • Lazarus IDE is now at 2.0.4
  • Kodi got some updated addons
  • Gimp got updated help files
  • We worked with upstream on a new package-selction-tool for Calamares
  • Certbot is now at 0.37.0
  • KDE-Git packages got updated to their latest git-commits
  • Pamac supports now to build packages from Web-URL links
  • libinput is now at 1.14.0
  • Latest python, haskell and upstream updates
  • Latest efforts by KDE can be reviewed via our current KDE-Dev ISO or current KDE-Vanilla ISO
  • Manjaro Juhraya ISOs got updated, including flatpak and snap support pre-activated. Office can be selected during installation between libreoffice-still or freeoffice: XFCE, KDE, Gnome

Give us the usual feedback and let us know what you think about this update.

Current supported Kernels

  • linux316 3.16.70
  • linux44 4.4.189 (no legacy nvidia-340 module!)
  • linux49 4.9.189
  • linux414 4.14.138
  • linux419 4.19.66
  • linux51 5.1.21 [EOL]
  • linux52 5.2.8 (no catalyst module!)
  • linux53 5.3-rc4 (not all modules build yet!)
  • linux419-rt 4.19.50_rt22
  • linux50-rt 5.0.21_rt16

Package Updates (Mon Aug 12 07:23:23 CEST 2019)

  • stable community x86_64: 1241 new and 1213 removed package(s)
  • stable core x86_64: 33 new and 33 removed package(s)
  • stable extra x86_64: 447 new and 341 removed package(s)
  • stable multilib x86_64: 20 new and 19 removed package(s)

A list of all package updates may be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Pango doesn't support bitmap fonts anymore

Applications that use Pango and that are configured to use bitmap fonts now only show rectangles instead of characters. This affects popular terminal emulator setups, because many people use fonts like Terminus in applications like GNOME Terminal. We recommend to switch fonts or downgrade pango.

Asian/CJK characters display as blocks

Install noto-fonts-cjk or another font of your choice. The problem seems related to a ttf-droid update.


libbloom>=1.6-2 update requires manual intervention

(Taken from Arch Linux website, 2019-07-11 by Felix Yan. Source: https://www.archlinux.org/news/libbloom16-2-update-requires-manual-intervention/)

The libbloom package prior to version 1.6-2 was missing a soname link. This has been fixed in 1.6-2, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libbloom: /usr/lib/libbloom.so.1 exists in filesystem

when updating, use

pacman -Suy --overwrite /usr/lib/libbloom.so.1

to perform the upgrade.

Items from previous update sets

File conflict: "snapd: /snap already exists in filesystem"

If you have this file conflict, we recommend to use the command-line interface for this time and use the --overwrite option. In a command-line interface, use the following command or any equivalent of your choice:

sudo pacman -Syu --overwrite '/snap' 

Warning: audit: directory permissions differ on /var/log/audit/filesystem: 755 package: 700

Execute sudo chmod 700 /var/log/audit/ in terminal

mariadb 10.4.x update requires manual intervention

(Source: https://www.archlinux.org/news/mariadb-104x-update-requires-manual-intervention/ , 2019-06-27, by Christian Hesse)

The update to mariadb 10.4.6-1 and later changes configuration layout as recommended by upstream.

The main configuration file moved from /etc/mysql/my.cnf (and its include directory /etc/mysql/my.cnf.d/ ) to /etc/my.cnf (and /etc/my.cnf.d/ ). Make sure to move your configuration.

Instantiated services (like mariadb@foo.service ) are no longer configured in separate files (like /etc/mysql/myfoo.cnf ). Instead move your configuration to configuration blocks with group suffix in main configuration file, one for each service. A block should look something like this:

datadir = /var/lib/mysql-foo
socket = /run/mysqld/mysqld-foo.sock

Like every mariadb feature update this requires the data directory to be updated. With the new configuration in place run:

systemctl restart mariadb.service && mariadb-upgrade -u root -p

Some KDE System Settings may have been reset to their defaults

  • System Settings > Input Devices > Touchpad > Tap-to-click
  • Scrolling
  • The compositor could get disabled during the upgrade which will stop all of the KDE eye-candy
  • (Font-)Hinting could get reset to none

XFCE 4.14-pre2 : I do not see XFCE 4.14-pre2 in the repositories!?

You won't see explicitly 4.14-pre2 anywhere on our xfce-gtk3 packages. We follow the versioning used by upstream. Here's the list of all components that are part of XFCE 4.14-pre2.

Kvantum theme reset

If you are using the Matcha theme in kvantum you may experience a theme reset. Simply install kvantum-theme-matcha if not happend yet and select the new provided variants. Manjaro 18.1 releases will ship with the new themes by default.

Issues with Octopi

Currently several users report different issues for Octopi. So if you encounter some of them, you may switch to pamac for now: sudo pacman -Syu pamac

(Note that sudo pacman -Syu pamac will both install Pamac and upgrade all upgradable packages on your system at the same time.)

Issues with DisplayCAL

DisplayCAL - Missing python2-dbus causes failure to launch application.

Solution - Install the python2-dbus package for now. Version 3.8.2 fixes the dependency error. As and when DisplayCAL 3.8.2 reaches stable branch you can remove python2-dbus as it does not require it. Only remove python2-dbus again if you installed it specifically for DisplayCAL.

Regression with Linux firmwares on machine running Vega GPUs.

June 2, 2019: We expect it to be fixed with linux-firmware 20190514-711d329-1.1. We downgraded the firmware related to Vega GPUs to a previous version. You should now be able to use Linux 4.19 correctly.

[Stable Update] 2019-05-26 - Kernels, XFCE 4.14-pre1, Virtualbox, LibreOffice

linux-firmware 20190514-711d329-1 introduced a regression that can make the system unbootable on systems that use a AMD Vega GPUs (for example: Vega 64, Vega 56, Vega 10) and Linux 4.19.

It is a regression that affects both Manjaro and Arch Linux. Here's some links.

Arch Linux bugtracker: https://bugs.archlinux.org/task/62666
Manjaro forum: Most recent stable branch update problem
Manjaro forum: Manjaro update prevents system booting
Manjaro forum: 'linux-firmware 20190514.711d329-1' update prevents my system booting.

If you are affected by this issue, you have essentially two choices: either use a different kernel or downgrade linux-firmware. The most preferred method is the first one since it doesn't involve keeping a package to an older version. Either way, if your system is completely unbootable (not even with a command line interface), you will need to do a chroot to repair your system. For each solution suggested below, we will suppose that you need to do a chroot; skip the chroot part if you manage to reach an usable command line interface.

For the first solution, as far as we know, it works fine on Linux 5.1 and supposedly also on Linux 5.0. Follow these steps in order to be able to install a new kernel:

  • Launch a live session with an installation medium;
  • Open a terminal;
  • Chroot your system. You may do so automatically with manjaro-chroot -a. On more complex system where manjaro-chroot may simply fail, you may have to do a manual chroot.;
  • Once you have chrooted on your system, use mhwd-kernel -i linux51 to install Linux 5.1 and all extra modules needed for your system. You may also try with Linux 5.0 (replace linux51 with linux50), although Linux 5.0 is expected to be End of Life soon.

(If you have multiple kernels installed on your machine, you may want to boot with other kernels before trying to install a new one.)

For the second one:

  • Chroot to your system from a live session;
  • Downgrade the linux-firmware package to version 20190424.4b6cf2b-1 with pacman -U /var/cache/pacman/pkg/linux-firmware-20190424.4b6cf2b-1-any.pkg.tar.xz. If the package is not available in your local cache, use pacman -U https://archive.archlinux.org/packages/l/linux-firmware/linux-firmware-20190424.4b6cf2b-1-any.pkg.tar.xz instead.

(Note that if you know how to use downgrade, you may also use downgrade.)
(Remember that downgrading a package is merely a temporary solution, do not hold the package to a previous version forever.)

signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is marginal trust

Update manjaro-keyring first. For more options read this thread:

Issues with "signature is marginal trust" or "invalid or corrupted package"

replace steam-devices with community/game-devices-udev?

Yes. The package name changed. Accept the replacement.


The update itself worked without any problem, but I had to restart the computer using "reboot" on console.


Better update of ever XFCE 4.14 ^^

I had to remove "throttled" first, before being able to update.


throttled: /usr/lib/throttled/__pycache__/mmio.cpython-37.pyc already exists

When I try to reinstall throttled afterwards, I get the same error and throttled cant be installed anymore.

Use the --overwrite function of pacman similar to libbloom troubleshooting notice.

1 Like

I have the following error:

installing java-openjfx (11.0.3.u1-1) breaks dependency 'java-openjfx<9' required by jabref

How should I proceed? Remove Jabref and then find a way to reinstall it?

1 Like

sudo pacman -Syu java8-openjfx

Thank you, do you mind telling me what this does? It will update the system but not update java?

It’ll install the java8 version of openjfx which your app needs and update the system.

1 Like


The update of another computer worked without any problem.

Updated without any issues from TTY with pacman on Cinnamon DE, kernel 5.2, Intel video. Thanks!

2 posts were split to a new topic: xfce4-display-settings crashes after stable update (2019-08-13)

The update worked fine, thank you!

However on my XFCE-Desktop, I noted a white vertical line in the task bar. It seems to cut the remaining space of the bar into to equal parts. Does anyone know what it's good for?

I did not see this line with the 4.14-pre versions of XFCE.

Screenshot can be provided, if helpful.

Updated from tty and everything went well. Actually all issues from previous update gone and fixed.

It might be a separator in your Panel. It can be used to spread different items out in your Panel. Make a right click on it and choose properties. You can switch the style to "Transparent" if you like.

1 Like

XFCE. Updated from tty no issues.

Mine is in the middle of the upgrade at the moment. However, it looks like the download of linux419-4.19.66-1-x86_64.pkg.tar.xz failed partway through.

not sure what to do with this:-

(159/159) checking for file conflicts                                                                             [####################################################################] 100%
error: failed to commit transaction (conflicting files)
python-future: /usr/bin/futurize exists in filesystem
python-future: /usr/bin/pasteurize exists in filesystem
Errors occurred, no packages were upgraded.
Error installing repo packages

Forum kindly sponsored by Bytemark