[Stable Update] 2019-07-25 - Kernels, Systemd, Virtualbox, Mesa, KDE-Git, Pamac-Qt

pdimens
I experienced the same problem with Plasma DE. I ended up booting into RL3 and reinstalling Grub. It seems to have solved it.
Regards & hope this helps.

Upgrade went without issues. Thanks team!

Everything went well, Plasma, 4.19LTS + Nvidia 340.xxx, Thanks Manjaro team!

1 Like

I use rEFInd and don't have GRUB on the system. I can try booting into RL3. Thanks.

after update my wifi does not work (kernel 52)
Network: Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi

after go back to 4.19 wifi is ok

A small fix update ...

### BoxIt memo ###

User philip created a snapshot of branch 'testing' to 'stable'.

 - stable community x86_64:  2 new and 0 removed package(s)
 - stable extra x86_64:  4 new and 4 removed package(s)

:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-07-25           2019-07-26
-------------------------------------------------------------------------------
                             fpakman                    -              0.4.1-1
                             uranium                    -            4.1.0-2.1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-07-25           2019-07-26
-------------------------------------------------------------------------------
                         thunar-gtk3              1.8.8-1              1.8.8-2
                    xfce4-panel-gtk3             4.13.6-2             4.13.6-4
                  xfce4-session-gtk3             4.13.3-9            4.13.3-10
                 xfce4-settings-gtk3             4.13.7-8             4.13.7-9

After update 25/07 in manjaro gnome no connection Ethernet/WiFi I have dell e6440 I'm running in kernel 5.2.2 and 4.19.60 LTS same issue I see this in log
[ 85.654253] iwlwifi 0000:03:00.0: Not sending command - RF KILL
[ 85.654255] wlp3s0: failed to remove key (2, ff:ff:ff:ff:ff:ff) from hardware (-5)
But after in verify rfkill is no for all!
More log here :

There were some firmware updates lately, which broke the connection. Please downgrade to the older version. We will check.

Thanks for your response

Without connection internet how I can download the downgrade version? I search in archlinux reposity and other from my phone I no find ...

$ ls /var/cache/pacman/pkg/linux-firmware*
/var/cache/pacman/pkg/linux-firmware-20190424.4b6cf2b-1-any.pkg.tar.xz
/var/cache/pacman/pkg/linux-firmware-20190514.711d329-1-any.pkg.tar.xz
/var/cache/pacman/pkg/linux-firmware-20190514.711d329-1.1-any.pkg.tar.xz
/var/cache/pacman/pkg/linux-firmware-20190717.bf13a71-1-any.pkg.tar.xz

Most likely via: sudo pacman -U /var/cache/pacman/pkg/linux-firmware-20190514.711d329-1.1-any.pkg.tar.xz

Currently I'm trying with another update.

2 Likes

Thanks !I have recopied that , if in futur update I have some error I will try that

After downgrade to linux-firmware-20190514 I have same issue after reboot !!!

downgrade network manager also

Check the pacman.log on which packages you had updated. Try to downgrade to the previous versions as needed.

tac /var/log/pacman.log | less

Log is empty in pacman.log I will downgrade manually all package after check manually from list update in this thread what package I have installed ...

Empty list is odd. Here is an example output of a regular upgrade:

$ pamac upgrade
==== AUTHENTICATING FOR org.manjaro.pamac.commit ====
Authentication is required
Authenticating as: Test User (user)
Password: 
==== AUTHENTICATION COMPLETE ====
Synchronizing package databases...
Starting full system upgrade...
Warning: linux316: local (3.16.71-1) is newer than core (3.16.70-1)
Warning: linux316-headers: local (3.16.71-1) is newer than core (3.16.70-1)
Warning: linux419: local (4.19.61-1) is newer than core (4.19.60-1)
Warning: linux419-headers: local (4.19.61-1) is newer than core (4.19.60-1)
Warning: linux51: local (5.1.20-1) is newer than core (5.1.19-1)
Warning: linux51-headers: local (5.1.20-1) is newer than core (5.1.19-1)
Resolving dependencies...
Checking inter-conflicts...
To upgrade (37):
  android-tools              9.0.0_r45-1           (9.0.0_r41-1)           community  
  aom                        1.0.0.errata1-1       (1.0.0-1)               extra      
  blender                    17:2.80rc2-1          (17:2.80rc1-2)          community  
  clang                      8.0.1-1               (8.0.0-4)               extra      
  compiler-rt                8.0.1-1               (8.0.0-1)               extra      
  firefox-developer-edition  69.0b7-1              (69.0b6-1)              community  
  firewalld                  0.7.1-1               (0.7.0-1)               community  
  jdk-openjdk                12.0.2.u10-1          (12.0.1.u12-1)          extra      
  jre-openjdk                12.0.2.u10-1          (12.0.1.u12-1)          extra      
  jre-openjdk-headless       12.0.2.u10-1          (12.0.1.u12-1)          extra      
  lib32-llvm-libs            8.0.1-1               (8.0.0-1)               multilib   
  lib32-mesa                 19.1.3-1              (19.1.2-1)              multilib   
  lib32-zstd                 1.4.1-1               (1.4.0-1)               multilib   
  libnm                      1.18.2-1              (1.18.0-1)              extra      
  libnm-glib                 1.18.2-1              (1.18.0-1)              extra      
  libphonenumber             8.10.15-1             (8.10.13-1)             extra      
  libtasn1                   4.14-1                (4.13-1)                core       
  libtool                    2.4.6+42+gb88cebd5-5  (2.4.6+42+gb88cebd5-4)  core       
  linux-firmware             20190717.bf13a71-1    (20190514.711d329-1.1)  core       
  llvm-libs                  8.0.1-1               (8.0.0-2)               extra      
  lxc                        1:3.2.1-1             (1:3.1.0-2)             community  
  mesa                       19.1.3-1              (19.1.2-1)              extra      
  networkmanager             1.18.2-1              (1.18.0-1)              extra      
  npm                        6.10.2-1              (6.10.1-1)              community  
  palemoon-bin               28.6.1-1              (28.6.0.1-1)            community  
  pkgconf                    1.6.3-1               (1.6.1-1)               core       
  python-mako                1.0.14-1              (1.0.13-1)              extra      
  python-shiboken2           5.13.0-4              (5.13.0-3)              extra      
  python-sqlalchemy          1.3.6-1               (1.3.5-1)               community  
  qt5-imageformats           5.13.0-2              (5.13.0-1)              extra      
  qt5-tools                  5.13.0-2              (5.13.0-1)              extra      
  semver                     6.3.0-1               (6.2.0-1)               community  
  thunar-gtk3                1.8.8-2               (1.8.8-1)               extra      
  xfce4-panel-gtk3           4.13.6-4              (4.13.6-2)              extra      
  xfce4-session-gtk3         4.13.3-10             (4.13.3-9)              extra      
  xfce4-settings-gtk3        4.13.7-9              (4.13.7-8)              extra      
  zstd                       1.4.1-1               (1.4.0-1)               core       

Total installed size: 22.6 MB
Apply transaction ? [y/N] y
Checking keyring...                                                                [37/37]
Checking integrity...                                                              [37/37]
Loading packages files...                                                          [37/37]
Checking file conflicts...                                                         [37/37]
Checking available disk space...                                                   [37/37]
Running pre-transaction hooks...
Remove Firefox Distribution Settings                                                 [1/1]
Upgrading android-tools (9.0.0_r41-1 -> 9.0.0_r45-1)...                             [1/37]
Upgrading aom (1.0.0-1 -> 1.0.0.errata1-1)...                                       [2/37]
Upgrading llvm-libs (8.0.0-2 -> 8.0.1-1)...                                         [3/37]
Upgrading mesa (19.1.2-1 -> 19.1.3-1)...                                            [4/37]
Upgrading libtasn1 (4.13-1 -> 4.14-1)...                                            [5/37]
Upgrading zstd (1.4.0-1 -> 1.4.1-1)...                                              [6/37]
Upgrading blender (17:2.80rc1-2 -> 17:2.80rc2-1)...                                 [7/37]
Upgrading compiler-rt (8.0.0-1 -> 8.0.1-1)...                                       [8/37]
Upgrading clang (8.0.0-4 -> 8.0.1-1)...                                             [9/37]
Upgrading libtool (2.4.6+42+gb88cebd5-4 -> 2.4.6+42+gb88cebd5-5)...                [10/37]
Upgrading firefox-developer-edition (69.0b6-1 -> 69.0b7-1)...                      [11/37]
Upgrading firewalld (0.7.0-1 -> 0.7.1-1)...                                        [12/37]
Upgrading jre-openjdk-headless (12.0.1.u12-1 -> 12.0.2.u10-1)...                   [13/37]
Upgrading jre-openjdk (12.0.1.u12-1 -> 12.0.2.u10-1)...                            [14/37]
Upgrading jdk-openjdk (12.0.1.u12-1 -> 12.0.2.u10-1)...                            [15/37]
Upgrading lib32-llvm-libs (8.0.0-1 -> 8.0.1-1)...                                  [16/37]
Upgrading lib32-mesa (19.1.2-1 -> 19.1.3-1)...                                     [17/37]
Upgrading lib32-zstd (1.4.0-1 -> 1.4.1-1)...                                       [18/37]
Upgrading libnm (1.18.0-1 -> 1.18.2-1)...                                          [19/37]
Upgrading libnm-glib (1.18.0-1 -> 1.18.2-1)...                                     [20/37]
Upgrading libphonenumber (8.10.13-1 -> 8.10.15-1)...                               [21/37]
Upgrading linux-firmware (20190514.711d329-1.1 -> 20190717.bf13a71-1)...           [22/37]
Upgrading lxc (1:3.1.0-2 -> 1:3.2.1-1)...                                          [23/37]
Upgrading networkmanager (1.18.0-1 -> 1.18.2-1)...                                 [24/37]
Upgrading semver (6.2.0-1 -> 6.3.0-1)...                                           [25/37]
Upgrading npm (6.10.1-1 -> 6.10.2-1)...                                            [26/37]
Upgrading palemoon-bin (28.6.0.1-1 -> 28.6.1-1)...                                 [27/37]
Upgrading pkgconf (1.6.1-1 -> 1.6.3-1)...                                          [28/37]
Upgrading python-mako (1.0.13-1 -> 1.0.14-1)...                                    [29/37]
Upgrading python-shiboken2 (5.13.0-3 -> 5.13.0-4)...                               [30/37]
Upgrading python-sqlalchemy (1.3.5-1 -> 1.3.6-1)...                                [31/37]
Upgrading qt5-imageformats (5.13.0-1 -> 5.13.0-2)...                               [32/37]
Upgrading qt5-tools (5.13.0-1 -> 5.13.0-2)...                                      [33/37]
Upgrading thunar-gtk3 (1.8.8-1 -> 1.8.8-2)...                                      [34/37]
Upgrading xfce4-panel-gtk3 (4.13.6-2 -> 4.13.6-4)...                               [35/37]
Upgrading xfce4-session-gtk3 (4.13.3-9 -> 4.13.3-10)...                            [36/37]
Upgrading xfce4-settings-gtk3 (4.13.7-8 -> 4.13.7-9)...                            [37/37]
Running post-transaction hooks...
Copy Firefox Distribution Settings                                                   [1/9]
Compiling GSettings XML schema files...                                              [2/9]
Updating icon theme caches...                                                        [3/9]
Reloading system manager configuration...                                            [4/9]
Creating temporary files...                                                          [5/9]
Reloading device manager configuration...                                            [6/9]
Arming ConditionNeedsUpdate...                                                       [7/9]
Updating the info directory file...                                                  [8/9]
Updating the desktop file MIME type cache...                                         [9/9]
Transaction successfully finished.

i have a dual title bar on firefox stable since this update using manjaro KDE, the setting "hide titlebar" in firefox and in plasma custom rules do not works anymore :face_with_raised_eyebrow:

Urx82WR

check if you have server side decoration on in kde kwin scripts

ok i have found the problem, i was using "match window class name" which don't works anymore i have set it to "Window title" instead and it works.

2 Likes

No problem. Please post what you find and your resolution. Re installing Grub didnt help anything with one of my machines. Problem returned today on the first boot. Interestingly, another distro boots just fine without problems. The boot screen is something pretty basic in the OS. I have already put another of my production machines through this update and so far no problem with but again this is pretty basic stuff to have working. Or not.

Forum kindly sponsored by Bytemark