[Stable Update] 2019-07-17 - Kernels, KDE, Browsers, Systemd, Octopi, LibreOffice

recently there was ttf-droid update(small version bump).Did it change anything?

The newest ttf-droid update was for a priority problem that conflicted with other fonts. I do not know if it also the fixed the square boxes problem since I could not recreate that issue on my end.

gotcha

No, ttf-droid still doesn't work, I still see just squares

Hallo,
I've got this

"Error: Could not perform the operation (conflicting files)
snapd: /snap exists in the file system
Errors have occurred, no packages have been updated.
No database errors were found!"

Do I habve do remove snapd before? It would be nice, if you cpuld help me.

greetz, enzo

From Known issues and solutions wiki

2 Likes

After last update KDE Settings are broken. I can only open KDE settings window and see the options in the left pane. But if I click on any of the option on the left pane the whole application crashes. That means that currently I cannot change KDE configurations.

Me too in one VM.
On my real system "KDE settings" works.

Blender also has the "already exists in filesystem" problem.

Instead of using the "--overwrite" flag, I set it to ignore in /etc/pacman.conf for now, since I don't want to upgrade 2.79 to 2.80 release candidate 1. (A little annoying that it would upgrade before an actual release.)

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
IgnorePkg = blender
#IgnoreGroup =

Note that this isn't a solution for libraries or programs which are dependencies of other programs, as ignoring packages will prevent upgrades of those other packages.

Pacman will remind you that you're ignoring it, if there are upgrades available for the packages you've listed in /etc/pacman.conf

Upstream released another update. Please check if the logout-dialog is now themed even without our workaround:

pamac upgrade
rm -v ~/.cache/sessions/*
cp /etc/skel/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml ~/.config/xfce4/xfconf/xfce-perchannel-xml/

1 Like

Yes, logout-dialog is now themed.

1 Like

I believe I found the cause for the panel and desktop loading slowly on existing profiles, while not on new ones.

The default process order for loading the Xfce desktop is xfwm4 followed by xfsettingsd.
With the new changes, the desktop will not continue to load until xfsettingsd has finished. By default this is fine, as it is loaded right after the compositor.

If you are using the default compositor, you can reset these settings with the following, and the issue should be fixed:

xfconf-query -c xfce4-session -p /sessions/Failsafe/Client0_Command -r
xfconf-query -c xfce4-session -p /sessions/Failsafe/Client1_Command -r

However, if you have ever used a different compositor, your process load order will not be default. The compiz-manjaro package, for example, includes a script which sets Client0_Command to compiz. This results in the delay, as xfsettingsd needs to start before compiz, but does not get executed right away.

If you are using compiz, you can fix this with the following:

xfconf-query -c xfce4-session -p /sessions/Failsafe/Client0_Command -a -s xfsettingsd
xfconf-query -c xfce4-session -p /sessions/Failsafe/Client1_Command -a -s compiz



@philm
The following changes need to be made to the compiz-manjaro package:

Line 3 in compiz-xfce-autostart-setup needs to be changed to the following:

xfconf-query -c xfce4-session -p /sessions/Failsafe/Client0_Command -a -s xfsettingsd
xfconf-query -c xfce4-session -p /sessions/Failsafe/Client1_Command -a -s compiz

Line 5 in compiz-xfce-uninstall-helper needs to be changed to the following:

xfconf-query -c xfce4-session -p /sessions/Failsafe/Client0_Command -r
xfconf-query -c xfce4-session -p /sessions/Failsafe/Client1_Command -r

I have not checked if changes need to be made for people using compton, but I suspect something similar may be required.

1 Like

Mine is so broken that I can't open sessions as simple as look and feel. Everything is broken and makes the application crash.
Can anyone help me, please?

  1. Restore your backup
    No Backup =
  2. New topic

blackmagic intensity pro 4k is not detected under kernel 5.2, but works fine with 5.1

@redL1nE_87 maybe this might help: IntelHD Tearing

When I updated my computer, the load are very high. I can't work on my PC.

Please create separate tread for your issue

1 Like

In my case it turned out that there was /usr/local/bin/bsdcpio (no idea how that got there) which still relied on libnettle.so.6 taking precedence over /usr/bin/bsdcpio from the libarchive package, removing /usr/local/bin/bsd* solves the issue completely.

pacman could have told you:

$ pacman -Fo /usr/local/bin/bsdcpio

Forum kindly sponsored by Bytemark