[Stable Update] 2019-07-09 - Qt5, Cinnamon, XFCE, Deepin, Palemoon, Firefox

Mostly looking good, but the package-manager seems to have a strange bug where AUR packages are concerned.

I needed to reinstall a couple of Perl modules due to the updated version of Perl. So I opened pamac-manager, selected the modules to rebuild and attempted to rebuild them. When the password dialogue popped up, it vanished a couple of seconds later, before I could type my password. The pamac-manager then became unresponsive and had to be killed using xkill.

This behaviour occurs every time I try to reinstall anything from AUR. There is, however, a workaround:

First select a package from the Manjaro repo to install. Then follow the process through putting in the password but cancel the install before it actually happens. Now select the AUR package and it can be installed without the password dialogue popping up.

UPDATE: seems an even deeper problem with pamac-manager and AUR. After rebooting, I got an alert that perl-mojolicious needed updating from AUR.

  • Opened pamac-manager from a terminal.
  • Clicked "updates".
  • Hit "apply".
  • Password dialogue opened and did stay open so I could enter my password.
  • Status display got as far as "Checking perl-mojolicious dependencies..."
  • Transaction Summary opens.
  • Clicked "Apply". GUI hung.
  • After 10-20 seconds, got message on terminal: "trans_release: Timeout was reached".
  • After another 10-20 seconds, the Transaction Summary closed.
  • GUI Still unresponsive and cannot be closed by clicking (X)
  • Some time later, terminal gives message "start_get_authorization: Timeout was reached".
    So pamac-manager definitely now has problems with AUR.

errors when updating grub -> only an entry for my main manjaro and other ignored.
I did an update-grub manually and all the entries came back

https://wiki.archlinux.org/index.php/pacman#Skip_package_from_being_upgraded

Heed the warnings.

Have you checked that the look and feel of Snap apps are correct? Recently I tried Spotify from Snap, and the mouse cursor was wrong. Same for any other Snap apps I tried, in fact. So I ended up using Flatpak instead. I'm on Manjaro Gnome.

Also, I hope that means AppArmor will be enabled out of the box?

The update went smoothly via pamac, unlike my previous update with octopi. shudder

Thanks team.

Thats fine, however things like the Cinnamon Settings Daemon, Caribou, UGet etc are allso producing
all kinds of error entries in the log.
Apparently theres a GLib problem i suppose?

I have a big issue (Cinnamon). I use diodon as a clipboard manager, but I could reproduce the problem with clipit:
Every time I copy some text in the clipboard, it starts a new instance of the clipboard manager, resulting after a while in a severe system slow-down (memory leak?)

Thanks.

Edit: actually, it is a problem with appindicator support in Cinnamon, nothing more. So I confirm the issue, but it is not so serious (the system slow-down I noticed was maybe not related).

Is this really a regression? Do you have a sample of .xsession-errors before the upgrade so you can compare? If you had the same kind of errors before and after, there is no regression then, it is on the same level of functionality/bugginess.

Last time I verified, AppArmor will be enabled by default on the upcoming ISO images, but it isn't retroactive. If you want AppArmor on older installation, you need to enable it manually.

1 Like

So far no issues. XFCE has had many updates of late but works flawlessly. Excellent work team, keep it up! (I am not power user, only web surfing and some tests) :slight_smile:

For me the plugins xfce4-orageclock and mailwatch are not working under xfce4-panel-gtk3-4.13.5-6. Downgraded to xfce4-panel-gtk3-4.13.5-5, which works fine, for the meantime.

[edit]

xfce4-panel-gtk3-4.13.6-1 works as intended
Thanks!

Everything went well on my side. Thanks team.

I ran update-grub before I rebooted , I knew that Grub itself was being updated but saw that update-grub wasn't run , didn't lose my entries that way . None of my kernels or modules were updated so probably the reason for update-grub not to run automatically .

Same here. No mailwatch, no weather - plugin. :frowning:

1 Like

@maxf and @screwtape, we've got an ongoing discussion about panel plugins in testing. The new panel update cut gtk2 support and related plugins broke until theoretically the ported gtk3 ones can be uploaded. There's already an upstream bug report on it.

2 Likes

I'm new to Linux security. Is it recommended to retroactively turn AppArmor on?

1 Like

Is that allso the cause of all those GDK and GLib entries in the .xsession-errors log,
or am i mixing something up here?
(Couldnt really find any helpful information, other than tons of bug reports related
to those error messages.)

No issues! Thank you!

No issues. Looks like htop showing high kernel cpu usage got fixed.

Thanks for the answer!

0 issues for me :sunglasses:

Forum kindly sponsored by Bytemark