[Stable Update] 2019-06-11 - Kernels, KDE Apps & Frameworks, Browsers, Nvidia, Xorg-Server, Mesa

I can't open LibreOffice Writer and Calc files.
I was using libreoffice-still and then I tried using libreoffice-fresh but it still doesn't work.

$ inxi -Fxz

System: Host: user-pc Kernel: 4.14.124-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.3.0 Desktop: KDE Plasma 5.15.5
Distro: Manjaro Linux
Machine: Type: Desktop Mobo: ASRock model: AB350 Pro4 serial: UEFI: American Megatrends v: P4.70 date: 02/12/2018
CPU: Topology: 8-Core model: AMD Ryzen 7 1700 bits: 64 type: MT MCP arch: Zen rev: 1 L2 cache: 4096 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 95840
Speed: 1520 MHz min/max: 1550/3900 MHz Core speeds (MHz): 1: 1495 2: 1158 3: 1058 4: 1058 5: 1058 6: 1058 7: 1058
8: 1058 9: 1058 10: 1058 11: 1058 12: 1058 13: 1058 14: 1058 15: 1058 16: 1058
Graphics: Device-1: NVIDIA GP106 [GeForce GTX 1060 3GB] vendor: eVga.com. driver: nvidia v: 430.14 bus ID: 26:00.0
Display: x11 server: X.Org 1.20.5 driver: nvidia resolution: 1920x1080~60Hz
OpenGL: renderer: GeForce GTX 1060 3GB/PCIe/SSE2 v: 4.6.0 NVIDIA 430.14 direct render: Yes
Audio: Device-1: NVIDIA GP106 High Definition Audio vendor: eVga.com. driver: snd_hda_intel v: kernel bus ID: 26:00.1
Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASRock driver: snd_hda_intel v: kernel
bus ID: 28:00.3
Device-3: Focusrite-Novation type: USB driver: snd-usb-audio bus ID: 3-2.4:6
Sound Server: ALSA v: k4.14.124-1-MANJARO
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASRock driver: r8168 v: 8.047.01-NAPI
port: d000 bus ID: 25:00.0
IF: enp37s0 state: up speed: 1000 Mbps duplex: full mac:
Drives: Local Storage: total: 1.70 TiB used: 959.68 GiB (55.2%)
ID-1: /dev/sda vendor: Western Digital model: WD1002FAEX-00Z3A0 size: 931.51 GiB
ID-2: /dev/sdb vendor: Crucial model: CT500MX500SSD4 size: 465.76 GiB
ID-3: /dev/sdc vendor: Micron model: C400-MTFDDAK128MAM size: 119.24 GiB
ID-4: /dev/sdd vendor: Patriot model: Pyro SE size: 111.79 GiB
ID-5: /dev/sde vendor: Intel model: SSDSC2CW120A3 size: 111.79 GiB
Partition: ID-1: / size: 92.27 GiB used: 69.29 GiB (75.1%) fs: ext4 dev: /dev/dm-0
ID-2: swap-1 size: 17.24 GiB used: 13.2 MiB (0.1%) fs: swap dev: /dev/dm-1
Sensors: System Temperatures: cpu: 30.0 C mobo: 28.0 C gpu: nvidia temp: 47 C
Fan Speeds (RPM): fan-1: 578 fan-2: 907 fan-3: 0 fan-4: 743 fan-5: 0 gpu: nvidia fan: 0%
Voltages: 12v: N/A 5v: N/A 3.3v: 3.38 vbat: 3.25
Info: Processes: 406 Uptime: 1d 53m Memory: 15.66 GiB used: 5.48 GiB (35.0%) Init: systemd Compilers: gcc: 8.3.0
clang: 8.0.0 Shell: bash v: 5.0.7 inxi: 3.0.34

I'm also having a strange problem with nvidia.

I use nvidia-xrun in my laptop, the nvidia-xrun-pm variant since bbswitch doesn't work for newer cards, so the discrete card gets shutoff at boot and I only use it if I want. It has been working fine for 6 months, computer gets really cold when in normal use and no problem to use the graphic card when switch to another TTY.

But after the last update it doesn't shutoff anymore, nvidia-xrun still does it's thing with no errors or hiccups, it puts the card on auto as before and then removes it, blacklists modules and etc, but it stays on even if it doesn't appear on lspci, nor /sys/bus/pci/devices/ and no module is loaded (they are blacklisted). What else could be waking up this card? I don't get.

My laptop went from a cold 38C to 46C needlessly.

I was using the beta but after the update I tried the stable version. Same error output. It should be the nvidia drivers most propably because on my other AMD machine I have no problems at all.

1 Like

That makes sense. No worries anyway, it's not the end of the world.
I'd be very interested to figure out how to make sure I can get my GUI back automatically when logging in though. Like, can I instruct Manjaro to use the virtual console 7 instead of another one at startup, is that how it works?

@philm
Why is kpmcore3, and kpmcore both in the repositories, if kpmcore3 is going to force me replace kpmcore if I want to update my installed system anyway?

We both know hitting N means nothing, gets updated.

@kenneth
If you didn't figure out what to do about the "blank screen problem" yet, maybe the solution provided in this thread might help:
https://forum.manjaro.org/t/nvidia-390-25-xfce-login-problem-workaround/42070

kpmcore 3 is used in ISOs for Calamares, because currently, Calamares is trash with kpmcore 4. It is the only real purpose of kpmcore3 package.

As for why it is trying to replace the original kpmcore on your system.. good question. I didn't have this particular issue on my side.

Got bad screen tearing when watching movies after the update, for the first time since installing Manjaro months ago.

  • DE: Cinnamon
  • GPU: Integrated Intel Iris 5100
  • Kernel: 4.19
1 Like

Never mind, somehow I had calamares installed on my production system.
This may be due to me working on an ISO lately, but I don't remember having it installed when working on other ISO's in the past (manjaro-tools).

Well, at least now I know I need to modify my profiles to use kpmcore3 and partitionmanager3. :wink:

Was expecting glitches with KeePassXC and ZFS, based on earlier reports,
but everything seems to be fine. :relaxed:
[kernel 4.19, nvidia-340, KDE on HP Z400]

Thanks. I switched to Testing Branch and installed the updated network-manager-applet only. It is working fine now.

My USB connected printed no longer works afer this update. My network printer (thankfully) still does.
I noticed cups-filters was updated, as was hplib - maybe this is the issue?
The printer in question is an HP Laserjet M15a
Tried deleting and re-adding th printer, if sees the printer but fails to add it with a error that the ' printer queue setup failed'
Any ideas?

If you had updated the kernel a reboot is needed.

2 Likes

Try with the kernel 4.14 LTS

Amarok doesn't work anymore!

A downgrade from libssh 3 months ago worked temporarily.
Then it worked by creating two symlinks.

sudo ln -s /usr/lib/libmysqlclient.so /usr/lib/libmysqlclient.so.18 sudo ln -s /usr/lib/libmysqld.so /usr/lib/libmysqld.so.18

Now there's nothing left. The database is not found.

Here is the error description and previous efforts in German:
https://manjaro-forum.de/viewtopic.php?f=3&t=1791

1 Like

Which equals https://wiki.manjaro.org/System_Maintenance

Thanks very much for providing the solution.
Works for me too!

1 Like

After this update my sound card Creative Sound Blaster Live 5.1 (SB0220) not working in surround mode (only stereo mode). When I try to play something in surround mode the sound card disappears from the devices and a dummy output appears. After rebooting sound card reappears, but everything repeats. Help me please.
Desktop environment is KDE.

I encountered screen tearing as reported by other users, and I solved it by adding the file 20-intel.conf in the folder /etc/X11/xorg.conf.d

Section "Device"
  Identifier  "Intel Graphics"
  Driver      "intel"
  Option      "TearFree" "true"
EndSection

I'm using compton, and is the first time, however, which I encountered the screen tearing.

I also found that VLC, despite the fact that I quit it, its icon remains stuck in the Panel: the only way to really quit it and remove the icon from the panel, was to kill it using the command "kill -9 $VLC_PID" in the terminal.

The third issue was related to the suspend to ram (standby): it usually takes a second: is instant, but after the update and a reboot, this time the laptop has take about ten seconds for going to sleep. Another reboot, hower, has solved also this issue, and I don't know if could be related, but before the second reboot i deleted the cache by using sudo pacman -Scc

My system specs here

1 Like

Exists the possibility that the tearing only happens in some applications, for example on Firefox but not on VLC. And also depends which video player are you using. I remember when I had tearing only on Firefox and I fixed the problem only for Firefox:

Tearing Firefox

Type about:config, confirm "Accepting the risk" then search for layers.acceleration.force-enabled .

By defaults, this option is set to false (and I have no idea why ... ) Toggle that boolean option to true, restart firefox and try fullscreen video again.

The results will make one's jaw to hit the ground in a very positive manner.

This fix is a must for all firefox users.

After this is done, tearing will be no more such an issue to solve.

source: https://bbs.archlinux.org/viewtopic.php?id=223294

Just in case, it's only an example, because tearing it's not always on the entire OS.