[Stable Update] 2019-05-26 - Kernels, XFCE 4.14-pre1, Virtualbox, LibreOffice

Hello community,

I am happy to announce another Stable Update!

This update holds the following changes:

  • We updated most of our kernels. Remember that linux318 now really had it's last build!
  • Another set of KDE-git packages
  • Virtualbox is now at 6.0.8
  • KDE Frameworks got updated to 5.58.0
  • XFCE is now at 4.14-pre1. Checkout our new ISO!
  • Latest Mozilla apps got added: Thunderbird & Firefox (incl. dev)
  • LibreOffice is now at 6.2.4
  • Haskell and other packages got updated to their latest build

Give us the usual feedback and let us know what you think about this update.

Current supported Kernels

  • linux316 3.16.67
  • linux318 3.18.140 [EOL] (it is now really EOL!)
  • linux44 4.4.180 (no legacy nvidia-340 module!)
  • linux49 4.9.178
  • linux414 4.14.121
  • linux419 4.19.45
  • linux420 4.20.17 [EOL]
  • linux50 5.0.18
  • linux51 5.1.4 (zfs modules still don't build)
  • linux51 5.2-rc1 (few extramodules build, but not all yet!)
  • linux419-rt 4.19.37_rt19
  • linux50-rt 5.0.14_rt9

Package Updates (Wed May 22 20:35:21 CEST 2019)

  • stable community x86_64: 595 new and 587 removed package(s)
  • stable core x86_64: 30 new and 30 removed package(s)
  • stable extra x86_64: 599 new and 741 removed package(s)
  • stable multilib x86_64: 7 new and 7 removed package(s)

A list of all package changes may be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Regression with Linux firmwares on machine running Vega GPUs.

June 2, 2019: We expect it to be fixed with linux-firmware 20190514-711d329-1.1. We downgraded the firmware related to Vega GPUs to a previous version. You should now be able to use Linux 4.19 correctly.

linux-firmware 20190514-711d329-1 introduced a regression that can make the system unbootable on systems that use a AMD Vega GPUs (for example: Vega 64, Vega 56, Vega 10) and Linux 4.19.

It is a regression that affects both Manjaro and Arch Linux. Here's some links.

Arch Linux bugtracker: https://bugs.archlinux.org/task/62666
Manjaro forum: Most recent stable branch update problem
Manjaro forum: Manjaro update prevents system booting
Manjaro forum: 'linux-firmware 20190514.711d329-1' update prevents my system booting.

If you are affected by this issue, you have essentially two choices: either use a different kernel or downgrade linux-firmware. The most preferred method is the first one since it doesn't involve keeping a package to an older version. Either way, if your system is completely unbootable (not even with a command line interface), you will need to do a chroot to repair your system. For each solution suggested below, we will suppose that you need to do a chroot; skip the chroot part if you manage to reach an usable command line interface.

For the first solution, as far as we know, it works fine on Linux 5.1 and supposedly also on Linux 5.0. Follow these steps in order to be able to install a new kernel:

  • Launch a live session with an installation medium;
  • Open a terminal;
  • Chroot your system. You may do so automatically with manjaro-chroot -a. On more complex system where manjaro-chroot may simply fail, you may have to do a manual chroot.;
  • Once you have chrooted on your system, use mhwd-kernel -i linux51 to install Linux 5.1 and all extra modules needed for your system. You may also try with Linux 5.0 (replace linux51 with linux50), although Linux 5.0 is expected to be End of Life soon.

(If you have multiple kernels installed on your machine, you may want to boot with other kernels before trying to install a new one.)

For the second one:

  • Chroot to your system from a live session;
  • Downgrade the linux-firmware package to version 20190424.4b6cf2b-1 with pacman -U /var/cache/pacman/pkg/linux-firmware-20190424.4b6cf2b-1-any.pkg.tar.xz. If the package is not available in your local cache, use pacman -U https://archive.archlinux.org/packages/l/linux-firmware/linux-firmware-20190424.4b6cf2b-1-any.pkg.tar.xz instead.

(Note that if you know how to use downgrade, you may also use downgrade.)
(Remember that downgrading a package is merely a temporary solution, do not hold the package to a previous version forever.)

Linux 5.1 - Critical bug found, may lead to data loss

We have published Linux 5.1.4 and added a patch in order to solve this issue. The content of that patch is available on our Gitlab: https://gitlab.manjaro.org/packages/core/linux51/blob/master/0001-dm-make-sure-to-obey-max_io_len_target_boundary.patch

Please update your system.

signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is marginal trust

Update manjaro-keyring first. For more options read this thread:

replace steam-devices with community/game-devices-udev?

Yes. The package name changed. Accept the replacement.

Linux 5.1 - Which extra modules are currently missing?

As said in the announcement, while the newest Linux version has been released in this update set, not every extra modules are currently available in our official repositories. Before jumping on Linux 5.1, please verify if you do not need any of those missing extra modules on your system.

(Last verification: May 26, 2019)
The following extra modules are missing:

The following extra modules are available:

  • ACPI call (linux51-acpi_call);
  • BBSwitch (linux51-bbswitch);
  • Broadcom wireless driver (linux51-broadcom-wl);
  • Catalyst drivers (linux51-catalyst);
  • Legacy NVIDIA 340.XX drivers (linux51-nvidia-340xx);
  • Legacy NVIDIA 390.xx drivers (linux51-nvidia-390xx);
  • NDIS wrapper (linux51-ndiswrapper);
  • Current NVIDIA drivers (linux51-nvidia);
  • NVIDIA backlight (linux51-nvidiabl);
  • Realtek 8168 drivers (linux51-r8168);
  • Realtek 8732bu drivers (linux51-rtl8732bu);
  • Thinkpad SMAPI (linux51-tp_smapi);
  • SCSI emulation (linux51-vhba-module);
  • VirtualBox guest modules (linux51-virtualbox-guest-modules);
  • VirtualBox host modules (linux51-virtualbox-host-modules).

Items from previous update sets

Small cleanup of Manjaro official repositories

Please note that the following packages got removed from our repositories.

  • chromium-chromevox
  • gimp-gtk3
  • pamac-classic
  • pamac-dev
  • pamac-dev-tray-appindicator

COMMAND-NOT-FOUND error during update/installation

During upgrade/installation the package command-not-found tries to sync its database with a mirror that seems to be currently (or permanently ?) offline, resulting in an error message

(1/1) installing command-not-found                                     [########################################] 100%
Could not download catalog file ... aborting
error: command failed to execute correctly

I (oberon) have already opened an issue upstream about the problem.

Kaffeine: Digital television doesn't work anymore

May 26, 2019: This issue should now be fixed with v4l-utils 1.16.6-1, according to the ticket on Arch Linux website. If you downgraded this package previously, stop keeping it downgraded and update this package to version 1.16.6-1 alongside every other upgradable packages.

Unfortunately, this functionality of Kaffeine is currently broken with v4l-utils 1.16.5-1.

It has already been reported to the Arch Linux bugtracker, see this: https://bugs.archlinux.org/task/62402

According to this ticket, Manjaro and Arch Linux are not the only distros affected by a similar issue.

As a temporary workaround, you may try to downgrade the v4l-utils package from 1.16.5-1 to 1.16.3-1. You may do so graphically with Pamac (with Install Local Package on /var/cache/pacman/pkg/v4l-utils-1.16.3-1-x86_64.pkg.tar.xz) using or with the command-line interface with pamac install /var/cache/pacman/pkg/v4l-utils-1.16.3-1-x86_64.pkg.tar.xz, sudo pacman -U /var/cache/pacman/pkg/v4l-utils-1.16.3-1-x86_64.pkg.tar.xz or any equivalent.

Please note that this is merely a temporary workaround and not a definitive solution. Do not keep this package downgraded forever as keeping downgraded packages for too long may become an issue in itself.

The KDE Updates Can Cause The Screenlocker To Crash

If you update from within a GUI session and use screenlock (e.g. it kicks in while the large update is being processed), it will crash the screenlocker.

To restore access, press CTRL+ALT+F2 to switch to another tty and log in with your username.

Then type in the following and press enter:

loginctl unlock-session 2

Press CTRL+ALT+F1 to switch back to a now unlocked KDE desktop.

XPlayer removal

May 26, 2019: This issue is now fixed with xplayer 2.0.2-2 and xplayer-plparser 1.0.2-2. While there is not an official fix from upstream yet, we fixed this issue by applying a patch suggested in this pull request on upstream's GitHub. Those packages are now back in our official repositories.

Because XPlayer doesn't work anymore alongside GStreamer 1.16.0, the following packages got removed from official repositories: xplayer and xplayer-plparser. Upstream is aware of the issue, but we do not know when it will be fixed. Those packages may come back eventually.

We suggest using alternatives such as VLC media player (package: vlc).

TLP 1.2.1, .pacnew file: Merges may be needed

TLP 1.2.1 got released in [Stable Update] 2019-04-20 update set, replacing TLP 1.1. Therefore, if you have customized your configuration file for TLP (/etc/default/tlp), a .pacnew file will be created when the tlp package will be upgraded. This .pacnew file is the new default configuration file provided by the package. Your old configuration file won't be edited or replaced automatically; by default, your old configuration file will be kept as it is and you will have to merge relevant part the new configuration file manually with a text editor. Guidance can't really be more precise since each person has its own configuration.

You may use a tool such as Meld (package: meld) in order to compare your old configuration file with the .pacnew file and see the differences more easily.

If you haven't modified your configuration file for TLP, normally, you will automatically go on the new configuration file for TLP provided in the package without any manual intervention needed.

If you use the current version of TLPUI (tlpui r109.703bade-1), it may complain with the following error with some settings: "expected item missing in config file." It is most likely because some new parameters introduced with TLP 1.2.1 are not in /etc/default/tlp. To get rid of those messages, you will need to do some merges between your old configuration files and the .pacnew files and manually add all those new settings, even if you end up using the default value for those settings.

TLPUI cannot be launched

There was a bug in a previous version of TLPUI (confirmed on tlpui r89.d6363f0-1) that changed the permissions of /etc/default/tlp to 600 (rw-------). The default permissions for this file is 644 (rw-r--r--).

It is most likely that TLPUI doesn't launch because it doesn't have the right permissions for /etc/default/tlp. TLPUI must be allowed to read that file in order to launch.

First, verify if the permissions of /etc/default/tlp are set correctly. You may verify that with ls -l /etc/default/tlp in a terminal. Here's an example of how the output will look like:

$ ls -l /etc/default/tlp
-rw-r--r-- 1 root root 14238 Apr 11 15:26 /etc/default/tlp

If you have -rw------- instead of -rw-r--r--, change the permissions of that file so this file becomes readable to the group and others too. You may do so in the terminal with sudo chmod 644 /etc/default/tlp.

Once it is done, TLPUI should work properly.

MComix 1.2.1: Can't launch after the upgrade

May 26, 2019: It should be fixed with mcomix 1.2.1-4.1. We backported a commit from upstream to MComix 1.2.1 to make it work on alongside python2-pillow 6.0.0. Please update your system.

This is a known issue that is due to breaking changes introduced in python2-pillow 6.0.0 (see this document). It is a package imported from Arch Linux and the issue has already been reported on Arch Linux side. See this ticket on the bug tracker: https://bugs.archlinux.org/task/62242

A true fix requires to do modifications in the source code of MComix.

Since python2-pillow (and python-pillow) is used by many programs, similar problems may happen with other software too.

"Spring cleanup" on Arch Linux: impact on Manjaro

Recently, Arch Linux did a "spring cleanup" of their Community repository (see the full discussion on the mailing list and seach for "spring"). Many package got removed from the Arch Linux official repositories and dropped to the AUR. Therefore, it means that many packages that were in our repositories because they were imported from Arch Linux got removed from our repositories too. Here's a non-exhaustive list of packages that got removed:

  • cherrytree - Hierarchical note taking application featuring rich text and syntax highlighting
  • docky - Full fledged dock application that makes opening common applications and managing windows easier and quicker
  • mate-menu - Advanced menu for MATE Panel, a fork of MintMenu (Not to be confused with mate-menus)
  • medit - GTK+ text editor
  • thermald - The Linux Thermal Daemon program from 01.org
  • wine-staging-nine has been removed / replaced with wine-nine. In case it is installed, it should be removed manually. http://archlinux.2023198.n4.nabble.com/Removing-wine-staging-nine-replaced-with-wine-nine-td4722447.html

If you want to continue to use those packages, you will have to use the AUR from now on.

You may try to do a package request in this category, but note that there is a high chance that your demand will be refused.


I am little worried about the stability of apps that rely on python. May I ask why python-wxpython wasn't updated?
More about the issue here

Kernel 4.19-45-1 (LTS), Xfce
Full update, all smooth, as far as I can tell after 10 minutes :slight_smile:

huge update - 1,5 GB - but no problems here again :grinning:

thanks to the Manjaro-Team :+1:


I don't know how to edit the philm post about " Known issues and solutions" so I post it here. Please, if someone knows how to edit philm wiki post, tell me.

When updating, pacman answers for replace steam-devices with community/game-devices-udev. I said "yes" to it. Everything goes smooth. Thanks!


I have a Nvidia card in my computer.
Now the update worked well without any issue - the previous updates I had to use "reboot" on console to reboot the computer.


I see the following message:

replace steam-devices with community/game-devices-udev

I am going to select Yes, has anybody had a problem with this?

No. See Tairosonloa's post above

1 Like

Thanks, it was not posted when I started writing the post and I took too long to submit it, so I did not see it. Sorry!
Update: Everything went fine!

I encountered an error on my python script after this update:

urllib3 (1.25.2) or chardet (3.0.4) doesn't match a supported version!

But I fixed it by running:

pip install --user --upgrade --force-reinstall requests

1 Like

No worries. We pushed an overlay package of python-wxpython with revision 2.1. This is included in this update.


All fine here.:+1:
82 Packages LXQT+ NVIDIA nonfree + Kernel 5.1.
80 Packages XFCE + AMD free + Kernel 5.1.

Thats normal and you should select yes. I never have had any permission to even use the old steam related name :wink: So the change was needed and is more fitting now, since the udev rule collection isnt related to steam in any way, but generic for gaming stuff.


I've just upgraded using KDE Plasma and 4.19 LTS kernel and now, after reboot, I don't have sound in any applications and the mouse wheel doesn't work either. Same thing with 4.14 LTS kernel.

1 Like

Hmm, weird. You may check the /var/log/pacman.log to see what might had changed on your end.

Depending on what method you use to update, I suppose. Dropping to TTL2 or so is better, then use systemctl reboot

Here's the log of today's update, taken from /var/log/pacman.log: https://privatebin.net/?be7d815449d8e47b#+KcRZq6THgneUjF509psAq07FXLZd8Fd+1axn6T/5Lw=

I don't see any errors or warning messages, but if you have happen to have an idea by looking at it, please, let me know. Any help is appreciated.

Edit: Switching to linux51 fixed the issue with the mouse wheel. Still no sound though. (As soon as I adjust the volume in the system applet or start playing music in mpd, the applet icon greys out and the sound device is removed from its list and replaced by "Fake output" or something similar in my native language.)

Edit #2: I've downgraded alsa-lib to the previously installed version and now sound is working again! I know downgrading packages should be the last resort and temporary, so I'm looking forward to the real solution. (Maybe it's about just waiting for the next update of this package?)

1 Like

Are you sure inkscape has to depend of mate-utils ?

XFCE : No issues.

Manjaro remains an absolute joy to use. Thank you for continuing to make a wonderful distro.

Forum kindly sponsored by Bytemark