[Stable Update] 2019-05-17 - Kernels, Grub, KDE, Deepin, Gnome, XFCE, LibreOffice, Bash, Systemd

Thank you. Much appreciated.
I guess that means we need to ignore forthcoming updates until the new stable kernels are, well, stable(?) Aren't they up to 5.1.3 or something, and someone said they tried all the future ones being tested and they all fail the bluetooth test.
Since the problem is not with Manjaro as such, does that mean we all need to reveal our problem to the kernel developers as well? (I don't envy them, I guess there's a million things that can go wrong!!)
Sorry for these elementary questions, I'm rather new to these forums, but I saw something saying if the problem is "upstream" bugs need to be reported there.

SORRY: ignore the last question, I didn't notice wolfyrion's comment saying there was already a fix on its way.

I did the steps you provided with gpg and the error is still the same (marginal trust, corrupted).

I guess I'll wait for another stable update, and hope this gets resolved in the mean time....

Mesa: Unhandled GL format: 0x8058

1 Like

Works for me.
Version 74.0.3729.131 (Official Build) Arch Linux (64-bit)
Operating System: Manjaro Linux
KDE Plasma Version: 5.15.5
KDE Frameworks Version: 5.57.0
Qt Version: 5.12.3
Kernel Version: 4.19.42-1-MANJARO
OS Type: 64-bit
Processors: 4 × Intel® Core™ i5 CPU M 520 @ 2.40GHz
Memory: 3.7 GiB of RAM

Did you try all the steps mentioned in that post?
Check rather Issues with "signature is marginal trust" or "invalid or corrupted package"
and follow the procedure. You might need to do it several times.

Did you manage to install arch and manjaro-keyring?
(mine had been corrupted and I had to delete the files in /usr/share/pacman/keyrings/manjaro before reinstalling it, but it might not be your case).

2 Likes

Thank you for the link. Following the steps provided there, I managed to successfully download the updated packages, without any warnings.

Was'nt it risky to NOT update systemd from TTY?

Nope, for me, it wasn't because of at least two things:

  1. In the above statement, using TTY to run updates wasn't brought up (as a strongly recommended way to do updates).
  2. The update wasn't too big (if I remember correctly, it was only around 500 MB).

Other reasons:
3. I read every related post thoroughly making me feel more confident about using Pamac GUI.
4. Pamac GUI is very easy to understand and not intimidating to look at--a noob/normie user like myself would almost always prefer GUI to TTY.

Finally, I think your query has already been more comprehensively addressed here.

Cheers! :smiling_face_with_three_hearts:

2 Likes

After last update, Brave is freezing after a couple of minutes (it seems to occur only when I have both Chrome and Brave open at the same time.). Maybe it's a coincidence but I noticed it only after update.

After this stable update my cpu Temps went a lot higher about +20C on cpu then before(from 30 to 50 with only opened Firefox), on both of my computers.
plasma KDE kernel 4.19
I'm currently on phone but when I get home I can post inxi and etc..

1 Like

aren't you supposed to be using pacman's keyring with these commands? :laughing:

Removing it manually did it. Thnx

What's the name of the new theme in gnome please?

You mean: kvantum-manjaro ?

I have a minor issue with the latest update: the display resolution resets after every start of the system to 1920x1080. On my screen (with my eyes LOL) this is to much so I now have to set it back to 1600x900 all the time.

Check this out: [Stable Update] 2019-05-17 - Kernels, Grub, KDE, Deepin, Gnome, XFCE, LibreOffice, Bash, Systemd

The default GTK theme for Manjaro Gnome has been switched to Matcha-sea (package: matcha-gtk-theme).

1 Like

Briefly again had the issue described in thread:


Have added on the end of that thread how things sorted out on this occasion.

Just a quick update: a new kernel 4.19.45 was released for stable update early 27/5/19 (eastern Australian time). I just tested this and it still has the bluetooth reconnect error documented extensively above by several people (eg wolfyrion, greg13).

Since this update, launching the Deepin desktop environment has no login sound.