[Stable Update] 2019-05-17 - Kernels, Grub, KDE, Deepin, Gnome, XFCE, LibreOffice, Bash, Systemd

Noticed that Mass Effect 1 (my usual test of Wine effectiveness) chokes on wine-staging. The loading screen flickers, and same in the event of actually managing to play the game. Totally unusable.

1 Like

System fonts are messed up after the last update. :frowning:
I am using GNOME.
Anyone else having the same issue ?

image

Looks like a theme issue. Check with Adwaita. (this is a good first step generally for GNOME issues)

1 Like

This makes my machine nearly unusable. XFCE4 without Thunderbird, Firefox or anything running except background tasks (all are at 0% or flicker to 1%) never goes below 26% and goes as high as 40%. Even typing this message, screen draw is in slow motion. It also causes CPU temps to stay high.

Anything we can do to fix this? It's absolutely frustrating...

2 Likes

Updated with no major issues.

I get only one warning when using requests:

/usr/lib/python3.7/site-packages/requests/__init__.py:91: RequestsDependencyWarning: urllib3 (1.25.2) or chardet (3.0.4) doesn't match a supported version!

But i fix this upgrading "requests":

sudo pip3 install --upgrade requests

Thanks!

This? Or perhaps start a new bug report? @pappl @acutbal

The current workaround I've got is simply disable xfce's compositor for now -- that should take care of xfwm4 hogging the cpu:

...do note though, this also disables v-blanking even if you have nvidia's composition pipeline on...in my case it results in minor screen-tearing in firefox but I can't see a difference in gaming.

I also tried the latest version of xfwm4 in unstable this morning and still nada. :man_shrugging:

2 Likes

Turning Enable display composting off and on again fixed the CPU issue. XFCE4 is back down to 0%-4%.

Amazing! Thanks so much for this. (Queue the IT Crowd video).

Edit: After several hours, the XFCE4 was creeping back up from 0-1% to 15-18%, so completely turning display composting off has fixed the high cpu issue for the moment. Confident this will be resolved as others seem to have the same issue.

3 Likes

I'm a little confused on your DE description...are you running 4.13 with the "*-gtk3" packages or are you still on 4.12? I'm curious to see whether or not this yet another issue affecting the non-free nvidia drivers...

Kernel: 5.0.15-1-MANJARO x86_64
Desktop: Xfce 4.13.3git-dc69f6
Display: x11
server: X.Org 1.20.4
driver: nouveau
DE: Xfce4
WM: Xfwm4
WM Theme: Matcha-dark-azul
GTK Theme: Matcha-dark-azul [GTK2]

FYI only edit: on unstable

Disabling diplay compositing reduces CPU load a lot. From CPU at 100 % to 35 % when browsing web.
It needs to stay disabled on my XFCE setup to solve the issue.

Thanks for help!:+1:

1 Like

The lovely npfeiler got it working again.

Hello,

Do you know how to fix this issue?
This one also displays when I'm using docker-compose and it(s very annoying since it brings also a little delay..
Btw, is it necessary to open an issue for this?

Thank you very much

Everything worked fine on AW alpha gnome.
Thanks guys.

Try turning off the xfce compositor option “synchronize drawing to the vertical blank”

1 Like

Hello,

I have the same error displaying every time I use a docker-compose (so I guess that it's a python based tool)
Since this error seems to bring some delay every time and that's annoying..
I wanted to fix that, but unfortunately I don't have pip3 and surprisingly the search for pip3 gave no results in my manjaro update package tool..

Do you know how I can fix this?

Thank you very much.

Ok I finally managed to fix this issue using that command.
I install python-pip which includes pip3..

This option is not available in my XFCE compositor settings. It should be the third option, but it's not there. Maybe because of Intel GPU only?

FYI, you just broke your python-requests package.

3 Likes

I do not have that option either, maybe the developers have eliminated it... :thinking:

1 Like

Forum kindly sponsored by Bytemark