[Stable Update] 2019-04-20 - Nvidia, Kernels, Deepin

One KDE Manjaro upgraded on my PC performed, and all went well :+1:, except Icecat browser did not load. I had to rebuild it, which takes at least two cupcakes and a glass of wine to accomplish. All else good. I will upgrade my laptop today, as soon as I find some more cupcakes. :cupcake::cupcake::wine_glass:

1 Like

Does it also happen after a reboot?

So this was dde-file-manager, let's wait for fix presumably tomorrow.

Yep. Also when switching from kernel 5.* to 4.19.

Drives detect fine on the USB2 ports.

Is there a way to force pacman to reinstall the updated packages?
Midway through the update I noticed one mirror showing a "?" as status. Wonder if an old package got mixed in.

For some reason I cant lock desktop ! Not from Raven menu and not from User indicator either. I am on Manjaro budgie.

Okie, so USB3 ports function properly with kernel 4.4.167-1.

They don't work with 5.0.7-1 or 4.19.34-1, nor 5.1rc1.
I tried re-downloading and installing 5.0 but no luck.

Hopefully it will be resolved with the next update.

Thanks! But, is it possible to update the Gnome Password Safe? The version 3.30 is not generating the keyfile while the 3.32 is.

can you return

inxi -Fxxxz
lsusb

have you tested also 4.14 ?
( USB3 Ko 5.1rc and 5.0 and OK 4.4)

Started the update today, then closed my laptop forgetting that I had started the update. I didn't realize I had updated again until it said [Transaction finished]. No issues whatsoever! Awesome job guys!

Just tried 4.14, also won't work. Overall system performance feels sluggish compared to the pre-update state.

Some readouts:

$ uname -a
Linux System 5.0.7-1-MANJARO #1 SMP PREEMPT Sat Apr 6 08:50:27 UTC 2019 x86_64 GNU/Linux
$ lsusb
Bus 002 Device 005: ID 04f2:b230 Chicony Electronics Co., Ltd Integrated HP HD Webcam
Bus 002 Device 004: ID 24f0:0137  
Bus 002 Device 006: ID 046d:c012 Logitech, Inc. Mouseman Dual Optical
Bus 002 Device 007: ID 0b05:17cb ASUSTek Computer, Inc. Broadcom BCM20702A0 Bluetooth
Bus 002 Device 003: ID 0409:005a NEC Corp. HighSpeed Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 138a:003c Validity Sensors, Inc. VFS471 Fingerprint Reader
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
$ inxi -Fxxxz
System:    Host: System Kernel: 5.0.7-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: KDE Plasma 5.15.4 tk: Qt 5.12.2 
           wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Hewlett-Packard product: HP EliteBook 8560p v: A0001D02 serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: Hewlett-Packard model: 1618 v: KBC Version 97.4E serial: <filter> BIOS: Hewlett-Packard v: 68SCF Ver. F.63 
           date: 05/27/2016 
CPU:       Topology: Dual Core model: Intel Core i7-2620M bits: 64 type: MT MCP arch: Sandy Bridge rev: 7 L2 cache: 4096 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21557 
           Speed: 798 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 848 2: 1007 3: 824 4: 862 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series] vendor: Hewlett-Packard 
           driver: radeon v: kernel bus ID: 01:00.0 chip ID: 1002:6760 
           Display: x11 server: X.Org 1.20.4 driver: radeon FAILED: ati unloaded: modesetting alternate: fbdev,vesa 
           compositor: kwin_x11 resolution: 1920x1200~60Hz 
           OpenGL: renderer: AMD CAICOS (DRM 2.50.0 / 5.0.7-1-MANJARO LLVM 8.0.0) v: 3.3 Mesa 19.0.2 compat-v: 3.1 
           direct render: Yes 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: Hewlett-Packard driver: snd_hda_intel 
           v: kernel bus ID: 00:1b.0 chip ID: 8086:1c20 
           Sound Server: ALSA v: k5.0.7-1-MANJARO 
Network:   Device-1: Intel 82579LM Gigabit Network vendor: Hewlett-Packard driver: e1000e v: 3.2.6-k port: 5020 
           bus ID: 00:19.0 chip ID: 8086:1502 
           IF: enp0s25 state: down mac: <filter> 
           Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi v: kernel port: 4000 bus ID: 25:00.0 
           chip ID: 8086:0085 
           IF: wlo1 state: up mac: <filter> 
Drives:    Local Storage: total: 465.76 GiB used: 184.71 GiB (39.7%) 
           ID-1: /dev/sda vendor: Hitachi model: HTS727550A9E364 size: 465.76 GiB speed: 3.0 Gb/s rotation: 7200 rpm 
           serial: <filter> rev: A0E0 scheme: MBR 
Partition: ID-1: / size: 19.56 GiB used: 15.88 GiB (81.2%) fs: ext4 dev: /dev/sda7 
           ID-2: /boot size: 487.9 MiB used: 182.6 MiB (37.4%) fs: ext4 dev: /dev/sda2 
           ID-3: /home size: 14.70 GiB used: 10.66 GiB (72.5%) fs: ext4 dev: /dev/sda8 
           ID-4: swap-1 size: 8.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda6 
Sensors:   System Temperatures: cpu: 57.0 C mobo: N/A gpu: radeon temp: 0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 216 Uptime: 6m Memory: 3.80 GiB used: 951.7 MiB (24.4%) Init: systemd v: 241 Compilers: gcc: 8.2.1 
           clang: 8.0.0 Shell: bash v: 5.0.2 running in: konsole inxi: 3.0.32 

XFCE, 4.19.34-1

Everything went smoothly! Thanks for all the hard work.

After the update I have to enter the wifi password again. Nothing else. :blush:

KDE Plasma 5.15.4
Great job!

successfully updated cinnamon machine, using tty
Thanks.

Manjaro XFCE on a Thinkpad here. The update went fine mostly but TLP-UI is no longer opening unless I launch it with sudo in a terminal. Before the TLP update, running the command tlpui would prompt for the root password before opening the graphical interface for TLP. Now, running tlpui returns the following:

/usr/share/tlp/tlp-func-base: line 350: /etc/default/tlp: Permission denied
Traceback (most recent call last):
File "/usr/lib/python3.7/runpy.py", line 193, in _run_module_as_main
"main", mod_spec)
File "/usr/lib/python3.7/runpy.py", line 85, in _run_code
exec(code, run_globals)
File "/opt/tlpui/tlpui/main.py", line 8, in
from . import settings
File "/opt/tlpui/tlpui/settings.py", line 73, in
tlpconfigfile = get_tlp_config_file()
File "/opt/tlpui/tlpui/settings.py", line 46, in get_tlp_config_file
currentconfig = check_output(["tlp-stat", "-c"]).decode(sys.stdout.encoding)
File "/usr/lib/python3.7/subprocess.py", line 395, in check_output
**kwargs).stdout
File "/usr/lib/python3.7/subprocess.py", line 487, in run
output=stdout, stderr=stderr)
subprocess.CalledProcessError: Command '['tlp-stat', '-c']' returned non-zero exit status 1.

I have to run sudo tlpui to open the graphical interface. Aside of that, it seems TLP itself runs properly.

This is no big issue but if anyone knows how to fix that (i.e. have tlpui prompt for the root password instead of returning the above error), I'm interested :wink:

I voted for the second so I post here:
Internet connections disappeared on my plasma kde after this updates and I suppose that's for the update of plasma-nw package. I ran sudo systemctl restart/enable NetworkManager.service then it solved.

3 Likes

check file

ls -la /etc/default/tlp 

it should be rw-r--r--

2 Likes

Just updated. It's running perfectly. No problems.

Thanks @stephane! The permissions for that file on my system were rw------- so I ran

sudo chmod g=r /etc/default/tlp
sudo chmod o=r /etc/default/tlp

and now the graphical interface for TLP opens and I can make some changes. Whenever I save the modifications, I get a prompt for the root password, which is the correct behavior. Thanks for your help!

1 Like

Hi,

GRUB translations where broken in unstable some time ago......
Quality management broken too?

Forum kindly sponsored by