[Stable Update] 2019-04-03 - Mate, KDE-Dev, Cinnamon, Deepin, Browsers

How to solve this problem with pacman? The file /var/cache/pacman/pkg/libreoffice-fresh-6.2.2-2-x86_64.pkg.tar.xz is corrupt (the package is invalid or is corrupt (PGP signature).
libreoffice-fresh: signature from “Evangelos Foutras evangelos@foutrelis.com” is invalid

Keeping mesa 19.0.1+really+18.3.5-1 and applying the rest of the update broke Viber for me, it’s window became transparent and when run in debug mode, it was complaining about not being able to use the OpenGL APIs (on VirtualBox). It is a Qt application, so the issue might affect other Qt-based software, too.

After i “downgraded” to the newer mesa 19.0.1-2, the issue was resolved.

I must say, this Stable Update is sadly the biggest PITA i’ve yet experienced, with respect to atrocious download speeds. So far i’ve successfully updated two of my three VMs [sudo pacman -Syyuu in TTY], & the third is underway now. However, irrespective of how many times i’ve refreshed/updated my mirror lists, the download speeds are simply miserable… each of those two VM updates took HOURS, & the current one looks like it likely will be ditto. I was wondering if maybe my ISP or VPN is/are having a fault, but when i run the usual Ookla speedtest in my browser i still see fairly normal values for my area.

If almost everyone is downloading the updates at around the same time, it’s going to clog up the traffic, I should think.

I always avoid fighting the crowds and wait a few days at least.

2 Likes

Maybe… albeit my own timing here re when i began trying to update vs when i saw the announcement, is little different to historically, yet these dreadful speeds have never happened to me before. Also, as well as the poor speeds, there’s a ton of weird errors also not previously seen by me, eg:


EDIT:
…and, this is how VM 3 just ended up…

Summary
error: failed retrieving file 'qt5-tools-5.12.2-3-x86_64.pkg.tar.xz' from mirror.deace.id : expected download size exceeded
error: failed retrieving file 'qt5-tools-5.12.2-3-x86_64.pkg.tar.xz' from mirror.upb.edu.co : expected download size exceeded
error: failed retrieving file 'qt5-tools-5.12.2-3-x86_64.pkg.tar.xz' from manjaro.mirror.liquidtelecom.com : expected download size exceeded
error: failed retrieving file 'qt5-tools-5.12.2-3-x86_64.pkg.tar.xz' from ct.mirror.garr.it : expected download size exceeded
error: failed retrieving file 'qt5-tools-5.12.2-3-x86_64.pkg.tar.xz' from mirror.catn.com : expected download size exceeded
error: failed retrieving file 'qt5-tools-5.12.2-3-x86_64.pkg.tar.xz' from mirror.cedia.org.ec : expected download size exceeded
warning: failed to retrieve some files
 smbclient-4.10.0-3-x86_64                           4.1 MiB  44.1K/s 01:36 [###########################################] 100%
 thunar-gtk3-1.8.4-2-x86_64                        964.0 KiB  36.8K/s 00:26 [###########################################] 100%
 xfce4-settings-gtk3-4.13.5-11-x86_64              499.8 KiB  74.6K/s 00:07 [###########################################] 100%
 compton-6.2-2-x86_64                              117.3 KiB  78.3K/s 00:01 [###########################################] 100%
 engrampa-1.22.0-1-x86_64                         1078.8 KiB  41.5K/s 00:26 [###########################################] 100%
 firefox-developer-edition-67.0b6-1-x86_64          46.3 MiB  41.5K/s 19:03 [###########################################] 100%
 firefox-developer-edition-i18n-en-gb-67.0b6-...   387.3 KiB  42.9K/s 00:09 [###########################################] 100%
 manjaro-application-utility-1.1.1-1-any            42.9 KiB  59.1K/s 00:01 [###########################################] 100%
 obconf-2.0.4-6-x86_64                             118.9 KiB  63.7K/s 00:02 [###########################################] 100%
 skrooge-2.18.0-3-x86_64                            11.4 MiB  34.8K/s 05:36 [###########################################] 100%
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.
[kdemeoz@manjaro-openbox-VM ~]$ 

Read the FAQ.

What mirrors are you using?

Regarding the weird errors, I wonder if your mirrors are fully-synced yet. Or maybe the post immediately below yours by grinner applies to your problem.

To be fair though, I haven’t installed the 3 April upgrades yet so I can’t say for sure I’m not going to suffer the same issue.

1 Like

Well i can’t guarantee they were the same mirrors for VM1 & VM2 [now closed down for the night after eventual success], but for VM3 which just stuttered to a failed halt [i did the same initial command for VM1&2]:

Summary
[kdemeoz@manjaro-openbox-VM ~]$ sudo pacman-mirrors -f 7
::INFO Downloading mirrors from repo.manjaro.org
::INFO Using default mirror file
::INFO Querying mirrors - This may take some time
  ..... Germany        : https://mirror.23media.com/manjaro/
  1.956 Germany        : http://mirror.23media.com/manjaro/
  3.617 Italy          : https://ct.mirror.garr.it/mirrors/manjaro/
  2.454 Indonesia      : https://mirror.deace.id/manjaro/
  ..... Indonesia      : http://mirror.deace.id/manjaro/
  ..... Colombia       : http://mirror.upb.edu.co/manjaro/
  ..... Kenya          : https://manjaro.mirror.liquidtelecom.com/
  ..... Kenya          : http://manjaro.mirror.liquidtelecom.com/
  ..... United_Kingdom : http://mirror.catn.com/pub/manjaro/
  ..... Ecuador        : https://mirror.cedia.org.ec/manjaro/
::INFO Writing mirror list
::Germany         : https://mirror.23media.com/manjaro/stable
::Indonesia       : https://mirror.deace.id/manjaro/stable
::Colombia        : http://mirror.upb.edu.co/manjaro/stable
::Kenya           : https://manjaro.mirror.liquidtelecom.com/stable
::Italy           : https://ct.mirror.garr.it/mirrors/manjaro/stable
::United_Kingdom  : http://mirror.catn.com/pub/manjaro/stable
::Ecuador         : https://mirror.cedia.org.ec/manjaro/stable
::INFO Mirror list generated and saved to: /etc/pacman.d/mirrorlist
[kdemeoz@manjaro-openbox-VM ~]$ sudo pacman -Syyuu
[sudo] password for kdemeoz: 
:: Synchronizing package databases...
 core                     149.5 KiB   134K/s 00:01 [#######################] 100%
 extra                                            1829.1 KiB  44.8K/s 00:41 [###########################################] 100%
 community                                           5.2 MiB  53.5K/s 01:40 [###########################################] 100%
 multilib                                          184.2 KiB  48.5K/s 00:04 [###########################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: bashrc-manjaro will be installed before its bash dependency
warning: dependency cycle detected:
warning: mesa will be installed before its libglvnd dependency
warning: dependency cycle detected:
warning: x264 will be installed before its ffmpeg dependency

Packages (52) bash-5.0.002-1  bashrc-manjaro-5.0.002-1  cmake-3.14.1-1  compton-6.2-2  cups-2.2.11-1  cups-filters-1.22.3-1
              curl-7.64.1-2  device-mapper-2.02.184-1  engrampa-1.22.0-1  ffmpeg-1:4.1.2-2
              firefox-developer-edition-67.0b6-1  firefox-developer-edition-i18n-en-gb-67.0b6-1  giflib-5.1.8-1
              gnome-bluetooth-3.32.1-1  gnupg-2.2.15-1  gnutls-3.6.7-1  gpgme-1.13.0-1  harfbuzz-2.4.0-1
              harfbuzz-icu-2.4.0-1  iana-etc-20190329-1  imagemagick-7.0.8.36-1  intel-ucode-20190312-1  libcups-2.2.11-1
              libglvnd-1.1.1-1  libgnome-keyring-3.12.0+11+g3766bcc-1  libibus-1.5.20-2  libinput-1.13.0-1
              libmagick-7.0.8.36-1  libreoffice-fresh-6.2.2-2  libsynctex-2018.48691-7  libwbclient-4.10.0-3
              llvm-libs-8.0.0-1  lvm2-2.02.184-1  manjaro-application-utility-1.1.1-1  mesa-19.0.1-2  nano-4.0-1
              obconf-2.0.4-6  perl-libwww-6.38-1  pkgconf-1.6.1-1  plasma-framework-5.56.1-4  poppler-0.75.0-1
              poppler-glib-0.75.0-1  poppler-qt5-0.75.0-1  python-3.7.3-1  python-lxml-4.3.3-1  qt5-tools-5.12.2-3
              skrooge-2.18.0-3  smbclient-4.10.0-3  thunar-gtk3-1.8.4-2  tzdata-2019a-1  x264-2:157.r72db4377-1
              xfce4-settings-gtk3-4.13.5-11

Total Download Size:    302.08 MiB
Total Installed Size:  1140.96 MiB
Net Upgrade Size:         1.60 MiB

:: Proceed with installation? [Y/n] 

U could try with your local mirror:
pacman-mirrors -c Australia
or
pacman-mirrors -f5
and then
pacman -Syyu
and see if that works any better.

1 Like

Ta, yeah, maybe tomorrow. The Australian ones are notoriously slow to update, so i usually avoid them. It’s late here now; i’ll retry tomorrow & cross my fingers.

1 Like

Yeah, I manually edit my mirrorlist file with a good quick mirror or three and just stick with it (ie moson), don’t use pacman-mirrors.

Are you doing this in peak evening timeframe? Could be ISP congestion also if all mirror downloads are crawling, or as was mentioned the mirrors are getting clobbered by lots of users updating.

Imagine it would be annoying anyway … move this box to testing too … :grin:

Good update, System after reboot works fine.
LXQT and XFCE with Kernel 5.0.
Thanks!

1 Like

Can someone please explain deepin-file-manager-nomodule? Thanks

The update went smoothly but some new errors have popped up in my logs

Apr 04 13:37:07 nicomo-pc kernel: rtl8192c_common: Polling FW ready fail! REG_MCUFWDL:0x00030006.
Apr 04 13:37:07 nicomo-pc kernel: rtl8192c_common: Firmware is not ready to run!
Apr 04 13:37:07 nicomo-pc kernel: rtl8192cu: 8051 reset failed!.........................

will do another reboot and see if they reappear.

Update : disappeared on the second reboot - no idea why.

Before doing the update via TTY (I am usually following these instructions) and wanting to have the newest version of mesa, I would like to know if I should:

  1. either run sudo pacman -Syyuw and then sudo pacman -Syuu, pamac upgrade --enable-downgrade
  2. or run sudo pacman -Syyuuw and then sudo pacman -Syuu, pamac upgrade --enable-downgrade

Or is there another way to do that?
Thanks in advance.

This is where configuring pamac-manager to automatically download updates comes into its own. By the time you come to do the update, the packages should all be sitting in cache ready for you.

This bug: [Stable Update] 2019-04-03 - Mate, KDE-Dev, Cinnamon, Deepin, Browsers (plasmashell use 100% CPU for each animated indicator)
can be fixed by setting environment variable QSG_RENDER_LOOP=basic
just create /etc/profile.d/fix_qt_bug.sh file with content: export QSG_RENDER_LOOP=basic

but I do not know what else it will affect and why everything was fine without this “fix” with QT 5.12.1 .

@suzannex you would be better working with Play on Linux for Wine… that way you can control different versions of wine and avoid that kind of problems.

2 Likes

Compton-6.2-2 broken after this upgrade…

/usr/bin/manjaro-compositor --start
[ 2019-04-04 07:45:26.388 parse_config_libconfig FATAL ERROR ] Error when reading configuration file "/home/obxdan/.config/compton.conf", line 29: syntax error
[ 2019-04-04 07:45:26.388 main FATAL ERROR ] Failed to create new compton session.

FYI: /home/obxdan/.config/compton.conf", line 29

    27  
    28  # Backend
    29  backend = "xrender";
    30  vsync = "opengl";
    31  mark-wmwin-focused = true;
    32  mark-ovredir-focused = true;
...

<<<Workaround>>>
downgraded to compton-4.0-1 :smile:
compton-5.1-1 also broken

inxi -Sxx
System:    Host: obxdan-pc Kernel: 5.0.5-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: Openbox 3.6.1 
           dm: LightDM Distro: 5.0.5-1-MANJARO