[Stable Update] 2019-04-03 - Mate, KDE-Dev, Cinnamon, Deepin, Browsers

@daPhipz i was not asking because of Leandro. I had a warning about mesa and lib32-mesa (19.0.1+really+18.3.5-1 to 19.0.1-1). I did -Syyuu anyway…

Thanks!

1 Like

Oh I see… I’m having the same problem - mesa wants to downgrade…

2 Likes
➜  ~ sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
warning: lib32-mesa: local (19.0.1+really+18.3.5-1) is newer than multilib (19.0.1-1)
warning: lib32-mesa-vdpau: local (19.0.1+really+18.3.5-1) is newer than multilib (19.0.1-1)
warning: lib32-vulkan-intel: local (19.0.1+really+18.3.5-1) is newer than multilib (19.0.1-1)
warning: lib32-vulkan-radeon: local (19.0.1+really+18.3.5-1) is newer than multilib (19.0.1-1)
warning: libva-mesa-driver: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.1-2)
warning: mesa: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.1-2)
warning: mesa-vdpau: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.1-2)
warning: vulkan-intel: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.1-2)
warning: vulkan-radeon: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.1-2)
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: bashrc-manjaro will be installed before its bash dependency
warning: dependency cycle detected:
warning: x264 will be installed before its ffmpeg dependency

Packages (54) bash-5.0.002-1  bashrc-manjaro-5.0.002-1  cmake-3.14.1-1  compton-6.2-2  cups-2.2.11-1
              cups-filters-1.22.3-1  curl-7.64.1-2  device-mapper-2.02.184-1  ffmpeg-1:4.1.2-2  gd-2.2.5-1.1
              giflib-5.1.8-1  gnupg-2.2.15-1  gnutls-3.6.7-1  gpgme-1.13.0-1  gst-plugins-ugly-1.14.4-2
              gtksourceview-pkgbuild-4-2  harfbuzz-2.4.0-1  harfbuzz-icu-2.4.0-1  highlight-3.50-1
              iana-etc-20190329-1  imagemagick-7.0.8.36-1  intel-ucode-20190312-1  kcmutils-5.56.0-2
              kvantum-qt5-0.11.0-1  lib32-libglvnd-1.1.1-1  lib32-llvm-libs-8.0.0-1  lib32-util-linux-2.33.1-1
              libcups-2.2.11-1  libcurl-compat-7.64.1-1  libglvnd-1.1.1-1  libibus-1.5.20-2  libinput-1.13.0-1
              libmagick-7.0.8.36-1  libwbclient-4.10.0-3  libxmlb-0.1.8-1  llvm-libs-8.0.0-1  lvm2-2.02.184-1
              meld-3.20.1-1  nano-4.0-1  pcsclite-1.8.25-1  pkgconf-1.6.1-1  plasma-framework-5.56.1-4
              poppler-0.75.0-1  poppler-glib-0.75.0-1  python-3.7.3-1  qt5-styleplugins-5.0.0.20170311-12
              qt5-tools-5.12.2-3  smbclient-4.10.0-3  telegram-desktop-1.6.3-1  tzdata-2019a-1  vim-8.1.1073-1
              vim-runtime-8.1.1073-1  vlc-3.0.6-10  x264-2:157.r72db4377-1

Total Download Size:   171.08 MiB
Total Installed Size:  706.34 MiB
Net Upgrade Size:       12.23 MiB

:: Proceed with installation? [Y/n]

Should I go ahead or?

@philm @lisa Is it normal that 19.0.1+really+18.3.5-1 is not in Stable repos anymore?

Perhaps you can wait for a while, the time we get a more definitive answer.

The last time I checked the installed packages, after updating after the announcement of the previous update (3-29-19), I am almost sure that mesa was in 19.0.1 + really + 18.3.5-1. I am newbie, and I do not understand very well why I am now in 19.0.1-2 ?? … I also remember doing an update a couple of days ago, more or less, of three packages (I do not remember what they were). Maybe mesa was updated then?

Looking at the warnings of these packages related to mesa in Octopi, do I need to update with -Syyuu?

During the testing cycle Mesa 19 was proven working. You can stay on Mesa 18 if wanted. If however someone still has issues with it, let us know. We can push back those Mesa 18 packages as needed.

is it ok to update ?

:: Starting full system upgrade...
warning: lib32-libva-mesa-driver: local (19.0.1+really+18.3.5-1) is newer than multilib (19.0.1-1)
warning: lib32-mesa: local (19.0.1+really+18.3.5-1) is newer than multilib (19.0.1-1)
warning: lib32-mesa-vdpau: local (19.0.1+really+18.3.5-1) is newer than multilib (19.0.1-1)
warning: lib32-vulkan-intel: local (19.0.1+really+18.3.5-1) is newer than multilib (19.0.1-1)
warning: lib32-vulkan-radeon: local (19.0.1+really+18.3.5-1) is newer than multilib (19.0.1-1)
warning: libva-mesa-driver: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.1-2)
warning: mesa: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.1-2)
warning: mesa-vdpau: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.1-2)
warning: vulkan-intel: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.1-2)
warning: vulkan-radeon: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.1-2)
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: bashrc-manjaro will be installed before its bash dependency
warning: dependency cycle detected:
warning: x264 will be installed before its ffmpeg dependency

Packages (54) bash-5.0.002-1  bashrc-manjaro-5.0.002-1  cmake-3.14.1-1  cups-2.2.11-1
              cups-filters-1.22.3-1  curl-7.64.1-2  device-mapper-2.02.184-1  ffmpeg-1:4.1.2-2
              firefox-66.0.2-1  flatpak-1.3.1-1  gd-2.2.5-1.1  giflib-5.1.8-1  gnupg-2.2.15-1
              gnutls-3.6.7-1  gpgme-1.13.0-1  gst-plugins-ugly-1.14.4-2  harfbuzz-2.4.0-1
              harfbuzz-icu-2.4.0-1  iana-etc-20190329-1  imagemagick-7.0.8.36-1  inkscape-0.92.4-4
              kcmutils-5.56.0-2  kdeconnect-1.3.4-1  kvantum-qt5-0.11.0-1  lib32-libglvnd-1.1.1-1
              lib32-llvm-libs-8.0.0-1  lib32-util-linux-2.33.1-1  libcups-2.2.11-1
              libglvnd-1.1.1-1  libgnome-keyring-3.12.0+11+g3766bcc-1  libibus-1.5.20-2
              libinput-1.13.0-1  libmagick-7.0.8.36-1  libmagick6-6.9.10.35-1
              libreoffice-fresh-6.2.2-2  libwbclient-4.10.0-3  llvm-libs-8.0.0-1  lvm2-2.02.184-1
              nano-4.0-1  pcsclite-1.8.25-1  pkgconf-1.6.1-1  plasma-framework-5.56.1-4
              poppler-0.75.0-1  poppler-glib-0.75.0-1  poppler-qt5-0.75.0-1  python-3.7.3-1
              qgpgme-1.13.0-1  qt5-tools-5.12.2-3  samba-4.10.0-3  sddm-0.18.1-1
              smbclient-4.10.0-3  tzdata-2019a-1  vlc-3.0.6-10  x264-2:157.r72db4377-1

Total Download Size:    335.65 MiB
Total Installed Size:  1378.88 MiB
Net Upgrade Size:         6.02 MiB

:: Proceed with installation? [Y/n]

This downgrading is really update to 19.01 version. I check this and work it.

I am seeing this:

warning: lib32-mesa: local (19.0.1+really+18.3.5-1) is newer than multilib (19.0
.1-1)
warning: mesa: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.1-2)
warning: vulkan-intel: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.
1-2)

What should I do? Should I do a

sudo pacman -Syyuu

?

See just above.

I’ll make an entry in the Wiki post about that. Leave me a moment to write it.

Ok. Going ahead. :slightly_smiling_face:

If you wanna upgrade mesa to 19.0.1 do a sudo pacman -Syyuu else if you wanna stick to 18.3.5 do a normal sudo pacman -Syyu

5 Likes

I lost on of my games with the update. Presumably with wine 4.5. Wolfeinstein-The Old Blood crash violently. Works fine with 4.3. Other game seems ok.

That’s what @lisa informed. In testing has a newer version, the stable has not received the update and no it is present in the list of packages are present in this update.

My phrase was bad enough to understand what I meant. :joy:

But I already edited. :wink:

1 Like

Updated 2 I7 multi monitor production machines using terminal and sudo pacman-mirrors --fasttrack && sudo pacman -Syyuu. Completely without any problems whatsoever. Thanks to philm and the rest of the crew. Just excellent!

Added information about that mesa thing in the wiki post. Said that you can either switch or keep the one you currently have, but told that it is possible that it may change in the future.

Hope the instructions are clear enough.

EDIT: Also added information for Brisk Menu. Do not be surprised if you don’t have icons for categories anymore: it was a necessary temporary fix in order to make Brisk menu work on MATE 1.22 while waiting for upstream to adapt the menu for MATE 1.22.

EDIT2: Also added “Spring cleanup” on Arch Linux: impact on Manjaro, in case people wonder why some packages like cherrytree and thermald got removed from Manjaro repos.

8 Likes

updated cinnamon machine via TTY using sudo pacman -Syyuu successfully.
Thanks.

Brisk will be fix soon for categories icons, thanks to vkareh

Updated without problems

1 Like

Long-time Gnome user migrated to KDE after the 3.32 :poop:show, so first KDE upgrade…all went very well with pacman -Syyuu. :man_cartwheeling::computer::partying_face:

6 Likes

Update went ok but there are still bugs in qt5 that make using Krita (from repos) with a wacom pen tablet very anoying, leaving the canvas borks the cursor and this only happens while using the pen tablet, mouse has no issues. This thread in the kde bugtracking system explains this issue, in the same thread they list the patches necessary to build Krita against qt 5.12 to solve the problem. A temporary solution would be to use the official appimage.

Otherwise another excelent update, cheers to the Manjaro team.

1 Like

Forum kindly sponsored by Bytemark