[Stable Update] 2019-03-29 - Kernels, Gnome, LibreOffice, Mesa, Budgie, Browsers, Qt

:+1:

Yaourt (Yet AnOther User Repository Tool ) war ein AUR-Hilfsprogramm, das seit einiger Zeit nicht mehr weiter entwickelt wird (siehe auch https://wiki.archlinux.de/title/Yaourt). Yaourt wurde daher mit diesem Update aus den Paktequellen entfernt. @Bleuzen empfiehlt deshalb einen anderen Helfer (trizen (Hinweis für KDE-Nutzer: kann mit Octopi verwendet werden), yay oder pamac (z.B. im CLI über die build Option)) zu nutzen.

2 Likes

There are more times the desktop system get stunned. And I checked the journalctl -r, in which I get many lines of the error about gdm-x-session:

/usr/lib/gdm-x-session[1075]: nvLock: client timed out, taking the lock

This error was reported many times before when I used the Mathematica 11.3. But it did not appear at other time when I used the manjaro. However now it appears much frequently. I think it is the issue of the updated Gnome. But I cannot find how to get it repaired.

There are a few reports of this message with the nvidia-390 driver. If you are not already running it you could try the nvidia (418) driver. Either use Manjaro Settings Manager -> Hardware (simpler) or read about how on the wiki https://wiki.manjaro.org/index.php?title=Configure_Graphics_Cards.

All good and well! Thanks team!

DE: XFCE
Kernels: linux419, linux416

Thank you for the advice!. It is helpful. However, after I changed it into the 418 driver, the error still appears, with a lower frequency. But it is still annoying.

Ah, okay. You could try this:

Hi,

have anyone experienced problems with the icon(s) in the gnome status menu?
Now there is a much too large user icon instead of the usual user picture.

Screenshot%20from%202019-04-03%2016-52-16

I added these into my kernel parameters. But after generating the grub.cfg and reboot, this annoying issue does still appear. It freeze the system few seconds when I open firefox and randomly comes at other time, And nvLock:... is still listed in the journal. : (

But still, thanks for your help!

Pamac unterstützt auch in der grafischen Benutzeroberfläche das AUR - ganz ohne weiteren Helper!

1 Like

Time to start a troubleshooting thread in ‘Technical Issues and Assistance’, I think.

First have a read of How to provide good information in your posts. Inxi might help identify an issue with your hardware/setup that leads to the issue. But particularly a copy of the journalctl error message(s) generated when opening firefox, or other instances of the freeze if you can catch one, will hopefully help to get some better assistance. :slightly_smiling_face:

Updated via TTY. The only issue I had was with the Dash-to-Panel extension. It would throw an error when it would try to update from the Gnome Extensions website. Had to manually apply the update.

Yes… I have a normal sized icon but not my picture profile. The picture is in the log in screen and in the lock screen, but not in that menu.

1 Like

When locking my screen, I can no longer press a key to get to the password field, I have to mouse drag up.

Gnome edition, nothing special

See [Stable Update] 2019-03-29 - Kernels, Gnome, LibreOffice, Mesa, Budgie, Browsers, Qt

But the update is already released. So when you update arc-menu extension everything should be working fine.

Gnome desktop – switched off extensions, upgraded via console, restarted and switched extensions back on again.

On Dell XPS 13 9680, brightness, back-light brightness and volume indicators no longer showing status bars when used. Icons are showing, buttons are working but the indicator bars inside the icon to show how high/low the volume/brightness is have not been showing since this update.

1 Like

Gnome desktop bugs: some keyboard shortcuts not working.

image

I rely on these four shortcuts very very very much. They greatly improved my efficiency. But now they are not working right now.
Every time I set these shortcuts, they are working. Then when I reboot the system, all of them fail to work or some of them fail to work.
This is super weird.

Please fix it. Thanks in advance!!!

Yeah, me too.

Pacman/Yay said that there were newer mesa packages installed. I reinstalled/downgraded with:

pacman -S  lib32-libva-mesa-driver lib32-mesa lib32-mesa-vdpau lib32-vulkan-intel lib32-vulkan-radeon libva-mesa-driver mesa mesa-vdpau vulkan-intel vulkan-radeon'
[2019-04-05 17:35] [ALPM] downgraded lib32-libva-mesa-driver (19.0.1+really+18.3.5-1 -> 19.0.1-1)
[2019-04-05 17:35] [ALPM] reinstalled mesa (19.0.1-2)
[2019-04-05 17:35] [ALPM] downgraded lib32-mesa (19.0.1+really+18.3.5-1 -> 19.0.1-1)
[2019-04-05 17:35] [ALPM] downgraded lib32-mesa-vdpau (19.0.1+really+18.3.5-1 -> 19.0.1-1)
[2019-04-05 17:35] [ALPM] downgraded lib32-vulkan-intel (19.0.1+really+18.3.5-1 -> 19.0.1-1)
[2019-04-05 17:35] [ALPM] downgraded lib32-vulkan-radeon (19.0.1+really+18.3.5-1 -> 19.0.1-1)
[2019-04-05 17:35] [ALPM] downgraded libva-mesa-driver (19.0.1+really+18.3.5-1 -> 19.0.1-2)
[2019-04-05 17:35] [ALPM] downgraded mesa-vdpau (19.0.1+really+18.3.5-1 -> 19.0.1-2)
[2019-04-05 17:35] [ALPM] downgraded vulkan-intel (19.0.1+really+18.3.5-1 -> 19.0.1-2)
[2019-04-05 17:35] [ALPM] downgraded vulkan-radeon (19.0.1+really+18.3.5-1 -> 19.0.1-2)

(The Alt-Tab bug under KDE Wayland is still present. Alt-Tab only switches between the last used, switching is only possible between two tasks.)

I’ve had an issue with this update for a while and tried to fix it before posting here but couldn’t. I’m using manjaro kde.
After this update the time it takes to login has roughly doubled, as the login seems to get stuck for a while (looks like around ~75% on my splashscreen’s loading bar). I have a gnome-keyring prompt when I login and this used to popup after the splash screen, when in the DE, but now it appears on top of the splash screen at around the same point.
The thing that confuses me is that I have another account on this PC, and that account isn’t affected by this issue. It is able to login like normal (very quickly) and the login doesn’t get stuck for a while like what’s happening on my main account.
I’ve tried the following things:

  • Disabling all my startup programs, doesn’t make a difference.
  • Comparing systemd-analyze blame (regular and --user) + critical-chain from both accounts, and there isn’t any significant difference.
  • Comparing xorg log, which again shows no difference.
  • Changing kernels to a lower and a newer version, no difference.

System log doesn’t really show anything significant either (no errors).

Has anyone had any similar problems/have any ideas?

I’m wondering whether it’s just worth creating a new account and moving everything to that.

Also my kde now freezes when I switch inputs with ibus, and when it unfreezes it seems as if the alt key is stuck as clicking on any window starts moving it, and latte-dock is just unresponsive to everything. Keyboard shortcuts don’t work (like alt-tab) so I have to manually switch to another tty to kill all the user processes to logout.

Here’s my inxi -Fxzc0, if it helps at all:

System:    Host: x-pc Kernel: 5.0.5-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: KDE Plasma 5.15.3 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: Acer product: Swift SF314-51 v: V1.07 serial: <filter> 
           Mobo: Acer model: M3_SK v: V1.07 serial: <filter> UEFI: Insyde v: 1.07 date: 11/30/2016 
Battery:   ID-1: BAT0 charge: 39.4 Wh condition: 39.4/48.3 Wh (82%) model: AC14B8K status: Full 
           Device-1: hidpp_battery_0 model: Logitech M585/M590 Multi-Device Mouse charge: 100% (should be ignored) 
           status: Discharging 
CPU:       Topology: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP arch: Kaby Lake rev: 9 L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21704 
           Speed: 899 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 900 2: 900 3: 900 4: 900 
Graphics:  Device-1: Intel HD Graphics 620 vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0 
           Display: x11 server: X.Org 1.20.4 driver: intel unloaded: modesetting resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2) v: 4.5 Mesa 19.0.1 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 
           Sound Server: ALSA v: k5.0.5-1-MANJARO 
Network:   Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Lite-On driver: ath10k_pci v: kernel 
           port: 3040 bus ID: 02:00.0 
           IF: wlp2s0 state: up mac: <filter> 
           IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Drives:    Local Storage: total: 465.76 GiB used: 103.77 GiB (22.3%) 
           ID-1: /dev/sda vendor: Western Digital model: WDS500G2B0B-00YS70 size: 465.76 GiB 
Partition: ID-1: / size: 448.50 GiB used: 103.77 GiB (23.1%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 45.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 201 Uptime: 1h 24m Memory: 7.66 GiB used: 2.24 GiB (29.2%) Init: systemd Compilers: gcc: 8.2.1 
           clang: 8.0.0 Shell: zsh v: 5.7.1 inxi: 3.0.32