[Stable Update] 2019-03-21 - Kernels, Deepin, Browsers, Pamac, Plasma, Python

update
stable
#1

Hi community,

Welcome to our nineth stable update for 2019. So what do we have with this one?

  • we updated Plasma to 5.15.3
  • more Kernel updates
  • Deepin packages got renewed
  • we pushed out split packages for Pamac. Now you can decide if you want to use the CLI, GTK or Qt UI for your package management
  • lastest Python and Ruby package updates got added

We hope with all these changes Manjaro to be more efficient for you all.


CLT2019

Thx to everyone who visited our booth at #CLT2019 we were able to donate over 180 € to the pinguin foundation of Limbach Zoo

Manjaro v18.0.4 released!

We updated our flagship ISOs of Manjaro Illyria with the latest packages. It comes with refreshed packages and updated tools. You may want to download our XFCE Edition with the latest 4.13 packages, aswell as our most recent styling efforts. Our KDE fans may try our KDE Edition with the latest KDE v5.15 instead. And our GNOME fans may try our Gnome Edition with the latest GNOME v3.30.


Current supported Kernels

  • linux316 3.16.62
  • linux318 3.18.136 [EOL]
  • linux44 4.4.167 [FZN]
  • linux49 4.9.164
  • linux414 4.14.107
  • linux419 4.19.30
  • linux420 4.20.17 [EOL]
  • linux50 5.0.3
  • linux418-rt 4.18.16_rt9
  • linux419-rt 4.19.25_rt16

Package Updates (Thu Mar 14 19:29:11 CET 2019)

  • stable community x86_64: 265 new and 271 removed package(s)
  • stable core x86_64: 12 new and 14 removed package(s)
  • stable extra x86_64: 196 new and 193 removed package(s)
  • stable multilib x86_64: 5 new and 6 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-03-12           2019-03-21
-------------------------------------------------------------------------------
                 awesome-freedesktop       r102.4ead7a4-1       r104.3f2d23c-1
                             beshell         2013.07.29-1                    -
                              etcher              1.4.9-1              1.5.5-1
                          gimp-devel             2.10.2-1                    -
            kde-servicemenus-dropbox             0.16.1-9                    -
                     kvantum-manjaro             0.12.0-1             0.13.0-1
                 kvantum-manjaro-dev             0.12.1-1                    -
                                lain      r1669.f6e032f-1      r1690.013654c-1
       manjaro-awesome-settings-18.0           20181113-1           20190313-1
              manjaro-theme-settings           20190309-1           20190312-1
                    matcha-gtk-theme           20190225-1           20190309-1
                            razor-qt              0.5.2-1                    -
                       terminus-font             4.46-1.1                    -
                         vlc-nightly     3.0.5v20181009-1                    -
                            gestures                    -              0.2.2-3
                       hplip-minimal                    -             3.18.9-1
                   libinput-gestures                    -               2.41-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-03-12           2019-03-21
-------------------------------------------------------------------------------
                      acpi_call-dkms            1.1.0-197            1.1.0-198
                         aj-snapshot              0.9.8-1              0.9.9-1
                               arcus              3.6.0-1              3.6.0-2
                         arduino-cli0.3.4.alpha.preview-10.3.6.alpha.preview-1
                             aws-cli           1.16.117-1           1.16.122-1
                         bitcoin-cli             0.17.1-1             0.17.1-2
                      bitcoin-daemon             0.17.1-1             0.17.1-2
                          bitcoin-qt             0.17.1-1             0.17.1-2
                          bitcoin-tx             0.17.1-1             0.17.1-2
                                cgns              3.3.1-7              3.4.0-1
                          clementine             1.3.1-20             1.3.1-21
                          cockatrice              2.6.2-1              2.7.0-2
                                code             1.32.1-1             1.32.2-1
                            collectd              5.8.1-3              5.8.1-4
                          containerd              1.2.0-3              1.2.5-1
                      cryptominisat5              5.6.8-1              5.6.8-2
                          curaengine              3.6.0-1              3.6.0-2
               deepin-control-center              4.9.6-1              4.9.7-1
                         deepin-dock              4.9.0-1            4.9.1.1-1
                 deepin-file-manager          1:4.7.7.2-1          1:4.7.7.3-1
                deepin-network-utils              0.0.9-1              0.1.0-1
                       deepin-topbar              0.6.2-1              0.6.2-2
                             dovecot              2.3.5-1              2.3.5-2
                              drupal             8.6.10-1             8.6.11-1
                                 dtc              1.4.7-1              1.5.0-1
                              erlang               21.2-1               21.3-1
                         erlang-docs               21.1-1               21.3-1
                          erlang-nox               21.2-1               21.3-1
                     erlang-unixodbc               21.2-1               21.3-1
                           etherwall              2.3.1-1              2.3.1-2
                firefox-adblock-plus              3.4.3-1                3.5-1
           firefox-developer-edition            66.0b13-1             67.0b1-1
  firefox-developer-edition-i18n-ach            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-af            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-an            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-ar            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-as            66.0b13-1             67.0b1-1
  firefox-developer-edition-i18n-ast            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-az            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-be            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-bg            66.0b13-1             67.0b1-1
firefox-developer-edition-i18n-bn-bd            66.0b13-1             67.0b1-1
firefox-developer-edition-i18n-bn-in            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-br            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-bs            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-ca            66.0b13-1             67.0b1-1
  firefox-developer-edition-i18n-cak            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-cs            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-cy            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-da            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-de            66.0b13-1             67.0b1-1
  firefox-developer-edition-i18n-dsb            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-el            66.0b13-1             67.0b1-1
firefox-developer-edition-i18n-en-gb            66.0b13-1             67.0b1-1
firefox-developer-edition-i18n-en-us            66.0b13-1             67.0b1-1
firefox-developer-edition-i18n-en-za            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-eo            66.0b13-1             67.0b1-1
firefox-developer-edition-i18n-es-ar            66.0b13-1             67.0b1-1
firefox-developer-edition-i18n-es-cl            66.0b13-1             67.0b1-1
firefox-developer-edition-i18n-es-es            66.0b13-1             67.0b1-1
firefox-developer-edition-i18n-es-mx            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-et            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-eu            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-fa            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-ff            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-fi            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-fr            66.0b13-1             67.0b1-1
firefox-developer-edition-i18n-fy-nl            66.0b13-1             67.0b1-1
firefox-developer-edition-i18n-ga-ie            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-gd            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-gl            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-gn            66.0b13-1             67.0b1-1
firefox-developer-edition-i18n-gu-in            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-he            66.0b13-1             67.0b1-1
firefox-developer-edition-i18n-hi-in            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-hr            66.0b13-1             67.0b1-1
  firefox-developer-edition-i18n-hsb            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-hu            66.0b13-1             67.0b1-1
firefox-developer-edition-i18n-hy-am            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-ia            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-id            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-is            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-it            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-ja            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-ka            66.0b13-1             67.0b1-1
  firefox-developer-edition-i18n-kab            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-kk            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-km            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-kn            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-ko            66.0b13-1             67.0b1-1
  firefox-developer-edition-i18n-lij            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-lt            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-lv            66.0b13-1             67.0b1-1
  firefox-developer-edition-i18n-mai            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-mk            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-ml            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-mr            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-ms            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-my            66.0b13-1             67.0b1-1
firefox-developer-edition-i18n-nb-no            66.0b13-1             67.0b1-1
firefox-developer-edition-i18n-ne-np            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-nl            66.0b13-1             67.0b1-1
firefox-developer-edition-i18n-nn-no            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-or            66.0b13-1             67.0b1-1
firefox-developer-edition-i18n-pa-in            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-pl            66.0b13-1             67.0b1-1
firefox-developer-edition-i18n-pt-br            66.0b13-1             67.0b1-1
firefox-developer-edition-i18n-pt-pt            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-rm            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-ro            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-ru            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-si            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-sk            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-sl            66.0b13-1             67.0b1-1
  firefox-developer-edition-i18n-son            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-sq            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-sr            66.0b13-1             67.0b1-1
firefox-developer-edition-i18n-sv-se            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-ta            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-te            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-th            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-tr            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-uk            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-ur            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-uz            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-vi            66.0b13-1             67.0b1-1
   firefox-developer-edition-i18n-xh            66.0b13-1             67.0b1-1
firefox-developer-edition-i18n-zh-cn            66.0b13-1             67.0b1-1
firefox-developer-edition-i18n-zh-tw            66.0b13-1             67.0b1-1
               firefox-ublock-origin             1.18.4-1             1.18.6-1
                          fltk-games            1.3.4.2-3                    -
                               fstrm              0.4.0-1              0.5.0-1
                                gcin              2.8.8-1              2.8.9-1
                             git-lfs              2.6.1-2              2.7.1-1
                               gitea              1.7.3-1              1.7.4-1
                               glava              1.6.0-1              1.6.3-1
                    gnome-packagekit             3.30.0-1             3.32.0-1
                              gopass              1.8.4-2              1.8.5-1
                            hyperion            1.03.2-16            1.03.2-17
                             jenkins              2.167-1              2.168-1
                              jgmenu                1.6-1                2.2-1
                                knot              2.7.6-2              2.8.0-1
                           libgexiv2             0.10.8-2             0.12.0-1
                                lmms           1.2.0rc8-1           1.2.0rc8-2
                      magnum-plugins            2018.10-1            2019.01-1
                               mixxx              2.2.0-1              2.2.0-2
                                mosh              1.3.2-6              1.3.2-7
                              mumble            1.2.19-12            1.2.19-13
                              murmur            1.2.19-13            1.2.19-14
                           musescore              3.0.4-1              3.0.5-1
                                mypy              0.660-1              0.670-1
                             netdata             1.12.1-1             1.12.2-1
                             notmuch             0.28.2-1             0.28.3-1
                        notmuch-mutt             0.28.2-1             0.28.3-1
                     notmuch-runtime             0.28.2-1             0.28.3-1
                         notmuch-vim             0.28.2-1             0.28.3-1
                   npm-check-updates              3.0.4-1              3.0.8-1
                              nsjail                2.8-1                2.8-2
                               opera       58.0.3135.90-1      58.0.3135.107-1
                    otf-font-awesome              5.7.0-1              5.7.2-1
                       pantheon-code              3.0.2-1              3.1.0-1
                            paraview              5.6.0-2              5.6.0-4
                     perl-test-inter               1.07-2               1.08-1
                                 pm2              3.3.1-1              3.4.0-1
                              polyml              5.7.1-2                5.8-1
                             postgis              2.5.1-1              2.5.1-2
                            powerdns              4.1.6-1              4.1.6-2
                   powerdns-recursor             4.1.11-1             4.1.11-2
                        pulseeffects              4.5.5-1              4.5.6-1
                    pyopencl-headers         1:2018.2.4-1         1:2018.2.5-1
                     python-apptools              4.4.0-3              4.4.0-4
                      python-awkward             0.8.10-1             0.8.11-1
                        python-black             18.9b0-3             19.3b0-1
                        python-boto3            1.9.107-1            1.9.112-1
                     python-botocore           1.12.107-1           1.12.112-1
                      python-certifi         2018.11.29-1           2019.3.9-1
                     python-cfn-lint             0.15.0-1             0.16.0-1
                         python-cmd2             0.9.10-1             0.9.11-1
                    python-cysignals             1.10.0-1             1.10.2-1
                     python-envisage              4.7.1-1              4.7.1-2
                   python-hypothesis              4.9.0-1             4.11.5-1
                 python-openstacksdk             0.25.0-1             0.26.0-1
                        python-patsy              0.5.1-1              0.5.1-2
                       python-prance             0.14.1-1             0.15.0-1
                       python-psutil              5.5.0-1              5.6.0-1
                       python-pyface              6.0.0-4              6.0.0-5
                    python-pykeepass              3.0.3-1              3.0.3-2
                     python-pyopencl         1:2018.2.4-1         1:2018.2.5-1
                       python-pytest              4.3.0-1              4.3.1-1
                python-requests-file              1.4.3-2              1.4.3-3
                 python-requests-ftp              0.3.1-2              0.3.1-3
                         python-rope             0.11.0-1             0.12.0-1
                      python-seaborn              0.9.0-3              0.9.0-4
                  python-statsmodels              0.9.0-2              0.9.0-3
                 python-testfixtures              6.6.0-1              6.6.1-1
                       python-traits              5.0.0-1              5.0.0-2
                     python-traitsui              6.0.0-2              6.0.0-3
       python-unittest-xml-reporting              2.2.1-1              2.3.2-1
                    python2-apptools              4.4.0-3                    -
                       python2-boto3            1.9.107-1            1.9.112-1
                    python2-botocore           1.12.107-1           1.12.112-1
                     python2-certifi         2018.11.29-1           2019.3.9-1
                   python2-cysignals             1.10.0-1             1.10.2-1
                    python2-envisage              4.7.1-1                    -
                  python2-hypothesis              4.9.0-1             4.11.5-1
                python2-openstacksdk             0.25.0-1             0.26.0-1
                       python2-patsy              0.5.1-1                    -
                      python2-prance             0.14.1-1             0.15.0-1
                      python2-psutil              5.5.0-1              5.6.0-1
                      python2-pyface              6.0.0-4                    -
                      python2-pytest              4.3.0-1              4.3.1-1
               python2-requests-file              1.4.3-2                    -
                python2-requests-ftp              0.3.1-2                    -
                        python2-rope             0.11.0-1             0.12.0-1
                     python2-seaborn              0.9.0-3                    -
                 python2-statsmodels              0.9.0-2                    -
                python2-testfixtures              6.6.0-1              6.6.1-1
                      python2-traits              5.0.0-1                    -
                    python2-traitsui              6.0.0-2                    -
      python2-unittest-xml-reporting              2.2.1-1              2.3.2-1
                                qcad           3.22.0.1-1           3.22.0.2-1
                            qjackctl              0.5.5-1              0.5.6-1
                            qsampler              0.5.3-1              0.5.4-1
                              qsynth              0.5.4-2              0.5.5-1
                             qxgedit              0.5.2-1              0.5.3-1
                              remacs              0.0.0-1            27.0.50-1
                             remmina            1:1.3.3-1            1:1.3.4-1
                            ruby-atk              3.3.2-1              3.3.3-1
                  ruby-cairo-gobject              3.3.2-1              3.3.3-1
                           ruby-gdk3              3.3.2-1              3.3.3-1
                    ruby-gdk_pixbuf2              3.3.2-1              3.3.3-1
                           ruby-gio2              3.3.2-1              3.3.3-1
                          ruby-glib2              3.3.2-1              3.3.3-1
          ruby-gobject-introspection              3.3.2-1              3.3.3-1
                           ruby-gtk2              3.3.2-1              3.3.3-1
                          ruby-pango              3.3.2-1              3.3.3-1
                     ruby-pkg-config              1.3.1-2              1.3.6-1
                               shfmt              2.6.3-1              2.6.4-1
                          stone-soup             0.22.1-1             0.23.1-1
                          strawberry              0.5.2-1              0.5.2-2
                                sway                1.0-1                1.0-4
                           terraform            0.11.12-1            0.11.13-1
                               tiled              1.2.2-1              1.2.3-1
                    ttf-font-awesome              5.7.0-1              5.7.2-1
                        ttf-ibm-plex              1.2.3-1              1.3.0-1
                             udiskie              1.7.5-2              1.7.7-1
                             umurmur            0.2.17-12            0.2.17-13
                             unbound              1.9.0-1              1.9.1-1
                         virt-viewer                7.0-3                8.0-1
                                 vtk              8.2.0-1              8.2.0-2
                           wordpress                5.1-1              5.1.1-1
                               xfmpc              0.2.3-3             0.2.90-1
                          xtrabackup              8.0.4-2              8.0.5-1
                                yarn             1.13.0-1             1.15.0-1
                             yoshimi             1.5.10-2           1.5.10.2-1
                     yubikey-manager              2.0.0-1              2.1.0-1
                  yubikey-manager-qt              1.1.0-1              1.1.1-1
                               ciano                    -              0.2.1-1
                              geotag                    -              0.103-2
                             offroad                    -                0.2-1
                       otter-browser                    -             1.0.01-2
           otter-browser-nowebengine                    -             1.0.01-2
            sugar-activity-turtleart                    -                218-1
                            swayidle                    -                1.2-2
                            swaylock                    -                1.3-3
                              waybar                    -              0.4.0-1


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-03-12           2019-03-21
-------------------------------------------------------------------------------
                               glib2             2.58.3-1                    -
                          glib2-docs             2.58.3-1                    -
                            linux414           4.14.105-1           4.14.107-1
                    linux414-headers           4.14.105-1           4.14.107-1
                            linux419            4.19.28-1            4.19.30-1
                    linux419-headers            4.19.28-1            4.19.30-1
                            linux420            4.20.15-1            4.20.17-1
                    linux420-headers            4.20.15-1            4.20.17-1
                             linux49            4.9.162-1            4.9.164-1
                     linux49-headers            4.9.162-1            4.9.164-1
                             linux50              5.0.1-1              5.0.3-1
                     linux50-headers              5.0.1-1              5.0.3-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-03-12           2019-03-21
-------------------------------------------------------------------------------
                           e2fsprogs             1.44.6-1             1.45.0-1
                                nspr               4.20-1               4.21-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-03-12           2019-03-21
-------------------------------------------------------------------------------
                     gtk-xfce-engine           2.10.1-1.1                    -
                        gtk3-classic             3.24.5-1             3.24.7-1
                         kinfocenter             5.15.2-1             5.15.3-1
                  linux414-acpi_call             1.1.0-84             1.1.0-85
                   linux414-bbswitch               0.8-84               0.8-85
                linux414-broadcom-wl      6.30.223.271-84      6.30.223.271-85
                   linux414-catalyst     1:15.201.1151-84     1:15.201.1151-85
                linux414-ndiswrapper              1.61-84              1.61-85
                     linux414-nvidia           1:418.43-3           1:418.43-4
               linux414-nvidia-340xx           340.107-43           340.107-44
               linux414-nvidia-390xx            390.116-2            390.116-3
                   linux414-nvidiabl              0.88-84              0.88-85
                      linux414-r8168          8.045.08-72          8.045.08-73
                  linux414-rt3562sta        2.4.1.1_r4-84        2.4.1.1_r4-85
                        linux414-spl             0.7.13-1             0.7.13-2
                   linux414-tp_smapi              0.41-84              0.41-85
                linux414-vhba-module          20161009-84          20161009-85
   linux414-virtualbox-guest-modules              6.0.4-7              6.0.4-8
    linux414-virtualbox-host-modules              6.0.4-7              6.0.4-8
                        linux414-zfs             0.7.13-1             0.7.13-2
                  linux419-acpi_call             1.1.0-23             1.1.0-25
                   linux419-bbswitch               0.8-23               0.8-25
                linux419-broadcom-wl      6.30.223.271-23      6.30.223.271-25
                   linux419-catalyst     1:15.201.1151-23     1:15.201.1151-25
                linux419-ndiswrapper              1.61-23              1.61-25
                     linux419-nvidia           1:418.43-5           1:418.43-7
               linux419-nvidia-340xx           340.107-23           340.107-25
               linux419-nvidia-390xx            390.116-3            390.116-5
                   linux419-nvidiabl              0.88-23              0.88-25
                      linux419-r8168          8.045.08-23          8.045.08-25
                        linux419-spl             0.7.13-2             0.7.13-4
                   linux419-tp_smapi              0.41-23              0.41-25
                linux419-vhba-module          20161009-23          20161009-25
   linux419-virtualbox-guest-modules             6.0.4-10             6.0.4-12
    linux419-virtualbox-host-modules             6.0.4-10             6.0.4-12
                        linux419-zfs             0.7.13-2             0.7.13-4
                  linux420-acpi_call             1.1.0-13             1.1.0-15
                   linux420-bbswitch               0.8-13               0.8-15
                linux420-broadcom-wl      6.30.223.271-13      6.30.223.271-15
                   linux420-catalyst     1:15.201.1151-13     1:15.201.1151-15
                linux420-ndiswrapper              1.61-13              1.61-15
                     linux420-nvidia           1:418.43-5           1:418.43-7
               linux420-nvidia-340xx           340.107-13           340.107-15
               linux420-nvidia-390xx            390.116-3            390.116-5
                   linux420-nvidiabl              0.88-13              0.88-15
                      linux420-r8168          8.045.08-13          8.045.08-15
                        linux420-spl             0.7.13-2             0.7.13-4
                   linux420-tp_smapi              0.41-13              0.41-15
                linux420-vhba-module          20161009-13          20161009-15
   linux420-virtualbox-guest-modules              6.0.4-9             6.0.4-11
    linux420-virtualbox-host-modules              6.0.4-9             6.0.4-11
                        linux420-zfs             0.7.13-2             0.7.13-4
                   linux49-acpi_call            1.1.0-117            1.1.0-118
                    linux49-bbswitch              0.8-117              0.8-118
                 linux49-broadcom-wl     6.30.223.271-117     6.30.223.271-118
                    linux49-catalyst    1:15.201.1151-117    1:15.201.1151-118
                 linux49-ndiswrapper             1.61-115             1.61-116
                      linux49-nvidia           1:418.43-2           1:418.43-3
                linux49-nvidia-340xx           340.107-36           340.107-37
                linux49-nvidia-390xx            390.116-1            390.116-2
                    linux49-nvidiabl             0.88-117             0.88-118
                       linux49-r8168          8.045.08-57          8.045.08-58
                   linux49-rt3562sta       2.4.1.1_r4-115       2.4.1.1_r4-116
                         linux49-spl             0.7.13-1             0.7.13-2
                    linux49-tp_smapi             0.41-117             0.41-118
                 linux49-vhba-module         20161009-115         20161009-116
    linux49-virtualbox-guest-modules              6.0.4-6              6.0.4-7
     linux49-virtualbox-host-modules              6.0.4-6              6.0.4-7
                         linux49-zfs             0.7.13-1             0.7.13-2
                               pamac              7.3.4-2                    -
                            pamac-qt              0.1.6-1            0.2.0-0.1
             pamac-tray-appindicator              7.3.4-2              7.3.5-2
                            qt5-base           5.12.1-2.1           5.12.1-3.1
             qt5-xcb-private-headers           5.12.1-2.1           5.12.1-3.1
                         thunderbird             60.6.0-0           60.6.0-0.1
                gnome-control-center                    -3.30.3+4+g26287234b-1
                           pamac-cli                    -              7.3.5-2
                        pamac-common                    -              7.3.5-3
                           pamac-gtk                    -              7.3.5-2


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-03-12           2019-03-21
-------------------------------------------------------------------------------
                         at-spi2-atk             2.30.1-1             2.32.0-1
                        at-spi2-core             2.30.1-1             2.32.0-1
                                 atk             2.30.0-1               2.32-1
                              baobab             3.30.0-1             3.32.0-1
                           bluedevil           1:5.15.2-1           1:5.15.3-1
                              breeze             5.15.2-1             5.15.3-1
                         breeze-grub             5.15.2-1             5.15.3-1
                          breeze-gtk             5.15.2-1             5.15.3-1
                            chromium      72.0.3626.121-1       73.0.3683.75-1
                            clawsker              1.3.0-1              1.3.1-1
                               dconf             0.30.1-1             0.32.0-1
                            discover             5.15.2-1             5.15.3-1
                   double-conversion              3.1.1-1              3.1.4-1
                             drkonqi             5.15.2-1             5.15.3-1
                            efitools              1.8.1-1              1.9.2-1
                                 eog 3.28.4+5+ge02a9ae0-1             3.32.0-1
                            epiphany             3.30.3-1             3.32.0-1
                         file-roller             3.30.1-1             3.32.0-1
                         flashplugin         32.0.0.142-1         32.0.0.156-1
                         foomatic-db         3:20190301-1         3:20190312-1
                 foomatic-db-nonfree         3:20190301-1         3:20190312-1
            foomatic-db-nonfree-ppds         3:20190301-1         3:20190312-1
                    foomatic-db-ppds         3:20190301-1         3:20190312-1
                               gedit             3.30.2-1             3.32.0-1
                        geocode-glib             3.26.0-1             3.26.1-1
                     glib-networking             2.58.0-1           2.60.0.1-1
                                  gn    0.1497.13ac6ca4-1    0.1538.74657a61-1
               gobject-introspection             1.58.3-1             1.60.0-1
       gobject-introspection-runtime             1.58.3-1             1.60.0-1
                               grilo              0.3.6-1              0.3.7-1
               gtk-update-icon-cache             3.24.5-1             3.24.7-1
                                gtk3             3.24.5-1             3.24.7-1
                               hefur                0.6-5                0.6-6
                   kactivitymanagerd             5.15.2-1             5.15.3-1
                       kde-cli-tools             5.15.2-1             5.15.3-1
                      kde-gtk-config             5.15.2-1             5.15.3-1
                         kdecoration             5.15.2-1             5.15.3-1
                    kdeplasma-addons             5.15.2-1             5.15.3-1
                           kdoctools             5.56.0-1             5.56.0-2
                             kgamma5             5.15.2-1             5.15.3-1
                            khotkeys             5.15.2-1             5.15.3-1
                         kinfocenter             5.15.2-1             5.15.3-1
                           kirigami2             5.56.0-2             5.56.1-1
                           kmenuedit             5.15.2-1             5.15.3-1
                          knetattach             5.15.2-1             5.15.3-1
                             kscreen             5.15.2-1             5.15.3-1
                       kscreenlocker             5.15.2-1             5.15.3-1
                         ksshaskpass             5.15.2-1             5.15.3-1
                           ksysguard             5.15.2-1             5.15.3-1
                         kwallet-pam             5.15.2-1             5.15.3-1
                kwayland-integration             5.15.2-1             5.15.3-1
                                kwin             5.15.2-1             5.15.3-1
                             kwrited             5.15.2-1             5.15.3-1
                                 ldb            1:1.4.3-1            1:1.4.6-1
                           libdazzle             3.30.2-1             3.32.0-1
                             libebml              1.3.6-1              1.3.7-1
                             libgadu             1.12.2-6             1.12.2-8
                          libkscreen             5.15.2-1             5.15.3-1
                        libksysguard             5.15.2-1             5.15.3-1
                         libmatroska              1.4.9-1              1.5.0-1
                      libphonenumber             8.10.1-2             8.10.6-1
                             libsoup             2.64.2-1             2.66.0-1
                  libva-vdpau-driver              0.7.4-3              0.7.4-4
                         libwbclient              4.9.4-2              4.9.5-1
                            lua-lpeg              1.0.1-2              1.0.2-1
                          lua51-lpeg              1.0.1-2              1.0.2-1
                          lua52-lpeg              1.0.1-2              1.0.2-1
                             mariadb            10.3.13-3            10.3.13-4
                     mariadb-clients            10.3.13-3            10.3.13-4
                        mariadb-libs            10.3.13-3            10.3.13-4
                               milou             5.15.2-1             5.15.3-1
                      mkvtoolnix-cli             31.0.0-1             32.0.0-1
                      mkvtoolnix-gui             31.0.0-1             32.0.0-1
                                mutt             1.11.3-2             1.11.4-1
                               mytop            10.3.13-3            10.3.13-4
                                 ntp          4.2.8.p12-2          4.2.8.p13-2
                              oxygen             5.15.2-1             5.15.3-1
                        pepper-flash         32.0.0.142-1         32.0.0.156-1
          plasma-browser-integration             5.15.2-1             5.15.3-1
                      plasma-desktop             5.15.2-1             5.15.3-1
                    plasma-framework             5.56.0-2             5.56.1-1
                  plasma-integration             5.15.2-1             5.15.3-1
                           plasma-nm             5.15.2-1             5.15.3-1
                           plasma-pa             5.15.2-1             5.15.3-1
                          plasma-sdk             5.15.2-1             5.15.3-1
                        plasma-vault             5.15.2-1             5.15.3-1
              plasma-wayland-session             5.15.2-1             5.15.3-1
                    plasma-workspace             5.15.2-1             5.15.3-1
         plasma-workspace-wallpapers             5.15.2-1             5.15.3-1
                    polkit-kde-agent             5.15.2-1             5.15.3-1
                          postgresql               11.1-3               11.2-1
                     postgresql-docs               11.1-3               11.2-1
                     postgresql-libs               11.1-3               11.2-1
                          powerdevil             5.15.2-2             5.15.3-1
                            protobuf            3.6.1.3-1              3.7.0-1
                          protobuf-c              1.3.1-1              1.3.1-2
                     python-protobuf            3.6.1.3-1              3.7.0-1
                    python2-protobuf            3.6.1.3-1              3.7.0-1
                            qt5-base             5.12.1-2             5.12.1-3
             qt5-xcb-private-headers             5.12.1-2             5.12.1-3
                               samba              4.9.4-2              4.9.5-1
                         sbsigntools              0.9.1-1              0.9.2-1
                            sddm-kcm             5.15.2-1             5.15.3-1
                           smbclient              4.9.4-2              4.9.5-1
                      systemsettings             5.15.2-1             5.15.3-1
                              talloc             2.1.14-1             2.1.16-1
                                 tdb             1.3.16-1             1.3.18-1
                              tevent           1:0.9.37-1           1:0.9.39-1
                             udisks2              2.8.1-1              2.8.2-1
                              upower             0.99.9-1            0.99.10-1
                            usbguard              0.7.4-4              0.7.4-5
                         usbguard-qt              0.7.4-4              0.7.4-5
                        user-manager             5.15.2-1             5.15.3-1
                                 vlc              3.0.6-8              3.0.6-9
                          webkit2gtk             2.22.7-1             2.24.0-1
              xdg-desktop-portal-kde             5.15.2-1             5.15.3-1
        xf86-video-intel 1:2.99.917+860+g3a2dec17-1 1:2.99.917+863+g6afed33b-1
                          yelp-tools             3.28.0-1             3.32.0-1
                            yelp-xsl             3.30.1-1             3.32.0-1
                    mallard-ducktype                    -                0.4-1


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-03-12           2019-03-21
-------------------------------------------------------------------------------
                         lib32-glib2             2.58.3-1                    -
                  lib32-gtk3-classic             3.24.5-1             3.24.7-1


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-03-12           2019-03-21
-------------------------------------------------------------------------------
                         lib32-dconf             0.30.1-1             0.32.0-1
             lib32-nvidia-cg-toolkit                3.1-6                3.1-7
                          lib32-pcre               8.42-1               8.43-1
                           lib32-tcl              8.6.9-1              8.6.9-2
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

41 Likes

Manjaro-Cinnamon 18.0.4 released
Pre stable update: removing VLC-nightly will also take out Gwenview
Xorg progressively uses more video memory the longer I keep my computer on
#2

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed


“Replace pamac with extra/pamac-gtk? [Y/n]”

Accept the replacement. The original pamac package is now split into three packages: pamac-gtk, pamac-cli and pamac-common.


vlc-nightly has been dropped

The vlc-nightly package, which was really useful in a time when VLC 3 was not officially out yet, has been dropped on our side and is not in the official repositories anymore. If you still have this package and you want the latest stable version of VLC media player, simply install the vlc package (the vlc-nightly package should be removed at the same time, in the same transaction).

Otherwise, you can continue to use vlc-nightly from the AUR (but you’ll have to compile it yourself).


Submenus in Thunar (File Manager in Xfce) issue

Submenus may not display correctly in Thunar. The same kind of issue also appears on Arch Linux forum (see those threads, #1, #2). It has been reported to the XFCE bug tracker too.

A known workaround is to downgrade lib32-gtk3-classic (if you have it), then gtk3-classic from version 3.24.7-1 to 3.24.5-1 (a simple log-out->log-in, or a reboot may be required). If you use gtk3 package instead of gtk3-classic, you can try the same kind of steps, but with lib32-gtk3 and gtk3 packages instead.

Please note that is is merely a temporary workaround and not a definitive, long term fix. You should not keep the downgrade forever, doing so may cause other problems in the future. Also, it is not guaranteed that downgrading those packages will not cause issues in other programs.


“NOTE, 4.20.17 was the last maintenance release by Greg Kroah-Hartman.; It is recommend to move on to linux50-series.” What should I do?

Linux 4.20 (which is not an LTS kernel) is now marked as End Of Life (EOL), so if you want to continue to use an non-LTS kernel, you should consider using Linux 5.0, and also uninstall kernel 4.20 soon.

Keeping EOL kernel installed on your system for too long can lead up to problems for future upgrades (especially if using NVIDIA drivers). When using non-LTS kernel, you must do maintenance/cleanup more often.


Items from previous update sets

" Replace xorg-mkfontdir with extra/xorg-mkfontscale? [Y/n]"

Accept the replacement.


Linux kernel 5.0.X available. Early problems reported.

The newest kernel series is now available for everyone. Please note that some issues has been reported with version 5.0.1 such as having a long delay at shutdown and losing sound output when using suspend. It is still available for the early adopters. You are free to install and use it or not.

As reported by some users, if you use WireGuard, you may have to manually run sudo dkms autoinstall in a terminal to get the kernel module working properly with Linux 5.0.1.
More info about dkms autoinstall (and DKMS in general) here.


Kodi 18.1: extensions may not work properly.

Kodi 18.1 is now available in our repositories. Since this is a major version change, extensions for Kodi (if you use some) may stop working properly. Developers of those extensions will need to make them compatible with Kodi 18.

If Kodi 18.1 doesn’t work properly for you and you absolutely need to use your extensions, you may use the old kodi package in /var/cache/pacman/pkg in order to downgrade Kodi to version 17.6. Please note that it is a temporary workaround and that the software provided in the old kodi package may stop working properly in the future too. You should not keep the downgrade forever.


ProjectM: projectm-pulseaudio v.s. projectm-qt, file conflict with /usr/share/pixmaps/prjm16-transparent.svg

Starting with version 3.1.0 of ProjectM, there are now only three packages instead of six and the QT part has been merged to the projectm-pulseaudio package.

Remove the projectm-qt package before upgrading your system.


If you have not kept up with [Stable Update] 2019-02-19 yet, please read the information below too.

How do I do updates via TTY-terminal?

This is a really major update release, with a lot of changes. To limit the risk of breakage in the middle of an system upgrade (which could lead to a broken system that will need to be repaired), you may want to do the system upgrade within a minimalist command-line environment. To do so:

  • Press CTRL+ALT+F2 (or F3, F4, F5, F6) to go into a pure command line interface.
  • Log in with your credentials.
  • Once logged in, you’ll have access to a CLI shell, like if you were using a terminal. Use sudo pacman -Syyu to update your system.

To go back to your regular desktop, press CTRL+ALT+F7. On some systems, it can be CTRL+ALT+F1 instead.

Systemd v241 series update

We tried to update systemd several times now in the last couple of month. Now we were certain to have a good snapshot, which works on most of Manjaro installations. When you are asked to replace libsystemd with systemd-libs please accept this request, otherwise your system may break!


“A stop job is running for User Manager for UID 1000” at shutdown/reboot, what should I do?

Stopping of the User Manager job may take 2 minutes due to the systemd update. Simply wait and let it go. It usually goes away at next boot.


Update is not proceeding due file conflicts

It is a common issue time to time to get errors like this:

python-pyqt5: /usr/lib/python3.7/site-packages/PyQt5/pycache/init.cpython-37.pyc already exists in filesystem

Especially with pycache files, you shouldn’t worry about. Simply delete the conflicting file(s) or use the overwrite function of pacman to continue the update.

sudo pacman -S python-pyqt5 --overwrite ‘*’


Plasma will not reboot from the Application Launcher

If you update from within Plasma (e.g. from the konsole), you may need to issue a systemctl reboot to reboot.


KDE Plasma5 may crash with this update

Due to our long-term testing of v5.15.0 release on some rare edge cases your Plasma5 may crash during this update. If that happens you have to switch to a TTY (Ctrl+ALT+F3), login and check with a cli-package-manager if your update is fully updated!

Pacman

sudo rm /var/lib/pacman/db.lck && sudo pacman -Su

Pamac

sudo rm /var/lib/pacman/db.lck && pamac upgrade


Various issues when using LibreOffice 6.2.0 on KDE Plasma 5 (can’t copy+paste, can’t use backspace in Calc, etc.)

Unfortunately, it seems that the new upstream VCL plugin for integration in KDE5 Plasma (see this notice from LibreOffice) isn’t perfectly functional yet. Upstream is aware of the situation and fixes will come in future versions of LibreOffice.

Examples of related bug reports from the Document Foundation
https://bugs.documentfoundation.org/show_bug.cgi?id=122689
https://bugs.documentfoundation.org/show_bug.cgi?id=122238

Workaround for LibreOffice 6.2.0: you may force Libre Office to use a different VCL by editing /etc/profile.d/libreoffice-fresh.sh, uncommenting the VCL you want to use, and rebooting.
More info about VCL: https://wiki.archlinux.org/index.php/LibreOffice#Theme

You may also consider to switch from LibreOffice Fresh to LibreOffice Still, the latter being at version 6.1.5.


Even older items

Can’t update with linux417 or/and linux418 present

Since we have completely removed those kernel series you should remove those kernels before you upgrade. Most likely you will notice that as you may have extramodules like nvidia installed. Those got updated and therefore complain about dependency issues.


Notifications looking weird in XFCE

Since the package dunst includes now dunstfy in the main package notifications may not displayed properly in XFCE. Please uninstall that package to solve that issue. Normally not needed in that edition.


Potential issues with dunstify-1.3.2-1 package

Upstream decided to include dunstify now in the dunst package. However, they didn’t add any replace, conflicts tags to that package, as Arch never packaged dunstify before. Therefore we try to remove dunstify automatically via manjaro-system package. On rare cases however, a manual user invention might be needed to remove the package. If that is the case, please issue the following command manually on your system: sudo pacman -Rdd dunstify && sudo pacman -Syu


Warning: PACKAGE: directory permissions differ on FILENAME

A file or directory on your system has a set of permissions which is different to those in the new package. You can either ignore it (because you changed it yourself) or you can change them so they match.

For example, for this message:

Warning: blueman: directory permissions differ on /usr/share/polkit-1/rules.d/filesystem: 750  package: 755

you can change the local file to match the package with:

sudo chmod 755 /usr/share/polkit-1/rules.d/filesystem

i3 changed its default config path

It seems that (from version >= 4.16) i3 is looking for its configuration in ~/.config/i3/config instead of ~/.i3/config.
Copy your config to the new path and all should work as before. (reported from an i3-gaps user).


I can’t open Nemo with elevated privileges (as root)

Workaround found: Use the dbus-x11 package instead of the regular dbus package. This package is available in the official repositories and provides dbus compiled without the --without-x option.

To replace dbus with dbus-x11 package, simply install dbus-x11 with your favorite package manager: dbus will be replaced by dbus-x11.


AMD-Ucode introduction

Unless you’ve already done this previously, All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.

6 Likes

[Solved] Create Document in Thunar
Pulseaudio forgets headphones are plugged in after resume from suspend
Pre stable update: removing VLC-nightly will also take out Gwenview
Is Thunar (XFCE) right click - create new document menu gone?
Paketverwaltung will updates nicht installieren/ Konnte Datei .... nicht finden
Update vlc-nightly
Neues dokument erstellen in thunar kontextmenu
VLC AUR nightly version in Manjaro official release?
thunar dies at least once a day
#3

It was first time when i use yay -Syyu. Everything went perfectly.
Also I noticed a message with recommendation to switch to kernel5. I decided it’s a good point to follow the recommendation. Also no issues at all.

P.S. is it safe to use alternately pacman and yay?

2 Likes

#4

Thx for another smooth update! (KDE Plasma, Nvidia, Kernel 5.0)

1 Like

#5

Yes, I generally use pacman for repos and yay for aur. But yay should pass repo actions to pacman by default.

As to the kernel - that is still a miswording or misreading. See the dozen or so topics on it.
And look in MSM for what is actually ‘recommended’. If 5.0 works for you though, cool.

(I said that then, but realized I do not have access to do it myself :cry:)

1 Like

#6

Here is exactly the message:

[2019-03-21 21:17] [ALPM-SCRIPTLET] NOTE, 4.20.17 was the last maintenance release by Greg Kroah-Hartman.
[2019-03-21 21:17] [ALPM-SCRIPTLET]
[2019-03-21 21:17] [ALPM-SCRIPTLET] It is recommend to move on to linux50-series.
[2019-03-21 21:17] [ALPM-SCRIPTLET] Use followed cmd to do that: ‘sudo mhwd-kernel -i linux50’

Looks little bit different to gitlab page.

1 Like

#7

It is indeed correct. Linux 4.20 (which is not an LTS) is now marked as End Of Life (EOL), so if you want to continue to use an non-LTS kernel, you should consider using Linux 5.0, and also uninstall kernel 4.20 soon.

Keeping EOL kernel installed on your system for too long can lead up to problems for future upgrades (notably if you use NVIDIA drivers, see people who weren’t able to upgrade because they kept Linux 4.18 for too long for example). When using non-LTS kernel, you must do maintenance/cleanup more often.

5 Likes

#8

Oh - thats because 4.20 is becoming EOL.
The current recommended and LTS is 4.19.
But again, if 5.0 works, especially if you have newer hardware, thats fine.

3 Likes

#9

Perfect update! (Plasma, Ryzen 2400g, Kernel 5.0)

2 Likes

#10

Perfect update … KDE, kernel 5, using TTY. Dkms issue fixed … didn’t need to reinstall digimend/dkms. Thanks! :grinning::+1:t2:

1 Like

#11

Well, it rebooted just fine so I’m guessing all went well :joy::+1:

7 Likes

#12

@philm Looks like compiz-manjaro needs to be recompiled. No longer working (ignores the config, and the settings window segfaults).

Other than that, no issues to report. Updated via Pamac GUI

System specs

Thinkpad W540
DE: Xfce4
WM: Compiz
CPU: Intel Core i7-4900MQ @ 8x 3.8GHz
GPU: Quadro K1100M
RAM: 3265MiB / 31796MiB

3 Likes

Manjaro-specific packages which need an update
#13

I think there is a mistake. In the settings manager, I am using kernel 4.20.17-1 but you say only up to .16 is supported? I also see 5.0.3-1 but it says only up to .2 is supported.

Besides that minor mistake, I updated using “sudo pacmac -Syyu” and everything seems to work fine!

AMD 2600x
GTX 1060

1 Like

#14

No problems upgrading my 2018 Dell XPS using TTY. Thank you!

1 Like

#15

Updated using TTY. No problems.

2 Likes

#16

Update worked. I had to remove vlc-nightly and install vlc but everything is good.

1 Like

#17

Just updated it with -Syyu, looks like everything is fine on GNOME.

Was this update supposed to update to GNOME 3.32 or is it still in unstable versions?

0 Likes

#18

There is some Gnome software in 3.32, but the “best” part is still in Unstable.

1 Like

#19

I will wait for a couple of days and see comments here before updating.

3 Likes

#20

Yeah I see, it updated gedit, file-roller and maybe few others to 3.32. Hope it’s gonna be on stable soon.

0 Likes