[Stable Update] 2019-03-12 - Kernels, KDE, Deepin, LibreOffice, Nvidia, Browsers, Calamares

update
stable

#1

Hi community,

Welcome to our eight stable update for 2019 and also marks the Manjaro 18.0.4 release. So what do we have with this one?

  • most of the kernels got renewed. We also added the first point release of the v5.0 kernel series.
  • we updated systemd to v241 - we added 607 additional patches so far to v241 series.
  • Plasma5 got it’s second point release of v5.15 series
  • KDE Apps got updated to 18.12.3
  • we updated KDE Frameworks to 5.56
  • latest libreoffice got added
  • more LXDE packages got added
  • glib2 and amdvlk got updated to their latest versions
  • we also updated the legacy Nvidia driver for Fermi GPUs .
  • latest brave and firefox browsers got added
  • mesa is now at 18.3.4
  • Nvidia driver got updated to 418.43
  • due to several issues cryptsetup will default to luks1 for now. Also we updated Calamares installer to reflect these changes
  • the usual deepin, deepin, sugar, python and haskell updates

We hope with all these changes Manjaro to be more efficient for you all.


CLT2019

Manjaro will take part on the Chemnitz Linux Days in March this year. You may want to visit our booth with the latest Manjaro hardware and Core Developers present to answer your questions. Feel free to bring your devices if you want to have Manjaro installed on them or problems fixed from our experts.

Partnership with FCS Linux Aarhus

We are happy to announce a new partnership with FCS Linux Aarhus owned by @fhdk. This enables us to offer you Laptops with Manjaro pre-installed and Manjaro Stickers you can use on your own hardware or gift them to a friend. For each sale FCS will donate a percentage to the Manjaro project.

Manjaro v18.0.4 released!

We updated our flagship ISOs of Manjaro Illyria with the latest packages. It comes with refreshed packages and updated tools. You may want to download our XFCE Edition with the latest 4.13 packages, aswell as our most recent styling efforts. Our KDE fans may try our KDE Edition with the latest KDE v5.15 instead. And our GNOME fans may try our Gnome Edition with the latest GNOME v3.30.


Current supported Kernels

  • linux316 3.16.62
  • linux318 3.18.136 [EOL]
  • linux44 4.4.167 [FZN]
  • linux49 4.9.162
  • linux414 4.14.105
  • linux419 4.19.28
  • linux420 4.20.15
  • linux50 5.0.1
  • linux418-rt 4.18.16_rt9
  • linux419-rt 4.19.25_rt16

Package Updates (Mon Mar 11 07:14:22 CET 2019)

  • stable community x86_64: 1180 new and 1141 removed package(s)
  • stable core x86_64: 44 new and 40 removed package(s)
  • stable extra x86_64: 939 new and 1082 removed package(s)
  • stable multilib x86_64: 35 new and 35 removed package(s)

A list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


[SOLVED]Application Launcher Problem
Chromium locks up after updating to 2019-03-12 stable update
Big update package
Libre Office Failed to Commit
#2

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

" Replace xorg-mkfontdir with extra/xorg-mkfontscale? [Y/n]"

Accept the replacement.

Linux kernel 5.0.X available. Early problems reported.

The newest kernel series is now available for everyone. Please note that some issues has been reported with version 5.0.1 such as having a long delay at shutdown and losing sound output when using suspend. It is still available for the early adopters. You are free to install and use it or not.

As reported by some users, if you use WireGuard, you may have to manually run sudo dkms autoinstall in a terminal to get the kernel module working properly with Linux 5.0.1.
More info about dkms autoinstall (and DKMS in general) here.

Kodi 18.1: extensions may not work properly.

Kodi 18.1 is now available in our repositories. Since this is a major version change, extensions for Kodi (if you use some) may stop working properly. Developers of those extensions will need to make them compatible with Kodi 18.

If Kodi 18.1 doesn’t work properly for you and you absolutely need to use your extensions, you may use the old kodi package in /var/cache/pacman/pkg in order to downgrade Kodi to version 17.6. Please note that it is a temporary workaround and that the software provided in the old kodi package may stop working properly in the future too. You should not keep the downgrade forever.

ProjectM: projectm-pulseaudio v.s. projectm-qt, file conflict with /usr/share/pixmaps/prjm16-transparent.svg

Starting with version 3.1.0 of ProjectM, there are now only three packages instead of six and the QT part has been merged to the projectm-pulseaudio package.

Remove the projectm-qt package before upgrading your system.


If you have not kept up with [Stable Update] 2019-02-19 yet, please read the information below too.

How do I do updates via TTY-terminal?

This is a really major update release, with a lot of changes. To limit the risk of breakage in the middle of an system upgrade (which could lead to a broken system that will need to be repaired), you may want to do the system upgrade within a minimalist command-line environment. To do so:

  • Press CTRL+ALT+F2 (or F3, F4, F5, F6) to go into a pure command line interface.
  • Log in with your credentials.
  • Once logged in, you’ll have access to a CLI shell, like if you were using a terminal. Use sudo pacman -Syyu to update your system.

To go back to your regular desktop, press CTRL+ALT+F7. On some systems, it can be CTRL+ALT+F1 instead.

Systemd v241 series update

We tried to update systemd several times now in the last couple of month. Now we were certain to have a good snapshot, which works on most of Manjaro installations. When you are asked to replace libsystemd with systemd-libs please accept this request, otherwise your system may break!


“A stop job is running for User Manager for UID 1000” at shutdown/reboot, what should I do?

Stopping of the User Manager job may take 2 minutes due to the systemd update. Simply wait and let it go. It usually goes away at next boot.


Update is not proceeding due file conflicts

It is a common issue time to time to get errors like this:

python-pyqt5: /usr/lib/python3.7/site-packages/PyQt5/pycache/init.cpython-37.pyc already exists in filesystem

Especially with pycache files, you shouldn’t worry about. Simply delete the conflicting file(s) or use the overwrite function of pacman to continue the update.

sudo pacman -S python-pyqt5 --overwrite ‘*’


Plasma will not reboot from the Application Launcher

If you update from within Plasma (e.g. from the konsole), you may need to issue a systemctl reboot to reboot.


KDE Plasma5 may crash with this update

Due to our long-term testing of v5.15.0 release on some rare edge cases your Plasma5 may crash during this update. If that happens you have to switch to a TTY (Ctrl+ALT+F3), login and check with a cli-package-manager if your update is fully updated!

Pacman

sudo rm /var/lib/pacman/db.lck && sudo pacman -Su

Pamac

sudo rm /var/lib/pacman/db.lck && pamac upgrade


Various issues when using LibreOffice 6.2.0 on KDE Plasma 5 (can’t copy+paste, can’t use backspace in Calc, etc.)

Unfortunately, it seems that the new upstream VCL plugin for integration in KDE5 Plasma (see this notice from LibreOffice) isn’t perfectly functional yet. Upstream is aware of the situation and fixes will come in future versions of LibreOffice.

Examples of related bug reports from the Document Foundation
https://bugs.documentfoundation.org/show_bug.cgi?id=122689
https://bugs.documentfoundation.org/show_bug.cgi?id=122238

Workaround for LibreOffice 6.2.0: you may force Libre Office to use a different VCL by editing /etc/profile.d/libreoffice-fresh.sh, uncommenting the VCL you want to use, and rebooting.
More info about VCL: https://wiki.archlinux.org/index.php/LibreOffice#Theme

You may also consider to switch from LibreOffice Fresh to LibreOffice Still, the latter being at version 6.1.5.

Items from previous update sets

Can’t update with linux417 or/and linux418 present

Since we have completely removed those kernel series you should remove those kernels before you upgrade. Most likely you will notice that as you may have extramodules like nvidia installed. Those got updated and therefore complain about dependency issues.


Notifications looking weird in XFCE

Since the package dunst includes now dunstfy in the main package notifications may not displayed properly in XFCE. Please uninstall that package to solve that issue. Normally not needed in that edition.


Potential issues with dunstify-1.3.2-1 package

Upstream decided to include dunstify now in the dunst package. However, they didn’t add any replace, conflicts tags to that package, as Arch never packaged dunstify before. Therefore we try to remove dunstify automatically via manjaro-system package. On rare cases however, a manual user invention might be needed to remove the package. If that is the case, please issue the following command manually on your system: sudo pacman -Rdd dunstify && sudo pacman -Syu


Warning: PACKAGE: directory permissions differ on FILENAME

A file or directory on your system has a set of permissions which is different to those in the new package. You can either ignore it (because you changed it yourself) or you can change them so they match.

For example, for this message:

Warning: blueman: directory permissions differ on /usr/share/polkit-1/rules.d/filesystem: 750  package: 755

you can change the local file to match the package with:

sudo chmod 755 /usr/share/polkit-1/rules.d/filesystem

i3 changed its default config path

It seems that (from version >= 4.16) i3 is looking for its configuration in ~/.config/i3/config instead of ~/.i3/config.
Copy your config to the new path and all should work as before. (reported from an i3-gaps user).


I can’t open Nemo with elevated privileges (as root)

Workaround found: Use the dbus-x11 package instead of the regular dbus package. This package is available in the official repositories and provides dbus compiled without the --without-x option.

To replace dbus with dbus-x11 package, simply install dbus-x11 with your favorite package manager: dbus will be replaced by dbus-x11.


AMD-Ucode introduction

Unless you’ve already done this previously, All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.


My system won't turn off unless I force it to shutdown with the power button
#3

Thank you for your work on Manjaro!

I get the following message at the begin of the update Replace xorg-mkfontdir with extra/xorg-mkfontscale? [Y/n]
I assume I can choose yes.


#4

Yes that’s correct


#5

As far as I can tell, no major issues here.
Wallpapers had to be set again and for some reason conky is a mess now.
Have to look into that when I have more time on my hands.

[edit]
Conky fix:
own_window_argb_visual = true

Everything is working as intended now.


#6

All good here on Gnome. I got the same message

And I chose yes. I also got informed that the permissions on nm were different one was 700 and one was 755. As far as I know it didn’t effect anything. So I guess I’m ok. So far no problems with the latest kernel 5.0.1-1-MANJARO. Thank you for all your hard work Manjaro Team.


#7

I however select yes and it immediately provides this error and does not let me proceed with the update (via pacman or pamac)

warning: could not fully load metadata for package kauth-5.55.0-1
error: failed to prepare transaction (invalid or corrupted package)

#8

Smooth update on KDE


#9

This rather seems like a download issue. First check if the mirror you’re using is fully synced and then redownload the update (pacman -Syyuu)


#10

GNOME magnifier has had some issues, where top bar and other parts were missing when zoomed in. This issue is on Ubuntu too, so feel it is a GNOME issue. However, Dash to Dock seams to disappear now too.

Got around this for now by install cinnamon desktop environment whilst I wait to see if this issue is fixed in the next release of GNOME.


#11

Not seeing that here.
Selected Y and was good to go.


#12

For GNOME so far it looks fine. Thank you.


#13

All ISO images of 18.0.4 are now online …


#14

I am using this mirror: mirror.math.princeton.edu/pub/manjaro which is showing as up to date according to https://repo.manjaro.org/. And even after running pacman-Syyuu I still get the same error.


#15

In contrast with Phil’s advice I updated using Pamac.
But all went fine on Xfce.


#16

Updated easily. However, my desktop background is reset to default. Actually, it removed custom background folder from the folder list on “desktop settings”.
Well, complete with linux 5 kernel, it seems more responsive my old compaq cq56 (which gained bluetooth recently and surprisingly!) for first one hour.


#17

xfce 18.0.4 upgraded with kernel 5.0.1-1, all good.

bob@Manjaro-Stable~$ inxi-Fxzc0
[bob@Manjaro-Stable ~]$ inxi -Fxzc0
System:
  Host: Manjaro-Stable Kernel: 5.0.1-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: Xfce 4.13.2git-UNKNOWN Distro: Manjaro Linux 
Machine:
  Type: Desktop System: LENOVO product: 10181 v: Lenovo K450e 
  serial: <filter> 
  Mobo: LENOVO model: N/A v: 31900058 STD serial: <filter> BIOS: LENOVO 
  v: I1KT38AUS date: 06/10/2014 
Battery:
  Device-1: hidpp_battery_0 model: Logitech M570 charge: 95% 
  status: Discharging 
CPU:
  Topology: Quad Core model: Intel Core i5-4460 bits: 64 type: MCP 
  arch: Haswell rev: 3 L2 cache: 6144 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 25548 
  Speed: 1156 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 1413 2: 1253 
  3: 1883 4: 1983 
Graphics:
  Device-1: NVIDIA GK208 [GeForce GT 720] vendor: Micro-Star MSI 
  driver: nvidia v: 418.43 bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.4 driver: nvidia 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce GT 720/PCIe/SSE2 v: 4.6.0 NVIDIA 418.43 
  direct render: Yes 
Audio:
  Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Device-2: NVIDIA GK208 HDMI/DP Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  Sound Server: ALSA v: k5.0.1-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8168 v: 8.045.08-NAPI port: d000 bus ID: 03:00.0 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter 
  vendor: Lenovo driver: rtl8821ae v: kernel port: c000 bus ID: 04:00.0 
  IF: wlp4s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 1.82 TiB used: 27.16 GiB (1.5%) 
  ID-1: /dev/sda vendor: Western Digital model: WD10EZEX-08M2NA0 
  size: 931.51 GiB 
  ID-2: /dev/sdb type: USB vendor: Western Digital model: WD Elements 25A2 
  size: 931.48 GiB 
Partition:
  ID-1: / size: 453.89 GiB used: 27.16 GiB (6.0%) fs: ext4 dev: /dev/sda1 
  ID-2: swap-1 size: 7.72 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda5 
Sensors:
  System Temperatures: cpu: 51.0 C mobo: N/A gpu: nvidia temp: 52 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 28% 
Info:
  Processes: 206 Uptime: 1m Memory: 7.72 GiB used: 891.1 MiB (11.3%) 
  Init: systemd Compilers: gcc: 8.2.1 Shell: bash v: 5.0.0 inxi: 3.0.32 

#18

When updating I received the error…

error: failed to commit transaction (conflicting files)
pycharm-community-edition: /usr/share/pycharm/lib/rhino-1.7.10.jar exists in filesystem

I renamed the file to OLD_rhino-1.7.10.jar and then successfully re-ran the update.


#19

Same here, and the same happened yesterday on my Arch box.


#20

Updated via TTY without issues :blush:

hardware info

ThinkPad L440

CPU - Intel i5-4200M @ 2.5GHz
GPU - Intel 4th Gen Core Processor
GPU driver - video-linux
DE - Xfce
WM - Openbox