[Stable Update] 2019-03-12 - Kernels, KDE, Deepin, LibreOffice, Nvidia, Browsers, Calamares

Small glitch with analogue audio since update.

After resume from Suspend-to-RAM, the analogue audio (to external 2.1 speaker system) is not recognised. Instead audio is output via the HDMI link to the monitor’s speakers.

Unplugging and re-inserting the analogue audio jack solves the problem until the next Suspend-to-RAM.

My system is KDE and the 5.0.1-1 kernel.

Manjaro Xfce here. Contributing to the update-grub observations:

I do also observe update-grub to be very slow, like 10-15 seconds, since a little while (some weeks maybe). Happens both in a Manjaro 17 installed 1 yr ago and always fully updated to 18 as well as in a fresh 18.0.4 Install from ISO.

In contrast, my other Linux on this laptop - Tumbleweed - does it within a fraction of a second. In both grub installations, os-prober is disabled, since I do multibooting via grub differently.

Yes, I also feel manjaro’s update-grub is slower than other distros.
But not as long as the " (around 10 minutes) " that httpeter is facing.
So how do you do your grub differently?

Report the file size of your grub.cfg here, if it is larger than 30 Kb then … :wink:

(8,7 KB)

Please refer to this thread on Tumbleweed:

Okay, thanks.
I too disable os-prober in all my OS’s. In fact, I do not use manjaro grub.

Refer here.
We can use multiboot or chainload or configfile or direct to any kernel symlinks as well.



aside the pen-drive, which only holds manjaro xfce, I’m having Windows 10 and Macos Sierra sharing the built-in HDD.

Thank you for referring to your tutorial, nicely comprehensive.


1 Like

Update on 12 Systems and 1 VB without Problems.



Slow Shutdown since Testing Update 2019-03-10 with Kernel 5.0.1 —> Slow Shutdown since Testing Update 2019-03-10 with Kernel 5.0.1 —> Speakers Have Stopped Working … Kernel 5.0.1 breaks audio after Resume; this is a workaround.

Right, disable finding macOS in your /etc/default/grub.
You boot MacOS using the…er…<forgot the name> , meaning not through grub, right?

reference : os-prober-skip

Thank you. That seems to be working now after Resume.

Slightly strange that it only works when set to Analogue Stereo Output, and not when set to Analogue Surround 2.1 Output.

I tested this update on 4 computers, 2 HP laptops (went smoothly in both cases), 1 older quadcore HP desktop with low-end nVidia graphics (no problem), but on my own more modern i7 HP desktop, the linux50 kernel hangs on boot. This is 100% repeatable, I can’t even watch the boot info (the console doesn’t accept my [esc] key strike), and it tries to get into plasma but freezes at some point on a black screen with the mouse cursor stuck in place. The kernel itself might still be running underneath, but I have no X and no console so…
I suspect there’s a conflict with the NVidia driver ; the card is a GTX 750ti, with two screens attached.
As it is my main rig and I use it for productive work, I have no time to investigate that issue so I reverted to 4.19 for the time being on that machine.

Thanks for the advice!
I’ve added the /dev/sda1 to /dev/sda4 and yes, the Mac is having its own boot selection menu. I remember it was tough teaching the Mac that I want to run linux on this device… Was able to do so eventually with rEFInd

After the reboot, my processor was working a lot more than the usually (it was something related to mandb); i rebooted and now all is going as usual. :slight_smile:

The manpage database needs to be updated every so often. It’s perfectly normal and while you can kill the update process it’s counter-productive.


Everything went fine after TTY upgrade.s Great job!:heart_eyes:

OS: Manjaro 18.0.4 Illyria
Kernel: x86_64 Linux 4.19.28-1-MANJARO
Uptime: 1h 13m
Packages: 1183
Shell: bash 5.0.0
Resolution: 1366x768
DE: KDE 5.56.0 / Plasma 5.15.2
WM: KWin
WM Theme: Breath
GTK Theme: Breath [GTK2/3]
Icon Theme: maia
Font: Noto Sans Regular
CPU: AMD A8-7410 APU with AMD Radeon R5 Graphics @ 4x 2.2GHz
GPU: AMD MULLINS (DRM 2.50.0, 4.19.28-1-MANJARO, LLVM 7.0.1)
RAM: 1574MiB / 3401MiB

Maybe we also don’t need people commenting that everything was fine when there’s a button on the poll for that.

Ops, my bad… i thought was a little issue; so it is not; good to know for the next time; have i to do something right now or just wait for the next mandb update?

Good point, especially if version and how updates were done isn’t included. Are posts genuinely useful if they do include those details?

Forum kindly sponsored by Bytemark