[Stable Update] 2019-02-19 - Kernels, KDE, LibreOffice, Systemd, VirtualBox, Deepin, Qt, Firmwares, Wine

update
stable

#144

Nah, for now I’m good thanks.

I just wanted somebody with the necessary skills to take a look and provide a fix. I can wait for that.


#145

If you have a specific issue then posting a separate thread is a better idea than hoping people see one post of a megathread, especially when others are having “larger” issues.


#146

Same happened here using kernel 4.20.
Wondering what happened…


#147

I essentially agree with all points said by suerdgepipe here, although I would say that a larger set of update doesn’t necessarily having more issues in itself than if the updates were more widespread, but rather that the same potential issues that would appear here and there with a more continuous approach appears instead all at the same time, which can give the impression that Stable is in a constant broken state because different issues with different software now appears in the same set of updates.

Also, I’ll just say again what I have said in my previous post: even on Arch, they are having hard time: many issues users are facing now at the same time also happened to some Arch Linux users (in a more widespread way because of how updates are published on Arch). Non exhaustive list in my previous post (quoted below).

So saying that Unstable has less issues than Testing or Stable, sorry, but I hightly doubt that. Same thing with people who say that “Arch Linux has less problem than Manjaro.”

(BTW, I had 0 problem in Testing on my side, even when doing the upgrade the “wrong” way. Doesn’t mean that because my personal experience was good mean that the branch has less issue than others.)

One of the major difference between Arch and Manjaro though is that when Arch got systemd 239.300, they did not went back to a previous version of systemd even if some people got their system broken because of a crash during upgrade. They just went trough it.

On Manjaro, we went to systemd 239.6 to 239.303 in December, but because many people got a crash during update, philm downgraded to 239.6 two days after to prevent more breakage. So instead of jumping from 239.6 to a newer version only once, we did that twice, with unfortunately the same result at the end (although honestly, with the experience I had and what was reported in Testing so far, I though it would have been WAY better than that, the real life prove me wrong…).
(Not even counting the moment when people didn’t do the systemd downgrade, so they got a broken system that needed to be chrooted.)

Maybe we did an error when we downgraded systemd in the beginning, hoping for a better result in the future. Perhaps Arch Linux, by essentially saying “well, too bad, deal with it”, actually did the right move on that one, even if it means that some people had to repair their system that day.

I do not blame philm and co on that move though. Back in December, the downgrade made sense. They just had too much hope I guess.


#148

I was extra cautious this update and logged out and performed on TTY2 -> no issues besides having to wait 2 min for UUID1000/992 (full disc encryption, KDE)
so as always - flawless update :smiley:
Can’t thank phil, oberon and all the others too much for this :+1:


#149
  1. I also wrote that. The amount of updates is getting too big to oversee what is going on.
  2. Not much what can be done here.
  3. True. The amount of new Manjaro users has risen fast in the last half of the previous year. Strange to say this but not everyone, like my neighbor, is Manjaro material.
  4. How come the systemd updates worked in Unstable? As I wrote I have 3 machines running Unstable and they all just work with updates coming in almost daily. The same systemd update should have been in Unstable as well, correct? Or am I missing something?

#150

Updated both computers through TTY, following wiki solutions when needed.
Still alive. :cake:


#151

Just updated and ran into the following issue: Black screen with only the mouse cursor (which can be moved and switches to the “clicking finger” at some spots - maybe we are still in the lightdm login screen?). When killing Xorg from TTY it loads again and then shows the desktop with no problems. But killing Xorg from TTY on each boot isn’t fun…

Using nouveau and Xfce as a desktop. Compiz is also in use but removing it doesn’t make a difference. Also, downgrading nouveau and the webkit packages didn’t solve the issue.

Which logs could give useful hints here?

edit: Never mind, the problem was not related to the update, see Is it a good idea to copy a partition from one SSD to another using GParted?. :slight_smile:


#152

Updated via TYY on 1 KDE System and 2 Cinnamon Systems with zero problems. Great work!


#153

Powertop isn’t working on my end.
No more to report, a good update.


#154

I updated my system with qt5 only issue (solved removing file) in TTY

Thanks Manjaro Team

XFCE - Kernel 4.19


#155

yes, it gives me this:

Cannot load from file /var/cache/powertop/saved_results.powertop
Cannot load from file /var/cache/powertop/saved_parameters.powertop
File will be loaded after taking minimum number of measurement(s) with battery only
Cannot load from file /var/cache/powertop/saved_parameters.powertop
File will be loaded after taking minimum number of measurement(s) with battery only
e[?1049he[22;0;0te[1;30re(Be[me[4le[?7he[39;49me[?1he=e[39;49me(Be[me[He[2J
segmentation fault


#156

Found the masochist! :laughing:


#157

You probably want to address that error. @Frog kindly provided some guidelines that worked for me, so they might work for you as well (keep the warning in mind though.) He also suggested trying first to try the overwrite option instead of removing the package…I can’t remember but I think I tried that and it still didn’t want to install, so I just removed it and then reinstalled again.


#158

Hmmm, after updating, my thunderbolt is dead and I can no longer use my docking station. Gnome reports that Thunderbolt could not be detected.

After the update, I started receiving errors about /usr/bin/boltctl already existing and was unable to update other applications. I manually removed bolt, deleted this file, and then reinstalled bolt and related packages, but I’m unable to get my thunderbolt to re-enable.

Made a thread for tracking this:


#159

Think it might have something to do with google chrome which I have now uninstalled. I never used it. Will keep an eye on it & see how it goes. Thanks.


#160

In the HP notebook I can not enter the pure line of commands (TTY) through the combination of keys (Ctrl + Alt + F2 …). Any other option to enter TTY?

Thanks


#161

if you have FN key on by default, you will need Ctrl+Fn+Alt+F2 (F3,F4,F5,etc…)


#162

Because unstable has been on systemd 240 and 241 for months now.

Stable is only now updating from 239 -> 241, skipping 240 as it was problematic in testing. It is major version updates like this that can crash x sessions, crash updates, and leave systems in an incomplete / borked state.

These issues were experienced by unstable and testing users also … just maybe not yourself (me either, I updated through tty).


#163

Also, a major difference between Unstable and other branches, if I’m correct, is that systemd never got downgraded on Unstable (like Arch did actually).

Essentially, it means that Unstable only did the transition from 239.6 to a newer version once, while other branches has done it at least twice. Hence, Unstable only got f-ed once, while other branches got f-ed more than one time with systemd.

The downgrade of systemd, hoping for a more stable transition, actually backfired on us hard.