[Stable Update] 2019-02-19 - Kernels, KDE, LibreOffice, Systemd, VirtualBox, Deepin, Qt, Firmwares, Wine

update
stable

#104

Updated on an full disk encrypted KDE. Except for trouble rebooting, it worked well.

Virtualbox 5.2.26 stopped working (vboxdrv stopped being loaded) but rebuilding it (from slightly modified PKGBUILD files) got it back working (with Shared Folders).


#105

No problems for me. Manjaro XFCE with 4.20 kernel. The update was made with Pamac and everything works well.


#106

I don’t understand this: both in Testing and in Stable the updates this year have problems. I use Unstable on 2 machines and it always works. I get a nice small amount of update packages per day and after having done the update and after the reboot the machines just work.
Why do Testing and Stable have problems, don’t these 2 versions get the same packages as I use in Unstable?
I hate the fact Stable has problems, around new Year I installed Manjaro Stable on my neighbor’s laptop, wrote a manual for her how to do things, including the updates, but now I have to go back to her AGAIN to do the updates manually. She is a computer illiterate who can use the programs she wants/needs to use, but there it ends. I chose Manjaro cause here at home we have 3 computers using it and here they just work, but they are all on Unstable, which seems to be more stable than Stable. How? Why?
Would it be an idea to copy Unstable to Testing and Stable and work from there to make the three versions equal for a while?
Would it be an idea to make the amount of updates in Stable smaller? Can it be things go wrong because too many packages are updated at the same time?
I am seriously thinking about installing a different OS on her laptop cause at the moment Manjaro is not the right one for her. Which one that will be I don’t know yet. From the start, early January, there have only been problems with Stable updates. I am not blaming anyone, let this be very clear, it is just that the situation right now is far from perfect.


#107

Thank you Manjaro team for another smooth upgrade ! Keep going ! :muscle:


#108

Aparently, Pamac (GUI updater) has a bug that crashes everytime the new update is installing.
It seems that testing and unstable guys and girls that worked with these packages done their updates throught tty or console and haven’t had those issues…
It was tested… And no one had such a big problem… :man_shrugging:


#109

hello i had the error with pyqt5 cache and the overwrite command provided didn’t worked, i was hurry to update so i have rm -r the whole __pycache__ folder, it worked i was able to update but i maybe made a mistake by deleting it because now i have some issues i have noticed that the activity button widget menu is not working (it works only one time after a fresh reboot and after it’s not possible to open the menu anymore) and also a bug with scripts that wont launch from plasma folder view widget/dolphin and open in kate instead (despite of being executable) when i click on them except if i put them on desktop and click, can i somehow rebuild the cache (the __pycache__ folder is here but i maybe there is missing files??) or the problems are not related?


thanks


#110

green upgrade from cinnamon :slight_smile:
thanks.


#111

Updated Cinnamon, LXDE and Cinnamon in VM (using sudo pacman -Syu only in terminal). Everything went OK. Thanx for another Stable update!


#112

That was pushing it a tad I fear…:rofl:


#113

Agreed on more users on unstable/testing. However. That might require users to be inclined…and to possess a certain dose of stoicism as well…which is rare(stoicism) these days. :wink:. I’m a coward, anyway…!:joy:


#114

Update went fine [KDE, kernel 4.20] - no manual intervention needed during update process. Used pacman -Syu within tty2.
Actions performed afterwards:

  1. Solved Libreoffice issues via setting SAL_USE_VCLPLUGIN=gtk3_kde5.
  2. Identified adjustable config files via sudo pacdiff. Merged changes manually - didn’t overwrite without thinking [e.g. /etc/pam.d/system-login - switched pam_tally.so -> pam_tally2.so]

Thanks a lot for your great work - much appreciated.


#115

I just did not clarify: I’m a newbie, and I have not done the update yet. I want to follow all the tips to minimize risks of break my system, and these are my doubts:

1.- I have checked my mirrors, and the third of the list is outdated, in all branches. Should I run pacman-mirrors --fasttrack and then pacman -Syy before the update? If so, can I do this in Konsole, or should I do it in TTY?

2.- In the TTY, if I have done the above through Konsole, is it enough with pacman -Syu or should I make pacman -Syyu? Is it better to do everything TTY with pacman-mirrors --fasttrack and then pacman -Syyu?

3.- Should I wait another day, or update now? Will something change in the next few days?:thinking:


#116

1. Backup your data (Timeshift, rsync, grsync, copy)


#117

No, it does not have a bug.

The systemd upgrade in this update is a major upgrade that can crash the graphical session, including all apps open in the graphical session (including Pamac or Terminal). This has been experienced in Unstable and Testing also.

If Pamac or Terminal is crashed mid update it can potentially leave a system in an unstable / unbootable state, requiring chroot into it to remedy.

This is why in the second thread post users were instructed to perform this update from tty, and given explicitly easy to follow instuctions on how to do this. There is no graphical session in a tty terminal, so updates can complete unhindered.

Bottom line is to read the second post in every announcement thread, it contains important information relevant to its specific update.

Those inexperienced users trepidatious about applying such a big update, don’t do it immediately. Wait a day or two. Read this thread and learn from potential issues others have had. That way if you experience the same issue you know how to resolve it yourself.


#118

Also the case with danish translations, so I expect it to be the case for all translations. Somehow they changed the string in SDDM or qt5, so it no longer gets translated by qt5-translations.


#119

What is the difference in running sudo pacman -Syyu in the tty2 (or any other tty) than in the regular terminal?


#120

The TTY is “outside” of the running X server + DE, which itself normally runs on TTY7 depending on the config.

Best approach however is to switch to multi-user mode with systemctl isolate multi-user.target, formerly known as runlevel 3 on sysvinit.
That should normally close X and its dependencies altogether.


#121

Thank you!


#122

Updated two laptops using Pamac this morning and all without issues.


#123

Updated 2 cinnamon and one XFCE using TTY, no problems.

Thank you.