[Stable Update] 2019-02-19 - Kernels, KDE, LibreOffice, Systemd, VirtualBox, Deepin, Qt, Firmwares, Wine

update
stable

#84

Being a rolling release you know, that you’re going to have some troubles and may need some help to solve them.
The same exact hardware reacts diferent with updates, and while we all have the same based software… Not all systems are the same and the dependencies are all diferent cause of the software you need to work with that pc/notebook…


#85

You are right, I just think that 20% is not reasonable, maybe increasing the number of users using the Testing update channel would decrease this number.


#86

I updated the wikipost to include instruction on how to do an update in TTY. Yeah, it’s a bit too late I guess (maybe I should have thought of that earlier this day), but hey, if there’s still people that didn’t upgrade yet… :confused:

I recycled the old instructions that was hidden.

I’m not that convinced. The thing is, if you make it the default branch, it will make “Stable” just merely be a “Testing 2”. Could we achieve the same result by just having more guinea pigs in Testing (and for the more brave of us, Unstable)?

Also, it would make a lot more delay for security vulnerabilities. Manjaro already take criticism because it delays all updates for testing purpose, including security fixes. I know there’s early updates for some browsers and mail client (sometime, thanks to jonathon, we get these even earlier than Arch, which is a bit funny), but it’s not enough for them.

Plus, will mirrors accept to host a fourth branch, with all the disk space it would need?

The only interest in my opinion for a fourth branch would be to host a “snapshot” of the state of Stable before a big upgrade release, which could be, in rare scenarios, useful to cherry pick downgrades when you don’t have what you need in /var/cache/pacman/pkg. It would not be a branch intended for daily usage, but more a branch for troubleshooting purpose.

EDIT: You read my mind. Still wanted to post my answer.


#87

I just edited my answer, we are in sync :grinning:
I consider my point finished.

Thank you for the discussion guys.


#88

Problem is that not many people like to have it system breaking down every now and then to test the updates and that’s why we end up having a trillon of post with the same exact problem, and angry cause they don’t know how to fix the problem.


#89

There were updated ISO’s within 24 hours :grinning:


#90

All it takes is to learn restraint and NOT initiate updates immediately when notified. Wait for update announcements first and follow instructions.

I did suggest that this should be in the About Manjaro section of the website so newcomers know the best practice procedure when they first decide to try manjaro. Unfortunately I was told that it’s best located in the Help section, which IMO is like closing the stable door after the horses have fled.


#91

I agree but maybe a link to the newbie part of the forum could be a solution to that


#92

I suggest you exercise some caution here. There is only so much that a distro, its maintainers, & indeed other users who did not experience problems, can do to help your “20%” if they are unwilling or unable to help themselves in the first & second instances.

“First” = just how much reading, practising & learning did they perform after coming to Manjaro from Windoze, or a fixed-release-cycle Linux? How many illegitimate preconceived ideas are they still harbouring about what they think a rolling-release Linux is, & also Manjaro specifically? How many bad practices are they using out of ignorance &/or laziness?

“Second” = why the fruitcake have so many apparent noobs independently posted nearly identical questions re this update? Why have they been so lazy as to post first rather than search the forum first? I’ll be rash & opine that damn-near ALL of these alleged failures / faults emerged already in the Unstable &/or Testing branches, wherein they were canvassed, investigated, solved, & written in relevant forum threads. Ergo, how come these Stable-branch “20%” are too noble & worthy to sully their hands by taking the time to search & read?


#93

By the way is it a way to peek what will going to be updated and without update as such?
Of course I mean without mailing list, just using pacman or octopi.

I’m pretty new to Linux and now I do pacman -Syyu which trigger update.


#94

Did you make sure dnsmasq was subsequently installed correctly?
pacman -Qi dnsmasq


#95

Ummm…maybe answer “no” when pacman asks to continue?


#96

Is it safe way?


#97

no it’s checkupdates : local db is not updated (unlike pacman -Sy)

checkupdates -h
Safely print a list of pending updates

#98

I successfully updated my own machine with KDE Plasma Kernel 4.19 + 4.14
but I had to do the overwrite thing for pyqt5 and that was before the update post. thankfully I went and ddg the error and found the solution in the Arch forums.
and I did the update from within the GUI and no crashes but indeed I couldn’t be able to do a restart from the ui itself I had to do it from the terminal

everything is working

Thanks Manjaro Team :wink:


#99

I get error: could not open file /var/lib/pacman/local/dnsmasq-2.80-3/desc: No such file or directory.

System seems to be OK though. (That might explain why I got the no connection error before rebooting.)


#100

My desktop’s environment is gnome. I had update manjaro yesterday by runing “sudo pacman -Syyu”. It’s was ok in the begining. Howerer, when the update was installed, the screen suddenly became dark, and the keyboard did not respond. After waiting for a long time, it showed the signs of booting and shutdown. Then it was stuck and it didn’t respond. Later, I forced to restart, and I was able to enter the system. Now is all ok!


#101

sudo pacman -Syyuu

Everything worked very smooooooooth

I even did not wait for the UID 1000 to finish and press RESET button

Works like charm…

Awesome job guys and Gals!!!


#102

Ran the upgrade using Pamac on Manjaro Cinnamon. The system suddenly decided to reboot mid-update. A stop job is running for User Manager for UID 1000 message popped up but i waited for it to just reboot.

After that several apps and services crashed (notably NetworkManager and pacman) due to missing /usr/lib/libidn2.so.4. (Almost no apps were updated.) I simply patched it by creating a symlink to /usr/lib/libidn2.so but that’s definitely not the correct way so I would like to see a solution. Finished the update this time and pacman complains with Error: could not open file /var/lib/pacman/local/bolt-0.7-2/desc: No such file or directory but works fine, and Baloo file extractor keeps crashing with quite useless signal: segmentation fault (and sometimes signal: bus error) message.


Thunderbolt not detected after update
#103

On that one, there’s a post on Arch Linux too. Mh for now, there isn’t much information about it, for now.

https://bbs.archlinux.org/viewtopic.php?id=244268

Perhaps if you can show us the core dump that is generated when it segfaults, it might help, although there’s no guarantee there’s something that you can really do on your end outside of waiting for an update.