[Stable Update] 2019-02-19 - Kernels, KDE, LibreOffice, Systemd, VirtualBox, Deepin, Qt, Firmwares, Wine

update
stable

#22

libidn2 was already updated last time. With libidn2 2.1.1-2 libidn2.so provision got added to help prevent partial upgrades breaking pacman. It would be great to know on which stage you got this breakage on your end.

I’ve reverted a commit which introduced the breakage, however there is still no proper fix from upstream. No worries, this update won’t break your system in that regard. I only want to point to an issue, which is not yet properly fixed by upstream.


#23

The thing is whether you do it in a terminal or with Pamac GUI, if the graphical session crashes, all graphical applications (including the terminal you ran in the graphical session) goes bye bye.

And when a terminal crashes, all commands run in the terminal crash too.

So if the graphical session crashes during an upgrade, even if done in a terminal, the upgrade will stop abruptly.

(Unless of course if by terminal, you meant TTY/pure CLI. My bad if so.)


#24

KDE, using kernel 4.20. Synced mirrors on Monday afternoon and updated through Octopi/Pacman GUI.

The update seemed to go well, but I was unable to either restart, or, shut down afterwards through the interface which refused to respond, and had to do so manually.

Everything running well since.

:+1:


#25

Update seems to be successful dropping to TTY, thanks! :+1::100:

One bug that I found on successful reboot was sudo powertop seems to fail with segmentation fault.

DE: Gnome
Kernel: 4.19.23-1-MANJARO
H/W: Xiaomi Air 13.3 (2017); i5; Intel HD Graphics 620 & GeForce MX150

Anybody else encounter this issue?


#26

what i’ve meant to say is that… if people haven’t upgraded yet… they have to do it with the terminal, cause pamac is somehow giving troubles…

Some people take the time to read the announcements… and possible problems…
Was an advice.


#27

Well, that is not an option. It’s a work laptop and my company requires it to be encrypted.


#28

as @philm said


#29

Yes, I understood that. But even if you use pacman, if the graphical session crashes during the upgrade and you launched pacman in a terminal (Gnome-Terminal, Konsole…), RIP pacman too.

Unless people actually reported Pamac crashing while in TTY using pacman upgrade, I doubt it is really caused by Pamac iself.


#30

Kde plasma with full encryption, 4.19 kernel , no issues since yesterday.


#31

From what i’ve seen people that done it with via terminal (even in GUI - Gnome terminal, Konsole…), hadn’t had their system broke…
I might be wrong…


#32

Qtile & Linux 4.20, update from TTY with pacman. No problems to report.


#33

1st attempt (via tty) failed with:

error: failed to commit transaction (conflicting files)
python-pyqt5: /usr/lib/python3.7/site-packages/PyQt5/pycache/init.cpython-37.pyc exists in filesystem

Retried with the following and update went through ok:

sudo pacman -Syu --overwrite /usr/lib/python3.7/site-packages/PyQt5/pycache/init.cpython-37.pyc

I then spent some time pulling *.conf.pacnew file data into their *.conf equivalents (reapplying my original non-default entries).

All is now working as it should. KDE.


#34

Cinnamon crashed too for me, so you may better go with terminal installation there too. :wink:


#35

I had the same issue as Yochanan, did the update via the gui for pamac, it crashed at some point and then when trying to do any CLI updates it said I was missing a libidn2.so.4 i think was the file, following the Arch wiki I was able to fix the issue after I removed the file lock for pacman before running the update command.

My system was up to date before this release.


#36

The update fails on my machine. Message is

libidn2: /usr/lib/libidn2.so.0 already exists in filesystem.

What should I do? I saw this file beeing covered in the tread, but can not figure out how to fix this. Thanks!


#37

I had an issue with a different file in pycache, but solved it too.


#38

Updated my 2018 Dell XPS laptop running Manjaro KDE.

I ran the update via Octopi, but, as usual, told it to run it via the terminal.

No problems arose during the update process. No conflicting files, etc.

After the packages were all updated, I did have to open a terminal and systemctl reboot to reboot the system.

During shutdown, I did get the stop job wait period. I just waited it out as suggested, and then reboot proceeded normally.

Everything seems to have come up just fine.

I did move to libreoffice-still as suggested. I’ll move back once the problems have been resolved upstream and made available to Manjaro.

Thanks for another great update!


#39

Thanks! Update went fine.


#40

I’m running kernel 4.19 on XFCE. With this update at stopped working:

$ echo "/usr/bin/touch /tmp/verminator.txt" | at now + 1 minute
warning: commands will be executed using /bin/sh
job 92 at Wed Feb 20 20:36:00 2019
$ atq
92	Wed Feb 20 20:36:00 2019 a verminator
$ # ....
$ atq
92	Wed Feb 20 20:36:00 2019 a verminator
92	Wed Feb 20 20:36:00 2019 = verminator
$

And that’s what it stays. No file was written to /tmp.


#42

I upgraded my GNOME installation using pamac which turned out to be a mistake. Right after the following, the user session died & the screen went black.

[2019-02-19 08:05] [ALPM] running 'systemd-update.hook'...
[2019-02-19 08:08] [ALPM] running 'firefox-pre.hook'...
[2019-02-19 08:08] [ALPM] running 'kernel-alive-pre.hook'...
[2019-02-19 08:08] [ALPM] transaction started
[2019-02-19 08:08] [ALPM] removed geoclue2 (2.5.2-2)
[2019-02-19 08:08] [ALPM] removed libsystemd (239.303+really+239.6-1)
[2019-02-19 08:08] [ALPM] upgraded amd-ucode (20190118.a8b75ca-1 -> 20190212.28f5f7d-1)
[2019-02-19 08:08] [ALPM] upgraded iana-etc (20181219-1 -> 20190125-1)
[2019-02-19 08:08] [ALPM] upgraded libsasl (2.1.26-16 -> 2.1.27-1)
[2019-02-19 08:08] [ALPM] upgraded audit (2.8.4-2 -> 2.8.4-3)
[2019-02-19 08:08] [ALPM] upgraded bat (0.9.0-1 -> 0.10.0-1)
[2019-02-19 08:08] [ALPM] upgraded libidn2 (2.1.0-1 -> 2.1.1-2)
[2019-02-19 08:08] [ALPM] upgraded bind-tools (9.13.5-4 -> 9.13.5-5)
[2019-02-19 08:08] [ALPM] upgraded libgpg-error (1.34-1 -> 1.35-1)
[2019-02-19 08:08] [ALPM] installed systemd-libs (241.159-1)
[2019-02-19 08:08] [ALPM] upgraded cryptsetup (2.0.6-1 -> 2.1.0-1)
[2019-02-19 08:08] [ALPM] upgraded kmod (25-1 -> 26-2)
[2019-02-19 08:08] [ALPM] upgraded pambase (20171006-1 -> 20190105.1-1)
[2019-02-19 08:08] [ALPM] upgraded systemd (239.303+really+239.6-1 -> 241.159-1)

I tried to continue in a TTY via pacman -Syyu, but it complained error while loading shared libraries: libidn2.so.4: cannot open shared object file: No such file or directory. Also bolt got corrupted in the process and was missing a couple files in /var/lib/pacman/local/bolt-0.7-2. I think that may actually be what broke pacman itself.


Thunderbolt not detected after update