[Stable Update] 2019-02-19 - Kernels, KDE, LibreOffice, Systemd, VirtualBox, Deepin, Qt, Firmwares, Wine

update
stable

#225

In my experience 95% of new people that starts in a linux enviroment, starts with Ubuntu.
Hell i’ve used it when i started…
Is like music (or whatever you want to put on)… We all started with the commercial music and end up having our taste and going in deeper.
For the linux community i think is exactly the same.


#226

Could be… But i doubt it… Somehow in the middle of the proccess of the update while still in GUI the system breaks and ends up in a black screen.
Systemd and pamac aparently don’t like each other.


#227

Do not forget to update your mirrors.


#228

I updated my desktop running Manjaro KDE today, and as with my laptop, all went well!


#229

From the Manjaro Wiki: Use pacman-mirrors to Set the Fastest Download Server


#230

Did the same, nothing to pay attention to be found there. Had to do the reboot via command line though. So I guess it worked fine.


#231

Another interesting “gotcha” for the few people who, like me, use at jobs.
I found that after the update, my at jobs weren’t running. Putting atd in debug mode, I saw an “authentication error” message when a job should have started.
A bit of searching reveals that the fix is to create /etc/pam.d/atd with the following contents:

auth required pam_unix.so
account required pam_unix.so
password required pam_unix.so
session required pam_unix.so

I don’t pretend to understand what this is doing, or why the problem started after the update (neither pam nor atd were updated), but it works, and that’s good enough for me.


#232

Instead of using nmtui to get network access, simply download the updates in GUI without installing them: sudo pacman -Syuw.
Then switch to TTY and run sudo pacman -Su.


#233

I updated my laptop with the XFCE-terminal, and have deleted

/usr/lib/python3.7/site-packages/PyQt5/__pycache__/__init__.cpython-37.pyc

that was belonging to no package.

I rebooted my computer (with the 2 minutes announced countdown during the first shut down) and it worked but after the following (or the following of the following? - in any case I have not changed anything in Clamav in the meantime) reboot, I had the following message when it was shutting down: “A stop job is running for Clam Antivirus userspace demon” with 1 minute 30seconds countdown. After the boot, a new message appeared telling me that ClamAV-milter is failed.

That is why I made:

systemctl status clamav-milter
● clamav-milter.service - 'ClamAV Milter'
   Loaded: loaded (/etc/systemd/system/clamav-milter.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Fri 2019-02-22 13:47:55 CET; 1h 31min ago
  Process: 633 ExecStart=/usr/bin/clamav-milter --config-file /etc/clamav/clamav-milter.conf (code=exited, status=1/FAILURE)

févr. 22 13:47:55 XX systemd[1]: Starting 'ClamAV Milter'...
févr. 22 13:47:55 XX clamav-milter[633]: ERROR: Parse error at /etc/clamav/clamav-milter.conf:296: Unknown option ScanOnAccess
févr. 22 13:47:55 XX clamav-milter[633]: /usr/bin/clamav-milter: cannot parse config file /etc/clamav/clamav-milter.conf
févr. 22 13:47:55 XX systemd[1]: clamav-milter.service: Control process exited, code=exited, status=1/FAILURE
févr. 22 13:47:55 XX systemd[1]: clamav-milter.service: Failed with result 'exit-code'.
févr. 22 13:47:55 XX systemd[1]: Failed to start 'ClamAV Milter'.


The lines 295-296 of /etc/clamav/clamav-milter.conf is:

# Enables on-access scan, requires clamav-daemon.service running
ScanOnAccess true

That is why I have checked:

● clamav-daemon.service - Clam AntiVirus userspace daemon
   Loaded: loaded (/usr/lib/systemd/system/clamav-daemon.service; enabled; vendor preset: disabled)
   Active: active (running) since Fri 2019-02-22 13:47:55 CET; 1h 45min ago
     Docs: man:clamd(8)
           man:clamd.conf(5)
           https://www.clamav.net/documents/
  Process: 5030 ExecReload=/bin/kill -USR2 $MAINPID (code=exited, status=0/SUCCESS)
 Main PID: 632 (clamd)
    Tasks: 2 (limit: 4915)
   Memory: 3.6M
   CGroup: /system.slice/clamav-daemon.service
           └─632 /usr/sbin/clamd --foreground=true

févr. 22 14:22:57 XX clamd[632]: Fri Feb 22 14:22:57 2019 -> SelfCheck: Database status OK.
févr. 22 14:32:57 XX clamd[632]: Fri Feb 22 14:32:57 2019 -> SelfCheck: Database status OK.
févr. 22 14:42:57 XX clamd[632]: Fri Feb 22 14:42:57 2019 -> SelfCheck: Database status OK.
févr. 22 14:49:49 XX systemd[1]: Reloading Clam AntiVirus userspace daemon.
févr. 22 14:49:49 XX systemd[1]: Reloaded Clam AntiVirus userspace daemon.
févr. 22 14:49:50 XX clamd[632]: Fri Feb 22 14:49:50 2019 -> Reading databases from /var/lib/clamav
févr. 22 14:50:02 XX clamd[632]: Fri Feb 22 14:50:02 2019 -> Database correctly reloaded (6998299 signatures)
févr. 22 15:00:02 XX clamd[632]: Fri Feb 22 15:00:02 2019 -> SelfCheck: Database status OK.
févr. 22 15:10:03 XX clamd[632]: Fri Feb 22 15:10:03 2019 -> SelfCheck: Database status OK.
févr. 22 15:21:38 XX clamd[632]: Fri Feb 22 15:21:38 2019 -> SelfCheck: Database status OK.

clamav-daemon.service is apparently working and has the PID 632 whereas the clamav-milter.service has the following PID 633, so I cannot understand what is not working.

I am writing it here since I think that it should be linked with the update.

Thanks a lot for the update and the work the developers made and for your help.


#234

What is the issue with network inside TTY? I’ve just checked and internet work for me in tty mode.


#235

Did you verify that that option still exists with that name?
EDIT: according to the manpage, there is no such option in clamav-milter.conf.
So it should work again when you remove that option (or comment it).
Maybe there’s also a clamav-milter.conf.pacnew file.


#236

Depending on the hardware and the installation, network (WiFi) doesn’t always work in a TTY when in runlevel 3.


#237

Despite the fact that I didn’t have issues with last update, I read all messages in this topic to learn advice’s.
So I’m ready for new update.


#238

You are absolutely right.

What I mean by “one-package updates” is a notification to update one package (like masterpdeeditor from AUR).

Partial updates are forbidden for me


#239

do you mean using systemctl isolate multi-user.target?


#240

After what appeared to be a successful update, I found that with kernel 4.14 I continued to experience the 2-minute delay every time I shut down the computer (even after closing all programs):

A stop job is running for User Manager for UID 1000

My grub configuration does not include quiet, so I ordinarily see scrolling text during shutdown. One time since the update, I saw instead of scrolling text a black screen with a non-flashing cursor. I waited 2 minutes and the computer then shut down normally.

Upgrading to kernel 4.19 seems to have corrected this problem. With the newer kernel the computer has so far been shutting down promptly.

Edit: It turns out that this problem occurs frequently (but not always) upon shutting down no matter which kernel I am using. I was mistaken when I stated that the problem does not occur when using kernel 4.19.


#241

You can get by it this way.
@kwg

Edit this file but always make a backup first.

/etc/systemd/system.conf

Look for this line and change this line

#DefaultTimeoutStopSec=90s

to

DefaultTimeoutStopSec=10s

#242

Yes, it works, but it doesn’t correct the underlying problem.


#243

Best start your own thread on the subject then. :grin:


#244

If this

“A stop job is running for User Manager for UID 1000” at shutdown/reboot, what should I do?

Stopping of the User Manager job may take 2 minutes due to the systemd update. Simply wait and let it go. It usually goes away at next boot.

not true

Try from terminal
systemctl poweroff