[Stable Update] 2019-02-19 - Kernels, KDE, LibreOffice, Systemd, VirtualBox, Deepin, Qt, Firmwares, Wine

update
stable

#205

I used Octopi for this update, although only by accident somehow. As far as I can tell there are no issues - at least system is booting, and there is nothing obvious wrong at the moment.

Command

journalctl -p err -b

reveals nothing.

Is there any way, apart from testing some things, that something went wrong in this update?


#206

I had this message too!
With the comments from @Frog and @ghayne I can sove it.


#207

I update through pacman because I like to read and keep a copy of the update process that is output to terminal. There is extra information that is not logged to pacman.log. In pamac that information is in a small window and the lines are cut off (have to scroll around to read). So using pacman to do updates is more convenient for me.

However, I use pamac all the time to research packages. It is much quicker and easier than pacman for that. Also the notifications are very useful. I just don’t use it to do actual updates.


#208

Pkgbrowser is also handy for this. It’s in the repos.


#209

It’s true except when you use pamac-cli as root (with sudo). In this case pamac directly uses libalpm without polkit/dbus, as pacman does.


#210

I had a very slight niggle, myself, after updating through Octopi using the GUI(for once I didn’t go through Konsole, twas mere laziness I fear)…:wink:


#211

Only 2 months in with Manjaro. After much reading I used TTY: sudo pacman-mirrors -f and sudo pacman -Syyu. Thanks for various people advising on the forum. No errors at all. Then rebooted KDE via systemctl reboot, letting it naturally shut down over the 2+ minutes. Brilliant! Thanks for the updates. System is definitely running faster too. :slight_smile: :+1:t2:


#212

Update completed successfully. I had to run systemctl reboot, because the shutdown icon did not appear in my start menu after installation. Then, “A stop job is running for User Manager for UID 1000” appeared on the screen. Following the instructions, I just had to wait a couple of minutes for systemd to update and everything worked fine.

I have updated my system through TTY, although I updated the mirrors and synchronized them with Konsole. For a newbie with a few weeks of experience in Manjaro, test passed. I confirm that it is important to read the instructions, and to listen to the experienced users! :grinning:


#213

Ooh, please please let me be right… is your avatar-name perchance an honorarium to Dick Dastardly and Muttley?


#214

You’re absolutely right, lol! :slight_smile: I’m a bit of a giggler, and used to love watching the program. You too?


#215

Ooh yes, with bells on! That show [like you, apparently] always had me in stitches. It was soooo droll. Sigh, such a long looooooooooooong time ago now… sob sniff. I’m so pleased to learn another Manjaroo remembers & loves it. :grin:


#216

Lol, yes … there’s some great clips on Youtube [Freetube] … MUTTLEY My Favorite Cartoon Dog (The Best Dog Laugh Ever) . All the different contraptions that Dasterdly fell foul of as well … rasenfrasen :rofl:
There were so many great programmes back then. Potty time was very funny too. Roobarb and Custard. Bagpuss. Great to rewatch clips now. :+1:t2:
Great to meet a fellow Muttley aficionado :smiley:


Installed kernel doesn't show up 2
#217

and @kdemeoz

Stop OT :wink: :slight_smile:

79be8ec76bf8a230d04553728e354a52--animated-cartoons-cartoon-fun
dd-m


Deepin Wallpaper and more by SGS
#218

Hey, what’s the big idea? How come you’ve crashed our DD&M channel? How dare you go OT by talking about Manjaro Stable Updates! Go start your own thread for such immaterial stuff. We know what’s truly important – DD&M :stuck_out_tongue_winking_eye:


#219

Updated a few minutes ago using TTY (my first Manjaro major update!). Everything went smoothly although I got the ptyqt5 error. However waiting for a few days before updating, reading the announcements and applying the proposed fixes made this update a breeze! Thanks for the great work! I used the following procedure to update (taken from Applying manjaro update from TTY, credits to @rahulprabhakar):

  1. Save and close all application.

  2. Logout [Eg. In KDE press Ctrl + Alt + Del and then click logout]

  3. Press Ctrl + alt + F2 and switch to TTY2. You can also try Ctrl + alt + F3 for TTY3 if required.

  4. Login on TTY2

  5. Run nmtui (Ncurses based network manager gui to connect to Lan / Wifi.)

  6. Run sudo pacman-mirrors -f 5 (Update mirrorlist with 5 fastest up to date mirrors)

  7. Run sudo pacman -Syyuw (First only download all packages to manage breaking change during package installation)

  8. Run sudo pacman -Syu

  9. Done with update, Run systemctl reboot


#220

I used pamac in the ttyl and encountered this problem several times. I then used pacman and had a smooth update.


#221

sorry for my frustration but I was already fed up by lot’s of bug’s I’ve been experiencing before, but now that libre-office and octopi became unusable I’m pretty sure I’ll be reformatting my manjaro laptop soon and move on to some other distro.


#222

Originally coming from Windows and still using it at work and my desktop at home, I’m used to the “Don’t turn off you computer” message that is shown on screen during long update processes. Is it possible that some Manjaro users during this last update did a hard reset with the Power button during this update thinking that their computer had crashed and that caused an issue on reboot?

I didn’t see any messages during reboot after this update, as I have bootsplash installed and enabled, but knowing what I know, I just waited for the update to complete and had no problems whatsoever.

I also run Manjaro on an old Dell laptop with no fancy configuration, so maybe all the bugs have been worked out in the linux software for my level of hardware.


#223

You are probably fine. (Remember that it is only a bit less than 20% of people having ‘problems’.)

If you did not pay attention at the time to the output - I generally read/skim through mine before closing the terminal - much of it is written to var/log/pacman.log.


#224

ublux