[Stable Update] 2019-02-19 - Kernels, KDE, LibreOffice, Systemd, VirtualBox, Deepin, Qt, Firmwares, Wine

update
stable

#185

I perform updates exclusively using sudo pacman -Syyu through Yakuake in KDE and don’t recall ever having a serious issue since I started using Manjaro more than three years ago, and I’m no IT professional.

However, I make a habit of reading through all the (often lengthy) Stable, Testing and Unstable announcements for “Known Issues and Solutions”.

I do also use Octopi, but only to install / remove individual packages and don’t have Pamac installed at all (don’t see why I would need it). Discover is installed for the update notification in the system tray, but then again I always update using pacman.


#186

Same situation here

I have found pamac unable to perform one-package updates at times (probably from AUR, sorry, I cannot remember exactly), which were successfully installed using pacman or yaourt, so I ended up using pacman (tty) / yaourt exclusively.

So, since I lost trust to it, pamac is just a notification icon form me (no offence intended to anyone, it’s just the way it is).

I am running manjaro for the last 3-4 years on home pc (xfce) and laptop (mate) and never had any problem (always reading announcements and all)


#187

That kinda a big issue if the community itself starts to lose trust to the software (in this case, the package manager) made in-house for Manjaro.

(I’m not shaming you for that, it’s a normal reaction when we have bad experience. I’m talking in general.)


#188

I maintain two separate but similar Manjaro i3 installations on my laptop (or rather, I did). One is my primary production install with an encrypted home partition, the other is just a testbed with no data and no encryption.

Usually I wait for the Stable Update announcement and subsequent posts from others to learn from their experiences. If everything seems mostly okay then I’ll run pacman in a terminal (but not tty) on my testbed. If all goes well then I’ll finally update my main production installation.

For some reason I did the whole procedure backwards this time.

This latest update announcement came out rather late and inexplicably decided to update my primary install (with encryption) first (what could go wrong?). The whole thing crashed at some point during the update. Luckily, the system rebooted fine and everything seems to be working okay.

The following day I ran pacman on my test installation (no encryption). Another system crash part way through the update but this time there would be no successful restart. My Manjaro test system is dead. Not a big problem though as it was just a testing installation.

Just wanted to put my recent experience out there because I think that perhaps there is too much blame being attributed to system encryption and the GUI pamac.


#189

Tis a pity your TB went south [why not recover it via a LiveISO chroot, btw?]. I share your [erstwhile] practice. I pedantically update each of my Stable VMs first [Xfce, Cinnamon, OpenBox, enlightenment, Plasma]. If they were successful [or otherwise i solved any problems], i next update my Stable Plasma Lappy [secondary pc]. Only then, if this update also went ok, will i finally update my Stable Plasma Tower [primary rig]. Tis terribly anal-retentive of me i know, but i’m a cautious chicken,


#190

I possibly will but I’ve been thinking about putting other WM’s in its place as well. Qtile is one that I’ve been wanting to try for quite a while. Haven’t looked at Awesome WM in some time either so perhaps that one as well.

Yeah, me too :smiley:


#191

is it possible to stuck at a qt version? like qt 5.12.1


#192

This is not a good idea on Manjaro, especially in long term.

The reason is because Manjaro, like Arch, normally always publishes software built with the lastest libraries available. What can happen is that eventually, the newest version is not backward compatible with the older version and will get a SOname bump.

If you hold back libraries for a long time, expect to get a error like that with software compiled against those libraries eventually.

cannot open shared object file: No such file or directory

#193

Zero problems with update: (TTY pacman -Syu). i3 - Kernel 4.14.
Waited out the 2 min stop process.
Removed Qualcom Atheros “firmware-6.bin”, always have to do this before starting up again (else no wifi). Apparently it wants firmware-5.bin, and if firmware-6.bin is present, no go. I wonder if firmware-6.bin is for Kernel 4.19? eventually I will try 4.19 and see what happens.

Thanks to everyone on the team for your continual work for us.


#194

Qualcomm Wi-Fi adapter, eh?

A long time ago, I had problem with kernel 4.14. Since then, I upgraded to 4.19, it works fine without having to delete any file on my side.

You can try kernel 4.19 and see if Wi-Fi works fine, and see if it works fine with your hardware in general too.

I recommend not to uninstall kernel 4.14 though, as it can still be useful as an “emergency kernel” for troubleshooting despite having compatibility problem.


#195

@Frog thanks for the tip. I should get off my rear and try 4.19. The -6-bin gets added back each update, I have a script to pull it off to another folder after each update. I’ll keep 414 as fall back.


#196

I have an production machine with Qtile, and old machines with Xfce, that I update before my production machine.

Qtile is a very interesting window manager. Some basic knowledge about python, maybe a little about OOP, and you can make an good configuration.


#197

I have an Arch gnome install (formerly Apricity), and I just use terminal from within Gnome for my updates with a straightforward
sudo pacman -Syu
except when I refresh the mirror list. I have been blissfully unaware of any problems the past few months, although my computer usage is generally normal everyday stuff.

These 2 months have seemed more tumultuous in Manjaro Stable land than Arch, at least on my system. I don’t update Arch in tty and yet I have been instructed twice in the past 2 months to do so in Manjaro.

The Arch news page hasn’t shown any new update warnings since mid last year. I also have a bare bones Anarchy OS (gnome) virtual machine which I update first then reboot to see if problems arise but it’s been uneventful so it’s always straight to real metal update of Apricity after that.

I update weekly instead of daily so the Arch updates do accumulate, unlike in DeMus’ case, yet I haven’t faced trouble with systemd or whatever.

As I understand it, pamac won’t just update one package at a time from the normal Manjaro repos, but will initiate a full upgrade because partial upgrades are not recommended. For AUR, yes you can use pamac to upgrade one package at a time, but only after all the normal repo upgrades have been installed.

My procedure is to update all the normal repo stuff first using pacman in the terminal after checking announcements. Once that’s done, I open pamac and see what AUR updates are available. If the AUR page for the package(s) in question doesn’t show problematic comments, I use pamac to install the update one by one.

I use pamac only for one-off removal or installation of packages (after completing my system upgrades in terminal), checking details/dependencies of individual packages, and viewing at a glance the list of orphaned or foreign packages during occasional maintenance checks.

I feel this needs to be said: pamac is a good and convenient tool but not for system upgrades. If for every upgrade one has to check announcements first to see if it’s safe to use pamac GUI for the upgrade, then let’s warn newcomers upfront that pamac is not really suitable for that purpose.


#198

I’m experiencing the same. My Arch machine has been more stable than my Manjaro system, albeit with very different hardware. Still, I find it ironic.

Yeah. I’m looking forward to the experience.


#199

Is there anyone who can answer this question? In my neighbor’s Manjaro laptop Octopi is used as well and it would be interesting to know if that woks well or not. So, has somebody here updated using Octopi and if so, what was the outcome?


#200

Have a guess when Manjaro started building and maintaining systemd packages, indepenent from Arch, releasing into unstable before Arch … can you guess?

Can ya? Wanna hint?

Can you also guess the packages causing pretty much all of the serious issues?

Can ya? Wanna hint?

Hopefully it is teething problems, but I personally don’t believe Manjaro has the technical user base to become a systemd early adopter / guinea pig.

Decision is seemingly final, bed has been made, and now we all have to sleep in it.


#201

yes i have used octopi as usual and with the terminal option when you have the choice between ok/cancel/terminal and now i have various bugs [Stable Update] 2019-02-19 - Kernels, KDE, LibreOffice, Systemd, VirtualBox, Deepin, Qt, Firmwares, Wine :s the system is still working but it’s annoying and i wonder what other bugs i will discover :disappointed_relieved:


#202

:open_mouth:

I had no idea.


#203

That may explain then.
I have had no trouble using Pamac for big updates on my end (>1GB). Only twice or thrice i updated through TTY/pacman because of a known risky update, every time because of a major systemd update.


#204

So this means the updates have to be done using the terminal, or even better log in to the command line with CTRL+ALT+F2 and use Pacman -Syyu.
Thank you for your answer.