[Stable Update] 2019-02-19 - Kernels, KDE, LibreOffice, Systemd, VirtualBox, Deepin, Qt, Firmwares, Wine

Greetings! I’ve been using Manjaro Deepin for the last 4 months no major issues at all and it’s been great! However I don’t think I will update if you guys expect their to be breakage on Deepin. Last I checked I’m on the stable edition, not testing. I enjoy all the work you developers do and hope this breakage issue gets resolved, but until then I won’t update unless I know it’s safe. Thank you for your continued hard work, my apologies if my comment is negative.

1 Like

I pushed an update for curl to fix a 100% CPU usage issue with networkmanager.

Hmm, have to see about that one. Maybe a rebuild of pacman is needed. Will see what I can do about that one.

@oberon already has the needed patches. He is working on providing them to the stable branch as soon as possible. So for now, please hold your horses.


Copy that, the horses are in the stable :wink:
And thanks for the speedy reply!
And good luck and thank you to @oberon

1 Like

Hey there,

@philm was trying a fresh install via calamares with standard ext4 + full-encryption + swap with hibernation with the latest iso of kde (http://rwthaachen.dl.osdn.jp/storage/g/m/ma/manjaro/kde/18.0.3/manjaro-kde-18.0.3-stable-x86_64.iso)

After successful installation a reboot was triggered and landed in grub-rescue mode.

Tested in Virtualbox. Can somebody confirm this?

Please provide the installation log of your installation or the exact steps you did. Personally I didn’t test encryption yet.

Good evening!

After the update i did a reboot and now my system doesn’t start anymore.
The following is shown at startup:

:: running early hook [udev]
Warning: /lib/modules/4.19.23-1-MANJARO/modules.devname not found - ignoring
starting version 239
:: running hook [udev]
:: Triggering uevents...
ERROR: device 'UUID=...' not found. Skipping fsck.
:: mounting 'UUID=...' on real root
mount: /new_root: can't find UUID=...
Your are now being dropped into an emergency shell.
sh: can't access tty; job control turned off
[rootfs ]# _

I can’t do anything after that, just a blinking underscore and no reaction to keyboard inputs. I managed to start my system with an 4.18 Kernel that is still installed, so i should be able to do something about that, but i really don’t know what to do.

EDIT: I fixed it. During my update i3wm crashed and i had to continue the update (updated in terminal). Apparently at the end of the update mkinitcpio wasn’t run, so i did that manually: mkinitcpio -p linux419

My update went poorly as well. I used pamac and cinnamon crashed which left me looking at a flashing cursor for a while before it started again.

After a reboot I discovered that the NetowrkManager nor pacman would run because they where looking for libidn2.so.4 but I had libidn2.so, so.0 and so.0.3.5 so I copied one and renamed it to get it all working.

Later I checked the provided files for libidn2; it does not supply libidn2.so.4 so I don’t know what happened if this issue is fairly isolated. Maybe a script didn’t run at the end of the update.

1 Like

Updated 2 stable Plasma systems via terminal. Update on both went fine. Only problem was that Calf would no longer run. Solved with updating from calf-git 0.90.1.r2531 to calf 0.90.1-4.
Many thanks to Philm and the team.

libidn2 was an older issue with the last update. The issue is more with curl and that got fixed today:

lddtree /usr/bin/pacman
/usr/bin/pacman (interpreter => /lib64/ld-linux-x86-64.so.2)
    libalpm.so.11 => /usr/lib/libalpm.so.11
    libgpgme.so.11 => /usr/lib/libgpgme.so.11
    libassuan.so.0 => /usr/lib/libassuan.so.0
    libgpg-error.so.0 => /usr/lib/libgpg-error.so.0
    libcurl.so.4 => /usr/lib/libcurl.so.4
        libnghttp2.so.14 => /usr/lib/libnghttp2.so.14
        << libidn2.so.0 => /usr/lib/libidn2.so.0 >>
            libunistring.so.2 => /usr/lib/libunistring.so.2
        libssh2.so.1 => /usr/lib/libssh2.so.1
        libpsl.so.5 => /usr/lib/libpsl.so.5
        libssl.so.1.1 => /usr/lib/libssl.so.1.1
        libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2
            libkrb5support.so.0 => /usr/lib/libkrb5support.so.0
            libdl.so.2 => /usr/lib/libdl.so.2
            libkeyutils.so.1 => /usr/lib/libkeyutils.so.1
            libresolv.so.2 => /usr/lib/libresolv.so.2
        libkrb5.so.3 => /usr/lib/libkrb5.so.3
        libk5crypto.so.3 => /usr/lib/libk5crypto.so.3
        libcom_err.so.2 => /usr/lib/libcom_err.so.2
        libz.so.1 => /usr/lib/libz.so.1
        libpthread.so.0 => /usr/lib/libpthread.so.0
    libcrypto.so.1.1 => /usr/lib/libcrypto.so.1.1
    libarchive.so.13 => /usr/lib/libarchive.so.13
        libacl.so.1 => /usr/lib/libacl.so.1
            libattr.so.1 => /usr/lib/libattr.so.1
        libexpat.so.1 => /usr/lib/libexpat.so.1
        liblzma.so.5 => /usr/lib/liblzma.so.5
        libzstd.so.1 => /usr/lib/libzstd.so.1
        liblz4.so.1 => /usr/lib/liblz4.so.1
        libbz2.so.1.0 => /usr/lib/libbz2.so.1.0
    libm.so.6 => /usr/lib/libm.so.6
    libc.so.6 => /usr/lib/libc.so.6

Hello @philm i posted the steps here https://forum.manjaro.org/t/failed-install-with-latest-manjaro-kde-18-0-3-stable-x86-64-iso/76443

Versuche mal:

sudo rm /usr/lib/python3.7/site-packages/PyQt5/pycache/init.cpython-37.pyc

Und wieder ein update versuchen.

This was my exact same experience, now on several laptops and desktops. Moral of the story. Never trust the GUI pacman. I will be removing the “upgrade” option from the menu bar from my Linux student systems. I give them admin and encourage them to update their systems regularly (and of course create their own backup strategies) but this one really got us. We had become used to the stability and forgot this is actually still wild Linux country. I have also noticed problems creating LUKS encrypted partitions while building from ISOs but will cover that in another post.

Sounds like a flat-earther comment :slight_smile:


Same issue happened with me. Solved by restoring from backup and running update by terminal. Seems gnome session was stopped and update didn’t finished

Update went flawlessly. Thanks for the awesome work!

Had the same issue. Had to live boot and chroot to downgrade systemd.

Which DE do you use?

Was my weirdest update yet. XFCE. Went through tty using pamac. Downloaded the updates OK. Started installing then seemed to finish at

Terminateddnsmasq (2.80-2 -> 2.80-3)
[hipster@manjaro ~]$

Went to the default login (what you see when opening a terminal).

Did ctrl+alt+f7. Booted into manjaro then almost instantly got an error about a connection. No mouse no nothing. Went back to tty & rebooted.

Booted back into manjaro OK then more updates appeared. Went back to tty & finished the updating.

Now it is all OK & downloaded. :thinking:

Just as info: There is an issue with Kernel 4.20.10 / 4.19.23 and powertop, also it is more a general problem:
Didn’t realize any other problems caused by that.

Wow, the amount of bug we got recently from upstream projects (kernel, Libre Office, systemd etc.) is kinda astounding. (According to your post, it is fixed with a change in the kernel code)

What a rough time to be on a rolling release, cutting-edge distro these days. Even on Arch, it seems they are having a hard time this winter.

I sympathize with all Manjaro and Arch maintainers that will take 100% of the blame. :grinning:


Forum kindly sponsored by Bytemark