[Stable Update] 2019-02-09 - Kernels, Deepin, Firefox, Wine, Python, Haskell

update
stable

#70

Depicts my experience
never had as little trouble with my OS as in the last 3 years with Manjaro :smiley:


#71

And then I have to change my os
 :confused:


#72

All 5 Dell/Intel machines updated fine through the tty.
As always great work and a big thank you :+1:

Alex


#73

All ok, KDE kernel 4.19, tty pacman, working well, thanks Manjaro team


#74

Update without problem. The only doubt is that I can not get into TTY mode with closed user session on my laptop through the combination of keys Ctrl-Alt-F2 

The update I made via terminal with user session started with the command sudo pacman -Syyuu, is that correct?

System:
  Host: atreides-pc Kernel: 4.20.7-1-MANJARO x86_64 bits: 64 
  Desktop: Gnome 3.30.2 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Hewlett-Packard product: HP G62 Notebook PC 
  v: 0497100000252710001020000 serial: <root required> 
  Mobo: Hewlett-Packard model: 143A v: 60.21 serial: <root required> 
  BIOS: Hewlett-Packard v: F.0A date: 06/14/2010 
CPU:
  Topology: Dual Core model: Intel Core i3 M 350 bits: 64 type: MT MCP 
  L2 cache: 3072 KiB 
  Speed: 1375 MHz min/max: 933/2266 MHz Core speeds (MHz): 1: 1136 2: 1429 
  3: 1441 4: 1399 
Graphics:
  Device-1: Intel Core Processor Integrated Graphics driver: i915 v: kernel 
  Device-2: AMD Park [Mobility Radeon HD 5430/5450/5470] driver: radeon 
  v: kernel 
  Display: x11 server: X.org 1.20.3 driver: radeon 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel Ironlake Mobile v: 2.1 Mesa 18.3.2 

Thanks Manjaro team

Powered by Google Translator :sweat_smile:


split this topic #75

A post was split to a new topic: Deepin VM DM segfault


#76

Unlike the last update, everything went well, but I was afraid a little bit, it will be a problem. :slight_smile:


#77

What is the “safest” way to update per terminal?
Is it sudo pacman -Syyuu ?
Or are there better ways?
Thank you for your work!


#78

I prefer pacman -Syyu but always read the release notes at the top of each release.


#79

The final u is only needed if you want to enable downgrade. sudo pacman -Syyu is the standard way. Otherwise, pamac update does exactly the same thing (sudo not needed here, pamac asks you for password).

I prefer pamac as it can check updates from the AUR too if you have it enabled. It also has a more “human” syntax. Check this - Pamac CLI


#80

Permission problems also give those warnings. Sometime programs need a lower level read permission, but permissions change to root only rw.


#81

pacman is run as root though so that shouldn’t be the issue here?


#82

Hi,
Thank you, Manjaro Team!. Update process went fine.
jochoa@jochoa
OS: Manjaro 18.0.2 Illyria
Kernel: x86_64 Linux 4.19.20-1-MANJARO
Uptime: 22m
Packages: 1179
Shell: bash 5.0.0
Resolution: 1366x768
DE: KDE 5.54.0 / Plasma 5.14.5
WM: KWin
WM Theme: Breath
GTK Theme: Breath [GTK2/3]
Icon Theme: maia
Font: Noto Sans Regular
CPU: AMD A8-7410 APU with AMD Radeon R5 Graphics @ 4x 2.2GHz
GPU: AMD MULLINS (DRM 2.50.0, 4.19.20-1-MANJARO, LLVM 7.0.1)
RAM: 1200MiB / 3401MiB


#83

When using pacman the proper and safely adequate (or adequately safe) command is

pacman -Syu

You only need to run two yy when/if you change mirrors, or other mirror/repo basic change or init. Not for normal/everyday usage.


It’s pity (only IMHO) that a lot of users use to always re-download databases, even if they don’t need to (are already up-to-date). It’s a waste of Global Internet bandwidth and Global power consumption (but who cares?..).


It’s also awkward (to me) that a lot of users rush updating their systems, like if there is some war or challenge, when they don’t have a special reason (a new package will solve an ongoing issue etc
). But it’s a personal choice



I said it! Now keep on with what you were doing!.. :laughing:


#84

When I searched linux418 in pamac-gui I only saw 4 items green box/installed: linux418 {kernel and modules} and the 418 nvidia driver, and ditto for 418-rt. I just checked 418 kernel and 418 nvidia driver for removal in the gui without using the terminal and it worked [it is gone]. Have now updated successfully, did I miss something? Seemed too easy :slight_smile: thanks


#85

Nope, if that was all that was listed you are good. Nice that it works from the pamac-gui. :smile:


#86

Thanks for the update. I made the update and receive this warning message meaning that it was impossible to pick the information of the files for usr/lib/python3.7 up:

Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil-5.4.8-py3.7.egg-info/
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil-5.4.8-py3.7.egg-info/PKG-INFO
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil-5.4.8-py3.7.egg-info/SOURCES.txt
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil-5.4.8-py3.7.egg-info/dependency_links.txt
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil-5.4.8-py3.7.egg-info/not-zip-safe
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil-5.4.8-py3.7.egg-info/top_level.txt
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil/__pycache__/__init__.cpython-37.opt-1.pyc
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil/__pycache__/_common.cpython-37.opt-1.pyc
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil/__pycache__/_compat.cpython-37.opt-1.pyc
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil/__pycache__/_exceptions.cpython-37.opt-1.pyc
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil/__pycache__/_psaix.cpython-37.opt-1.pyc
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil/__pycache__/_psbsd.cpython-37.opt-1.pyc
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil/__pycache__/_pslinux.cpython-37.opt-1.pyc
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil/__pycache__/_psosx.cpython-37.opt-1.pyc
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil/__pycache__/_psposix.cpython-37.opt-1.pyc
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil/__pycache__/_pssunos.cpython-37.opt-1.pyc
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil/__pycache__/_pswindows.cpython-37.opt-1.pyc
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil/tests/__pycache__/__init__.cpython-37.opt-1.pyc
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil/tests/__pycache__/__main__.cpython-37.opt-1.pyc
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil/tests/__pycache__/test_aix.cpython-37.opt-1.pyc
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil/tests/__pycache__/test_bsd.cpython-37.opt-1.pyc
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil/tests/__pycache__/test_connections.cpython-37.opt-1.pyc
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil/tests/__pycache__/test_contracts.cpython-37.opt-1.pyc
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil/tests/__pycache__/test_linux.cpython-37.opt-1.pyc
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil/tests/__pycache__/test_memory_leaks.cpython-37.opt-1.pyc
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil/tests/__pycache__/test_misc.cpython-37.opt-1.pyc
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil/tests/__pycache__/test_osx.cpython-37.opt-1.pyc
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil/tests/__pycache__/test_posix.cpython-37.opt-1.pyc
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil/tests/__pycache__/test_process.cpython-37.opt-1.pyc
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil/tests/__pycache__/test_sunos.cpython-37.opt-1.pyc
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil/tests/__pycache__/test_system.cpython-37.opt-1.pyc
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil/tests/__pycache__/test_unicode.cpython-37.opt-1.pyc
Avertissement: impossible de récupérer les informations de fichier pour usr/lib/python3.7/site-packages/psutil/tests/__pycache__/test_windows.cpython-37.opt-1.pyc

In Pamac, I see that python is not a AUR package, but an “extra” one.

What should I do?

Thanks in advance.


#87

No problems with the update!

Just one thing that caught my attention,
lightdm: local (1:1.28.0-1.1) is newer than extra (1:1.28.0-1)

May I ask why was lightdm was downgraded?


#88

#89

Have problems with both of my test-machines and lot of them reproduceable with VM:

Some of them is Deepin / 4k related, some Manjaro only