[Stable Update] 2019-02-09 - Kernels, Deepin, Firefox, Wine, Python, Haskell

update
stable

#22

Most likely that if you had just waited a while (a coupe of hours at worst), it would have been OK.

Mirrors doesn’t synchronize instantaneously. lol


#23

Everything went smooth. Got a dependency cycle warning between Mesa and something wayland related but I ignored it.

I was hoping for Virtual Box 6.0.4 though. Maybe next time :slight_smile:

Thank you to all the devs for the update, my wife for allowing me to install it and my cat for not jumping on the keyboard while pamac was doing its thing. :+1:


#24

I’d like to believe you’re correct but I’ve had to run that command even when it wasn’t same day.


#25

No worries. It’s currently on Unstable, so it’ll come eventually.

That’s odd. Normally, you don’t have to refresh your mirror list each time just to get updates. :confused:

I know some mirrors take a long time to sync (like 24 hours, maybe even more), so depending on the mirror, it can happens that you’ll only get the new stuff the next day.

What do you usually use to check and apply updates?


#26

after 2nd reboot also my trackpad worked again. wlan sometimes needs second or third reboot - no change. but it is s broadcom-topic I think.
lenovo yoga pro3 kernel 420

great work, thx!


#27

You’ve been lucky. The update I did today was 64 packages.


#28

keyring update problems:

sudo pacman -Syyuu

> Blockquote (84/84) checking keys in keyring                                                              [#######################################################] 100%
downloading required keys...
:: Import PGP key 2048R/8218F88849AAC522E94CF470A5E9288C4FA415FA, "Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>", created: 2011-08-25? [Y/n] y
error: key "Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>" could not be imported
:: Import PGP key 4096R/B5971F2C5C10A9A08C60030F786C63F330D7CB92, "Felix Yan <i@felixc.at>", created: 2012-01-20? [Y/n] y
error: key "Felix Yan <i@felixc.at>" could not be imported
:: Import PGP key 2048R/86CFFCA918CF3AF47147588051E8B148A9999C34, "Evangelos Foutras <foutrelis@gmail.com>", created: 2010-11-12? [Y/n] y
error: key "Evangelos Foutras <foutrelis@gmail.com>" could not be imported
:: Import PGP key 2048R/535F8C0339450F054A4D282706096A6AD1CEDDAC, "Laurent Carlier <lordheavym@gmail.com>", created: 2011-10-30? [Y/n] y
error: key "Laurent Carlier <lordheavym@gmail.com>" could not be imported
:: Import PGP key 2048R/F3691687D867B81B51CE07D9BBE43771487328A9, "Bartlomiej Piotrowski <b@bpiotrowski.pl>", created: 2011-10-10? [Y/n] y
error: key "Bartlomiej Piotrowski <b@bpiotrowski.pl>" could not be imported
:: Import PGP key 4096R/BD27B07A5EF45C2ADAF70E0484818A6819AF4A9B, "Eli Schwartz <eschwartz93@gmail.com>", created: 2016-05-04? [Y/n] y
error: key "Eli Schwartz <eschwartz93@gmail.com>" could not be imported
:: Import PGP key 2048R/E499C79F53C96A54E572FEE1C06086337C50773E, "Jelle van der Waa <jelle@vdwaa.nl>", created: 2011-10-08? [Y/n] y
error: key "Jelle van der Waa <jelle@vdwaa.nl>" could not be imported
:: Import PGP key 4096R/C100346676634E80C940FB9E9C02FF419FECBE16, "Morten Linderud <mcfoxax@gmail.com>", created: 2014-09-05? [Y/n] y
error: key "Morten Linderud <mcfoxax@gmail.com>" could not be imported
:: Import PGP key 2048R/E4CDFE50A2DA85D58C8A8C70CAA6A59611C7F07E, "Philip Müller (Called Little) <philm@manjaro.org>", created: 2012-05-05? [Y/n] y
error: key "Philip Müller (Called Little) <philm@manjaro.org>" could not be imported
:: Import PGP key 2048R/02FD1C7A934E614545849F19A6234074498E9CEE, "Christian Hesse (Arch Linux Package Signing) <arch@eworm.de>", created: 2011-08-12? [Y/n]
y
error: key "Christian Hesse (Arch Linux Package Signing) <arch@eworm.de>" could not be imported
:: Import PGP key 4096R/3DCE51D60930EBA47858BA4146F633CBB0EB4BF2, "Filipe Laíns (FFY00) <filipe@lains.me>", created: 2018-04-18? [Y/n] y
error: key "Filipe Laíns (FFY00) <filipe@lains.me>" could not be imported
:: Import PGP key 4096R/76C6E477042BFE985CC220BD9C08A255442FAFF0, "Jonathon Fernyhough <jonathon@manjaro.org>", created: 2014-03-31? [Y/n] y
error: key "Jonathon Fernyhough <jonathon@manjaro.org>" could not be imported
:: Import PGP key 4096R/04DC3FB1445FECA813C27EFAEA4F7B321A906AD9, "Daniel M. Capella <polycitizen@gmail.com>", created: 2016-01-03? [Y/n] y

error: key "Daniel M. Capella <polycitizen@gmail.com>" could not be imported
error: required key missing from keyring

I tried
sudo pacman-mirrors -f
but got the same results after.


#29

Hello, kernel 417 removed no problem using settings manager, trying to remove 418 [I also have 418rt installed] I get this. Says completed, but kernels are still shown in list, same after restarting.

linux418
linux418-rt
linux418-rt-nvidia-340xx
linux418-nvidia-340xx
Starting
checking dependencies...
:: linux-rt-manjaro: removing linux418-rt breaks dependency 'linux418-rt'
:: linux-rt-manjaro-nvidia-340xx: removing linux418-rt-nvidia-340xx breaks dependency 'linux418-rt-nvidia-340xx'
Done ...

Trying to remove kernel 418-rt first, I get this:

linux418-rt
linux418-rt-nvidia-340xx
Starting
checking dependencies...
:: linux-rt-manjaro: removing linux418-rt breaks dependency 'linux418-rt'
error: failed to prepare transaction (could not satisfy dependencies)
:: linux-rt-manjaro-nvidia-340xx: removing linux418-rt-nvidia-340xx breaks dependency 'linux418-rt-nvidia-340xx'
Done ...

thanks for any info


#30

Try doing the removal with pacman (for each package), e.g.
sudo pacman -R linux418
Best to be booted into a kernel you are not removing. :wink:

(Looking back at my logs I needed to remove the other modules first so the order for me was linux418-vhba-module, linux418-nvidia then linux418. After updating I realized that I still needed to remove linux418-headers. But you will likely have a different set of packages.)

Search in pamac-gui with ‘linux418’ and sort by state to see all you have installed that will need to be removed.

As far as I am aware linux418-rt is still supported and will not need to be removed, but the update process will know better than me.


#31

My keyring problems were solved by followiing Jonathon’s nuclear option.


#32

thanks, I’ll have to get back to this later as I want to back up my system first. This has moved into uncomfortable territory for me, wish the settings manager/one click method would work :slight_smile:

yes, correct, I noticed that. Will start with the other one first, thanks


#33

Backup are always good. :+1:

It is for the best that Manjaro does not remove packages installed by the user (imagine if you were depending specifically on linux418 for some reason…) but I understand the concern.


#34

I’ve been using the “super stable” update method for some time, i.e. waiting a few days for any dust to settle before updating. Saw the warning about the kernels so thought I’d do some pre-update prep. Several times in the past 6 months or so “problems” shown early in the update thread have been taken care of after waiting, which has been great!


#35

That’s boring.

Make no backups, fire up pamac, hit next next, next and reboot. Better than a caffeine shot. Guaranteed :+1: :smile:


#36

Ran sudo pacman -Syyuu, on KDE … no problems at all. Thank you very much for great updates. :smiley::+1:t2:


split this topic #37

5 posts were split to a new topic: Out-of-memory with lightdm-1:1.28.0-1.1 and webkit greeter


#38

I check the forum several times daily. If I find there is an update in stable or testing I go to login and TTL, then do the trusty [pacman-mirrors -f0] and [pacman -Syyu] unless I get the warning about something needs down graded, then [pacman -Syyuu]. I don’t mind the extra steps and I trust this manner of upgrading. Incidentally I seldom get a notification of an update from pamac unless it is from Aur for my one and only Google-Chrome from Arch.


#40

All good so far. XFCE linux419.


#43

All works fine here at three Pc´s. :smiley:

Thanks to the Manjaro-Team.
caho


#45

Update went fine.
Hope that kernel 4.14 will remain for some time, since kernel 4.19 and 4.20 still boots on and off.

Arch skipped from 4.14 lts to 4.19 lts without warning.