[Stable Update] 2019-01-17 - Kernels, KDE Apps, KDE Plasma, Deepin, Firefox, Calamares, XFCE

update
stable

#1

Hi community,

Welcome to our second stable update of 2019 worth of one week of work and another one on testing it. So what do we have with this one?

  • Firefox is now at its tenth beta release of v65 series
  • regular Firefox is now at 64.0.2
  • KDE Plasma is now at 5.14.5
  • KDE Apps is now at 18.12.1
  • VirtualBox got several fixes
  • we updated some of our XFCE packages
  • we updated most of our Deepin packages
  • certbot got updated to 0.30.0
  • our vulkan-stack got mostly updated
  • all the regular haskell and python updates

We hope with all these changes Manjaro to be more efficient for you all.


FOSDEM19

Some of our core developers will join PINE64 Inc. at FOSDEM19 in Brussels. We will establish an even more closer relationship with this ARM based company. Also we are looking forward to see your reactions on the big announcement PINE64 Inc. will do at FOSDEM19. Stay tuned for any upcoming news.

Partnership with FCS Linux Aarhus

We are happy to announce a new partnership with FCS Linux Aarhus owned by @fhdk. This enables us to offer you Laptops with Manjaro pre-installed and Manjaro Stickers you can use on your own hardware or gift them to a friend. For each sale FCS will donate a percentage to the Manjaro project.

Manjaro v18.0.2 released!

To end the year with a high note we updated our flagship ISOs of Manjaro Illyria with the latest packages. It comes with refreshed packages and updated tools. You may want to download our XFCE Edition with the latest 4.13 packages, aswell as our most recent styling efforts. Our KDE fans may try our KDE Edition with the latest KDE v5.14 instead. And our GNOME fans may try our Gnome Edition with the latest GNOME v3.30.


Current supported Kernels

  • linux316 3.16.62
  • linux318 3.18.131 [EOL]
  • linux44 4.4.167
  • linux49 4.9.149
  • linux414 4.14.92
  • linux417 4.17.19 [EOL]
  • linux418 4.18.20 [EOL]
  • linux419 4.19.14
  • linux420 4.20.1
  • linux414-rt 4.14.87_rt49
  • linux416-rt 4.16.18_rt11
  • linux418-rt 4.18.16_rt9

Package Updates (Sat Jan 12 10:12:43 CET 2019)

  • stable community x86_64: 817 new and 805 removed package(s)
  • stable core x86_64: 17 new and 18 removed package(s)
  • stable extra x86_64: 635 new and 686 removed package(s)
  • stable multilib x86_64: 10 new and 10 removed package(s)

A detailed list of all changes made can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


FOSDEM 2019 Brussels - Belgium
#2

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Notifications looking weird in XFCE

Since the package dunst includes now dunstfy in the main package notifications may not displayed properly in XFCE. Please uninstall that package to solve that issue. Normally not needed in that edition.


Potential issues with dunstify-1.3.2-1 package

Upstream decided to include dunstify now in the dunst package. However, they didn’t add any replace, conflicts tags to that package, as Arch never packaged dunstify before. Therefore we try to remove dunstify automatically via manjaro-system package. On rare cases however, a manual user invention might be needed to remove the package. If that is the case, please issue the following command manually on your system: sudo pacman -Rdd dunstify && sudo pacman -Syu

Items from previous update sets

“warning: systemd: local (239.3xx-1) is newer than core (239.6-2)” What do I do?

As said in this announcement, systemd packages has been downgraded to an older version. Hence, as long as the version installed on your system will be on a higher version, you’ll receive a warning.

If you already have systemd 239.303 on your system and you have no problem with it, you can just ignore the warning and continue to use systemd 239.303. There’s no need to do any action.

If you are still interested to downgrade systemd to 239.6, you can do the downgrade with pamac upgrade --enable-downgrade or sudo pacman -Syyuu.


Warning: PACKAGE: directory permissions differ on FILENAME

A file or directory on your system has a set of permissions which is different to those in the new package. You can either ignore it (because you changed it yourself) or you can change them so they match.

For example, for this message:

Warning: blueman: directory permissions differ on /usr/share/polkit-1/rules.d/filesystem: 750  package: 755

you can change the local file to match the package with:

sudo chmod 755 /usr/share/polkit-1/rules.d/filesystem

How do I do updates via TTY-terminal?

  • Press CTRL+ALT+F2 (or F3, F4, F5, F6) to go into a pure command line interface.
  • Log in with your credentials.
  • Once logged in, you’ll have access to a CLI shell, like if you were using a terminal. Use pamac upgrade or sudo pacman -Syyu (or other equivalent command) to update your system.

To go back to your regular desktop, press CTRL+ALT+F7. On some systems, it can be CTRL+ALT+F1 instead.


i3 changed its default config path

It seems that (from version >= 4.16) i3 is looking for its configuration in ~/.config/i3/config instead of ~/.i3/config.
Copy your config to the new path and all should work as before. (reported from an i3-gaps user).


I can’t open Nemo with elevated privileges (as root)

Workaround found: Use the dbus-x11 package instead of the regular dbus package. This package is available in the official repositories and provides dbus compiled without the --without-x option.

To replace dbus with dbus-x11 package, simply install dbus-x11 with your favorite package manager: dbus will be replaced by dbus-x11.


AMD-Ucode introduction

Unless you’ve already done this previously, All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.


Rebuilding fontconfig cache: failed to write cache

Please ignore this message. Upstream already works on a solution. More about the issue here.


LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn’t work for you, you may use gtk instead of gtk3_kde5 as UI framework.


Installing glibc (2.28-4) breaks the dependency “glibc=2.27” required by lib32-glibc

Install the update either:

  • from terminal: sudo pacman -Syu or;
  • with Octopi instead of Pamac.

Something using Perl/Python/glibc broke

Rebuilds needed!

  • If it’s an AUR package, try to reinstall it from AUR. It most likely needs to be rebuilt.
  • If it’s a repo package, please report and check back regularly for updates.

I’ve lost a Thunderbird addon/feature

Thunderbird 60 disables incompatible addons by default. There’s an about:config switch should you want to force-enable the addon, but many addons simply will not work with the newer Quantum-based Thunderbird.

Read more about Thunderbird 60 here: Thunderbird 60


Firefox - WebGL not working anymore

You may try the following solution:

Open about:config and set security.sandbox.content.read_path_whitelist to /sys/.


#3

I don’t see any updates


#4

It has just been released. It can take a while (depends on the mirror) before your mirror get the new packages and distribute them.


#5

ah ok thanks bro


#6

All ok, KDE kernel 4.19, use pacman-mirrors before updating


#7

I have a curious question about updating. I don’t use Pamac to update, I prefer to use the terminal and use the command sudo pacman -Syyu
I was just wondering if this is the best or safest way to update or if there are any other options to update? Thanks for any help!


#8

@kdemeoz, Scheduler flip also at stable branch:

$ cat /sys/block/sda/queue/scheduler
[mq-deadline] kyber bfq none

$ uname -a
Linux computer 4.20.1-1-MANJARO #1 SMP PREEMPT Wed Jan 9 17:43:49 UTC 2019 x86_64 GNU/Linux

#9

All good here, thanks for hard work.

OS: Manjaro 18.0.2 Illyria
Kernel: x86_64 Linux 4.20.1-1-MANJARO
Uptime: 5m
Packages: 1113
Shell: bash 4.4.23
Resolution: 1920x1080
DE: Xfce4
WM: Xfwm4
WM Theme: Agua
GTK Theme: Clearlooks [GTK2]
Icon Theme: gnome
Font: Noto Sans 11
CPU: Intel Core i5-4460 @ 4x 3.4GHz [44.0°C]
GPU: GeForce GT 720
RAM: 731MiB / 7908MiB


#10

Albeit different front-ends, both are equivalent and will do the same job for updating your system.

By the way, Pamac can also be used in CLI. pamac -h for a list of possible actions, and pamac <COMMAND> -h for a more detailed description and a list of options for that specific command. It has a completely different syntax than pacman, it’s similar to what you have on APT or DNF.


#13

Perfect!
I got updates for Cinnamon Desktop, Calibre, Chromium, Evolution, NVIDIA Drivers, Cairo Dock and Rhythmbox too.
No problems. I love it!


#14

I’ve solved it ahhahahha thanks to Wiki


#15

I really appreciate your work in Manjaro and I know you have a lot of work to do. But let me ask you:Please, pull Musescore 3.0.1 that’s already on Arch Community repo to Manjaro stable.
https://www.archlinux.org/packages/community/x86_64/musescore/
Musescore is a wonderful software but versoin 3.0.0 released last month came out-of-box with many bugs that are now corrected in 3.0.1.
Thank you.


#16

Weird, the only thing I see is that Musescore is at 3.0-1 on Arch Community and that it has been flagged as out of date.

(3.0.1 and 3.0-1 isn’t the same thing, if it was a misreading.)


#17
sudo pacman-mirrors --fasttrack && sudo pacman -Syyu

This makes you to install updates faster


#18

Borg Backup is incompatible with the update of python-msgpack from 0.5.6-2 to 0.6.0-1.
See Bug here (not only mount does fail for me, but also regular backup): https://bugs.archlinux.org/task/61346
Or here: https://github.com/borgbackup/borg/issues/4220#issuecomment-448302127

Downgraded python-msgpack from 0.6.0-1 => 0.5.6-2 and all is well again.

Already had the same problem on my second install with “Testing”, but somehow was convinced that borg is from AUR and not much time to investigate, sorry about that.


#19

The most stable Arch distro props to you guys


#20

i guess safest way is in tty 2 or 3


#21

Is there anyway I can find out which is my mirror? And is it possible to switch to an specific mirror?


#22

Like others I never got the update and I use the command ‘pacman -Syu’ which AFAIK updates mirrors as well.

pacman-mirrors -f solved it. Could someone please explain why the up-to-date mirror list keeps changing?