[Stable Update] 2019-01-05 - Pacman, Pamac, Deepin, Haskell, Python

update
stable

#41

Everything appeared to went well.

██████████████████  ████████   linux_missingno@lm-GE70-MANJARO 
██████████████████  ████████   ------------------------------- 
██████████████████  ████████   OS: Manjaro Linux x86_64 
██████████████████  ████████   Host: GE70 2OCOE REV:1.0 
████████            ████████   Kernel: 4.20.0-1-MANJARO 
████████  ████████  ████████   Uptime: 1 min 
████████  ████████  ████████   Packages: 1097 (pacman) 
████████  ████████  ████████   Shell: bash 4.4.23 
████████  ████████  ████████   Resolution: 1920x1080 
████████  ████████  ████████   DE: KDE 
████████  ████████  ████████   WM: KWin 
████████  ████████  ████████   WM Theme: Adapta 
████████  ████████  ████████   Theme: Adapta [KDE], Adwaita [GTK2], Breath [G 
████████  ████████  ████████   Icons: breeze-dark [KDE], Adwaita [GTK2], maia 
                               Terminal: konsole 
                               Terminal Font: Noto Mono 10 
                               CPU: Intel i7-4700MQ (8) @ 3.400GHz 
                               GPU: NVIDIA GeForce GTX 765M 
                               GPU: Intel 4th Gen Core Processor 
                               Memory: 1249MiB / 11927MiB 

                                                       

Although, it was on a freshly installed machine.


#42

try screenfetch -n
Get rid of logo and takes less room. :wink:


#43

@philm On a BIOS system it broke GRUB with:
Error symbol 'grub_key_is_interrupt' not found

I fixed it with this tutorial.


#44

After the update, I have a problem with the popup notification window of XFCE, such as when I increase or decrease the volume with the keyboard.

I attach an example:

Captura%20de%20pantalla%20de%202019-01-06%2020-33-21


#46

oh, didn’t know that. I will try to do that next time.

E: I am using Neofetch since it gets information faster, shows more information, and do more thing than Screenfetch. But everyone is allowed to use their own program if they like it more.


#47

I have the exact same issue as @zimudec, I already tried to reset the xfce4-notifyd config file but that did not help.

EDIT: Killing dunst and restarting the xfce4-notifier works.


#48

What would be the final solution? uninstall dunst?
or do we have to wait for a new update to work properly?
what is dunst for?


#49

Removed it with pacman -Rdd dunst and only update-notifier needs it on my system and it still works right now


[Testing Update] 2019-01-03 - Pacman, Pamac, Deepin, Haskell, Python
#50

I get this,

error: failed to commit transaction (conflicting files)
python-pbr: /usr/bin/pbr exists in filesystem

fixed it with

sudo pip uninstall pbr

#51

I think update-notifier is really useful for any minimal edition without Pamac.
I use it on KDE because it’s lightweight and less “intrusive” (no icon, no process in background, just timer/conky/cron).


#52

The latest manjaro torrent file does not work to download manjaro iso.
Using qbittorrent (Have downloaded other non-manjaro torrents)

manjaro-xfce-18.0.2-stable-x86_64.iso.torrent

checked signatures on downloaded iso:

$ sha1sum manjaro-xfce-18.0.2-stable-x86_64.iso
1dee45baab6768fcdf07a0b370b0e3fd4d3594e6  manjaro-xfce-18.0.2-stable-x86_64.iso
$ gpg --verify manjaro-xfce-18.0.2-stable-x86_64.iso.siggpg: assuming signed data in 'manjaro-xfce-18.0.2-stable-x86_64.iso'
gpg: Signature made Thu 03 Jan 2019 10:24:21 AM PST
gpg:                using RSA key E4CDFE50A2DA85D58C8A8C70CAA6A59611C7F07E
gpg:                issuer "philm@manjaro.org"
gpg: Can't check signature: No public key

#53

sudo pacman -S manjaro-keyring archlinux-keyring


#54

Thanks for your great effort.
Guys it hard to believe that but Nvidia-Bumblebee wake-up problem is solved (well-known problem for hybrid graphic cards for switching to nvidia gpu after suspend or hibernation)!!! I couldn t believe my eyes after open my notebook after 2 days of suspend Nvidia card was still work without any intervention, awesome :slight_smile:


#55

Update all good except after boot I now get eth0 connected as my network connection which will work for some sites but not others. Network Manager also shows ‘Wired Connection 1’ when I connect to this all is good and I can access everything again. This makes the ‘eth0’ connection dissapear from Network manager, ‘Wired connection 1’ is set to automatically connect when avaliable. How do I fix this so I don’t have to manually do this every boot? thanks

Operating System: Manjaro Linux
KDE Plasma Version: 5.14.4
Qt Version: 5.12.0
KDE Frameworks Version: 5.53.0
Kernel Version: 4.19.13-1-MANJARO
OS Type: 64-bit
Processors: 4 × Intel® Core™ i3-4130 CPU @ 3.40GHz
Memory: 7.7 GiB of RAM


#56

Unplug your ethernet wire and use WIFI.


#57

Sorry I don’t understand what you mean here.
1)This is a desktop machine and I don’t have wifi device/card setup on it
2)why use wifi rather than a cable?

I just want a way to make the ‘Wired connection 1’ connect automatically.


#58

Sorry, not all machines are built with the same hardware, mine has both. When you shut down do you check the box for save sessions for future logins? That might do it.


#59

After installing the update my pacman cache(which is just a symlink to a folder in another partition) up and vanished, pacman couldn’t then find the location of the updated pacman package and I was left without a pacman installation at all.

It seems just recreating the symlink(all files were still there) and then manually uncompressing /usr from pacman’s install folder was enough to let me proceed with the update, but then pacman’s information on the package database is left inconsistent and this will probably cause me problems in the future.

It’s something I’m still looking into and is probably my fault for being lazy and just symlinking the cache away, we’ll see what comes of it.


#60

Using KDE I have the ‘Startup and shutdown’-‘Desktop Sessions’-‘restore previous session’ checked.
also Network Manager has the option ‘Automatically connect to this network’ checked. I don’t know what you mean by “check the box for save sessions for future logins” where is that?
It used to work fine.


#61

Save%20Session%20etc