[Stable Update] 2018-12-31 - Kernels, KDE Apps, KDE Frameworks, VirtualBox, LibreOffice, Deepin, ZFS

update
stable
#1

Hi community,

Welcome to the last stable update for 2018.
2019-mjr

So what do we have with this one?

  • lot of changes went into Virtualbox v6.0
  • Firefox is on its 7th beta of v65 series
  • some updates to Cinnamon, Deepin and our Kernels
  • small adjustments to MSM
  • latest Wine
  • We updated QT5 to 5.12 LTS
  • Latest linux-firmware.
  • KDE Frameworks are at 5.53.0
  • KDE Apps are at 18.12.0
  • Mesa got updated to 18.3.1
  • LibreOffice got updated to 6.1.4
  • ZFS is now at 0.7.12
  • all the regular haskell, php and python updates

We hope with all these changes Manjaro to be more efficient for you all.


Partnership with FCS Linux Aarhus

We are happy to announce a new partnership with FCS Linux Aarhus owned by @linux-aarhus. This enables us to offer you Laptops with Manjaro pre-installed and Manjaro Stickers you can use on your own hardware or gift them to a friend. For each sale FCS will donate a percentage to the Manjaro project.

https://linux-aarhus.dk/en/vare/manjaro-bladebook/
https://linux-aarhus.dk/en/vare/sticker-alu-powered-by/


Manjaro v18.0.2 released!

To end the year with a high note we updated our flagship ISOs of Manjaro Illyria with the latest packages. It comes with refreshed packages and updated tools. You may want to download our XFCE Edition with the latest 4.13 packages, aswell as our most recent styling efforts. Our KDE fans may try our KDE Edition with the latest KDE v5.14 instead. And our GNOME fans may try our Gnome Edition with the latest GNOME v3.30.


Current supported Kernels

  • linux316 3.16.62
  • linux318 3.18.131 [EOL]
  • linux44 4.4.167
  • linux49 4.9.148
  • linux414 4.14.91
  • linux417 4.17.19 [EOL]
  • linux418 4.18.20 [EOL]
  • linux419 4.19.13
  • linux420 4.20.0
  • linux414-rt 4.14.87_rt49
  • linux416-rt 4.16.18_rt11
  • linux418-rt 4.18.16_rt9

Package Updates (Mon Dec 31 10:18:33 CET 2018)

  • stable community x86_64: 1774 new and 1678 removed package(s)
  • stable core x86_64: 34 new and 34 removed package(s)
  • stable extra x86_64: 816 new and 917 removed package(s)
  • stable multilib x86_64: 30 new and 31 removed package(s)

A detailed list of all package updates can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

29 Likes
#2

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

“warning: systemd: local (239.3xx-1) is newer than core (239.6-2)” What do I do?

As said in this announcement, systemd packages has been downgraded to an older version. Hence, as long as the version installed on your system will be on a higher version, you’ll receive a warning.

If you already have systemd 239.303 on your system and you have no problem with it, you can just ignore the warning and continue to use systemd 239.303. There’s no need to do any action.

If you are still interested to downgrade systemd to 239.6, you can do the downgrade with pamac upgrade --enable-downgrade or sudo pacman -Syyuu.


Warning: PACKAGE: directory permissions differ on FILENAME

A file or directory on your system has a set of permissions which is different to those in the new package. You can either ignore it (because you changed it yourself) or you can change them so they match.

For example, for this message:

Warning: blueman: directory permissions differ on /usr/share/polkit-1/rules.d/filesystem: 750  package: 755

you can change the local file to match the package with:

sudo chmod 755 /usr/share/polkit-1/rules.d/filesystem

Items from previous update sets

How do I do updates via TTY-terminal?

  • Press CTRL+ALT+F2 (or F3, F4, F5, F6) to go into a pure command line interface.
  • Log in with your credentials.
  • Once logged in, you’ll have access to a CLI shell, like if you were using a terminal. Use pamac upgrade or sudo pacman -Syyu (or other equivalent command) to update your system.

To go back to your regular desktop, press CTRL+ALT+F7. On some systems, it can be CTRL+ALT+F1 instead.


i3 changed its default config path

It seems that (from version >= 4.16) i3 is looking for its configuration in ~/.config/i3/config instead of ~/.i3/config.
Copy your config to the new path and all should work as before. (reported from an i3-gaps user).


I can’t open Nemo with elevated privileges (as root)

Workaround found: Use the dbus-x11 package instead of the regular dbus package. This package is available in the official repositories and provides dbus compiled without the --without-x option.

To replace dbus with dbus-x11 package, simply install dbus-x11 with your favorite package manager: dbus will be replaced by dbus-x11.


Pamac: “Failed to commit transaction - Transaction not prepared” at the end

So far, it has only been a false alarm: updates are applied successfully.


AMD-Ucode introduction

Unless you’ve already done this previously, All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.


Rebuilding fontconfig cache: failed to write cache

Please ignore this message. Upstream already works on a solution. More about the issue here.


LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn’t work for you, you may use gtk instead of gtk3_kde5 as UI framework.


Installing glibc (2.28-4) breaks the dependency “glibc=2.27” required by lib32-glibc

Install the update either:

  • from terminal: sudo pacman -Syu or;
  • with Octopi instead of Pamac.

Something using Perl/Python/glibc broke

Rebuilds needed!

  • If it’s an AUR package, try to reinstall it from AUR. It most likely needs to be rebuilt.
  • If it’s a repo package, please report and check back regularly for updates.

I’ve lost a Thunderbird addon/feature

Thunderbird 60 disables incompatible addons by default. There’s an about:config switch should you want to force-enable the addon, but many addons simply will not work with the newer Quantum-based Thunderbird.

Read more about Thunderbird 60 here: Thunderbird 60


Firefox - WebGL not working anymore

You may try the following solution:

Open about:config and set security.sandbox.content.read_path_whitelist to /sys/.


libutf8proc>=2.1.1-3 update may require manual intervention

This should normally be automatically fixed via manjaro-system update.

The libutf8proc package prior to version 2.1.1-3 had an incorrect soname link. This has been fixed in 2.1.1-3, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libutf8proc: /usr/lib/libutf8proc.so.2 exists in filesystem

when updating, use


pacman -Suy --overwrite usr/lib/libutf8proc.so.2

to perform the upgrade.


Pamac: “Invalid or corrupted package.”

If you receive an “Invalid or corrupted package.” error message with Pamac and if the details contains an output similar to the following:

Details
Synchronizing package databases...
Starting full system upgrade...

Preparing...
Resolving dependencies...
Checking inter-conflicts...
Downloading...
Downloading manjaro-system-20180716-1-any.pkg.tar.xz...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Upgrading manjaro-system (20180702-1 -> 20180716-1)...
==> Fix libutf8proc upgrade ...
resolving dependencies...
looking for conflicting packages...

Packages (1) libutf8proc-2.1.1-4

Total Download Size:   0.05 MiB
Total Installed Size:  0.32 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading libutf8proc-2.1.1-4-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
upgrading libutf8proc...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
Running post-transaction hooks...
Arming ConditionNeedsUpdate...
Warning: lock file missing /var/lib/pacman/db.lck
Starting full system upgrade...
Resolving dependencies...
Checking inter-conflicts...
Error: could not open file /var/lib/pacman/local/libutf8proc-2.1.1-2/files: No such file or directory
Warning: could not fully load metadata for package libutf8proc-2.1.1-2

Failed to prepare transaction:
invalid or corrupted package

Try the following steps: close Pamac window first, then launch it again and start the update procedure again. It should continue from where it left off.


Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you’re able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.

icon-kde-513

Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if ‘default.pa’ has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.

#3

With this update cinelerra-cv has been dropped to the AUR without replacement at the moment

#4

I already posted about this in the community support section but after latest update on Deepin the dock doesnt show up. I get the desktop and can use alt-f2 to get the terminal but thats it

#5

@oberon is currently working on Deepin and might push some more packages in that regard.

#6

Everything fine, thanks !

#7

Smooth as silk…as always. My biggest worry was Virtualbox 6.0 but all my images started flawlessly.

KDE Plasma Version: 5.14.4
Qt Version: 5.12.0
KDE Frameworks Version: 5.53.0
Kernel Version: 4.20.0-1-MANJARO

Happy New Year to everyone and a big thanks to all contributors for all the hard work you put in this year!

3 Likes
#8

pacman -Syyu, yes? Pardon my newbness with this package manager.

All went great. Fully functional system.

One teeny problem I can’t figure out: Applications 18.12 is supposed to be able to use the color emoticons in Noto Color Emoji. None do. I’ve never understood font fallbacks for missing glyphs, so I am very lost as to how to diagnose this, never mind fix it. Gonna fire up another thread for help.

KDE Plasma: 5.14.4
Frameworks: 5.53.0
Apps: 18.12.0
Qt: 5.12.0
Kernel : 4.20.0-1-MANJARO

May the new year bring much joy and reward!

(Edit: Ooop, didn’t mean to reply direct to you, @Pkadd - but Hi! anyway. :sweat_smile:)

#9

Just to quickly post KDE error before rebooting, incase I can’t boot back in and need to reinstall … Unable to create io-slave. klauncher said: Error loading ‘/usr/lib/qt/plugins/kf5/kio/file.so’. Can’t access home, etc.

EDIT: rebooted and everything is working fine. Sorry, newb error/1st updates. Thanks for such a great update, and best wishes for 2019.

#10

Since this update I’ve got two issues.

1 - There is the following error when updating:

The AppStream system cache was updated, but some errors were detected, which might lead to missing metadata. Refer to the verbose log for more information.

2 - Every time I reboot the system there is a coredump.

What to do?

Thanks

3 Likes
split this topic #11

A post was split to a new topic: No object for D-Bus interface

#12

Same here.

#13

look what that coredump is related to and report / fix it :joy:

#14

1.3 GB of updates and everything worked fine :slight_smile:

I also wish a happy new year to everyone, may all your wishes and hopes become true in 2019!

#15

Looking at the logs it reports this:

Process 1018 (kwin_x11) of user 1000 dumped core.

Stack trace of thread 1018:
#0 0x00007fbeac412d7f n/a (n/a)

#16

MKVToolnix-GUI stopped working after update (both Cinnamon and LXDE):

Reinstall of application didn’t help.

#17

Like @strawman, I saw this during the upgrade:

(27/31) Updating the appstream cache…
The AppStream system cache was updated, but some errors were detected, which might lead to missing metadata. Refer to the verbose log for more information.
error: command failed to execute correctly

Should I worry about that? Is there a fix for that? Thank you.

1 Like
#18

Everything fine but got this warning:

[2018-12-31 13:59] [ALPM] warning: directory permissions differ on /usr/share/polkit-1/rules.d/
filesystem: 750  package: 755

what to do?

#19

Successfully updated via terminal !
Gnome - Kernel 4.19

1 Like
#20

May I ask which kernel do you use? We thought we fixed the issue with QT5 and older kernels lower than 4.11, but there might be still some edge cases out there. Also which systemd is used on your machine? Also you can try to install dbus-x11 and see if that helps.