[Stable Update] 2018-12-31 - Kernels, KDE Apps, KDE Frameworks, VirtualBox, LibreOffice, Deepin, ZFS

update
stable

#147

For displaying the Manjaro logo in the Whisker Menu button:

Right-click on Whisker Menu > Properties > Click on the icon (under “Icon:”) > in “Select Icon From” select “Image Files” > on the left sidebar select Other Locations > Computer > usr > share > icons > manjaro > maia (or any of the other two variants) > select the icon “maia.svg” > OK.

Welcome to the Forum! :slightly_smiling_face:


#148

No issues, KDE. Thanks once again Manjaro Devs and Happy New Year to all!


#149

I had the same message, and I am ignoring it too. I found this:

AppStream is a cross-distribution specification to provide metadata about software components.
This tool allows for reading, writing, validating and transformation of AppStream XML or YAML metadata.
It also gives access to the system metadata pool, for example to query for software that provides a
specific MIME-type, and installing it by its software component identifier.

As there is so many people ignoring it, I am ignoring too, and found no problem in my Manjaro Testing XFCE.

PS: I use this command “appstreamcli status --verbose” and at the end it shows some text saying “was not found”, but don’t know if it is related.


#150

XFCE, 4.19.13-1

Everything went smoothly! Thanks for all the hard work, and happy New Years!


#151

Philm the coredumps returned though I changed to dbus-x11

03/01/19 13:27 systemd-coredump Process 1019 (kwin_x11) of user 1000 dumped core.

Stack trace of thread 1019:
#0 0x00007efec5be0d7f n/a (n/a)


#152

Gnome, 4.19.13-1

Everything went smoothly! Thanks to the Manjaro team for all for the work done, and happy New Years!


#153

Hi, my menu button vanished. I did the update through terminal (sudo pacman-mirrors -f0 && sudo pacman -Syyu). When the button vanished, I found the “menu libre” and saw this error: Parsing error & it said that “/usr/lib/jvm/java-10-openjdk/bin/policytool” has not been found in the PATH. And more detail is below. How can i get the menu back? Thank you.

[Desktop Entry]
Name=OpenJDK Java 10 Policy Tool
Name[fi]=OpenJDK Java 10 - käytäntötyökalu
Name[fr]=OpenJDK Java 10 - Outil de réglage
Comment=OpenJDK Java 10 Policy Tool
Comment[fi]=OpenJDK Java 10 - käytäntötyökalu
Comment[fr]=OpenJDK Java 10 - Outil de réglage
Keywords=java;security;policytool
Exec=/usr/lib/jvm/java-10-openjdk/bin/policytool
Terminal=false
Type=Application
Icon=java10-openjdk
Categories=Settings;

#154

did you try to reinstall jdk10-openjdk? Else you may remove /usr/share/applications/policytool-java10-openjdk.desktop


#155

Hi,
after upgrade when I run Virtual Box I see this information:
–startvm is an option for the VirtualBox VM runner (VirtualBoxVM) application, not the VirtualBox Manager.
What to do with this?
Dario


#156

Not a bug but a change in Virtualbox. See here for details https://www.virtualbox.org/ticket/18207
Here’s what my launch string looks like now:
/usr/lib/virtualbox/VirtualBoxVM --startvm "Windows10 Production"


#157

Hi TomZ,
Many thanks, it helped!
:slight_smile:


#158

I have a similar Problem as Citroen mentioned 3 Days ago, but i think have done something terrible stupid. My /var/lib/pacman/local/linux-firmware… folder also only had the file mtree inside. It was an even older linux-firmware version. I tried to uninstall the package, but that didn’t work because the process always reclaimed something (sorry, didn’t made a screenshot). I thought it was only left over from a previous installation and deleted that folder. That was terrible wrong, because when i now want to update to this last update, the packages can be downloaded but then the process won’t install the files, because he finds firmware files and stops the installation…

…and so on.

I tried to find out which package is responsible for the files to manually get them out of the way, but when i ask pacman there is no package linked to them:

[furby@Travelmate ~]$ pacman -Qo /usr/lib/firmware/3com/3C359.bin
Fehler: Kein Paket besitzt /usr/lib/firmware/3com/3C359.bin

Now i am not able to complete the update. Can anyone help in this situation?

Thanks


#159

hello i tried both and it didn’t work :confused: I searched for “whisker menu” in the pc because there should be an option for it but i haven’t found. it’s not a very big deal just a little annoying. i guess i’ll wait for an update :slight_smile: i have xfce and kernel 4.14.91-1-MANJARO x86_64. the package updated is this xfce4-whiskermenu-plugin 2.3.0-1 updated on 4th jan.


#160

Open TTL with Ctrl Alt F2 at Login menu and run:
sudo pacman -S xfce4-whiskermenu-plugin
Then reboot.


#161

They still look like this no matter the theme or icons. I am on the latest stable updates. Does the system applet have any config that I can just clear? I had tried a few applets recently from AUR. But I am not sure that caused this.


#162

Well there is definitely some sort of reset going on with the Budgie taskbar. After doing my upgrade and rebooting, I lost many of the applets. I don’t have the issue you have with the white background. Here is what I suggest trying. Open terminal (not as root) and type in the following, which should reset your taskbar and many of your settings in Budgie Settings Manager back to default.

nohup budgie-panel --reset --replace&

Edit to add; this reset worked for me. The only issue I have is with adding the Weathershow applet. It crashes the taskbar and won’t let me add it. I will contact the Ubuntu Budgie dev and let him know.


#163

Thanks, I will note that down for future reference but even that didn’t work. Taskbar did reset and I had to set it up again as I wanted but no change with icons.


#164

That is odd. I showed the Ubuntu Budgie dev your picture and he was perplexed. It didn’t happen on both PCs of mine. I wonder if it is something else causing it. I noticed a couple of your icons are KDE/QT based programs (not sure what the other two are.) I think, qbittorent and Keepass are QT programs if I am not mistaken. Perhaps it has something to do with QT5 settings or QT5TC. I would explore that path also.

I will also invite the Manjaro Budgie maintainer to this thread.


#165

I changed icon theme to Adwaita in Qt configuration tool and now they look like this -
Screenshot%20-%202019-01-08-02-52

This is much better though, thanks for looking into it.
If I choose from any Papirus variant, it’s back to white background. Can you try changing on your end and see if you have any issue with Papirus?


#166

I have no issues with Papirus or the many, many other icon themes I have installed. :wink:
I running the stable build btw. My last trick to try would be to reinstall ‘gtk-update-icon-cache’ and see if that helps.