[Stable Update] 2018-12-31 - Kernels, KDE Apps, KDE Frameworks, VirtualBox, LibreOffice, Deepin, ZFS

update
stable

#83

Happy new year and I did check out your thread. Pretty cool :slight_smile:


#84

The update succeed but I got this warning;

Warning: blueman: directory permissions differ on /usr/share/polkit-1/rules.d/filesystem: 750  package: 755

Should I worry?


#85

Thank you all and happy new year :slight_smile:

I updated from tty and my whisker menu gone. I cannot take it back, had to add a new one without old settings.
virtualbox has small issues. first, theme seems ridiculous :slight_smile:
then, I cannot use shortcut for guest to start it. It says

–startvm is an option for the VirtualBox VM runner (VirtualBoxVM) application, not the VirtualBox Manager.

and starts virtualbox instead of image. Adding new shortcut to the desktop won’t help.

Edit: I found the solution for the shortcut problem here: https://www.virtualbox.org/ticket/18207
I changed the line in the link from /usr/lib/virtualbox/VirtualBox to /usr/lib/virtualbox/VirtualBoxVM


#86

Thanks, I have the same system and had the same glitch. It was solved by following what you did and it worked!


#87

No. You can either change the directory permissions so they match,

sudo chmod 755 /usr/share/polkit-1/rules.d/filesystem

or ignore the difference.


#88

I’ve just pushed a new budgie-desktop package to our unstable branch. Maybe it helps:

pamac install http://repo.manjaro.org.uk/pool/overlay/budgie-desktop-10.4+211+g6f7f894d-1-x86_64.pkg.tar.xz
pamac install http://repo.manjaro.org.uk/pool/overlay/budgie-extras-0.7.0-0.1-any.pkg.tar.xz


#89

8 posts were split to a new topic: Not able to boot into graphical session after 2018-12-31 update


#91

I get the following issue after upgrading musescore to 3.0-1 when I try to start it :

musescore: /usr/lib/libQt5Core.so.5: version `Qt_5.12' not found (required by musescore)

This seems to be due to the fact, qt5-base is only on version 5.11.2-3. I tried installing version 5.12 from the AUR, but all I could find were the packages qt5-base-headless, qt5-base-nostatx and qt5-base-git. If I try to install any of those, it breaks the dependencies of other packages on qt5-base.
I even temporarily tried to install qt5-base 5.12 manually as an arch-package, but musescore wouldn’t start either, I’d guess it was due to it being compiled with a slightly different qt5 version still.


#92

I assume you’re not on an updated mirror server. The latest qt5-base is this one in our stable branch:

pamac install http://repo.manjaro.org.uk/stable/extra/x86_64/qt5-base-5.12.0-1.1-x86_64.pkg.tar.xz


#93

I upgraded those packages as you mentioned but still no luck!


#94

Please try to use the matcha-gtk-theme, as this is the current maintained theme we support on Manjaro for all our GTK based editions. Most community editions already switched to it.

pamac install http://repo.manjaro.org.uk/pool/overlay/matcha-gtk-theme-20181228-1-any.pkg.tar.xz


#97

Yup, I am using Matcha-Sea widgets theme and Papirus-Maia icons.


#99

Then please open an issue for the theme with screenshots and what needs to be changed. Does this issue happen on all colour variants? If so, mention that too. The history of our package can be found here. You can mention that we try to use always the latest upstream code of the theme.


#100

just updated deepin no problemo


#101

I am not sure this has anything to do with matcha… Even on Adwaita I have the same problem… Maybe this is related to latest changes in gnome or budgie?


#102

A little strange. After updating, the new VirtualBox failed to start, complaining about the wrong version of qt5 libraries. Seeing a post about the same error for something else, I tried manually installing qt5-base, but this broke the rest of KDE.
A bit of digging and I found that although the instructions for an earlier release about upgrading from a terminal say use either “pamac upgrade” or “pacman -Syyu”, for some reason (I’ll have to dig to work out why) “pamac upgrade” only installed a small subset of packages. “pacman -Syyu” added another 271 packages, which fixed everything.


#103

I tried to update my wife’s Acer laptop but it failed.
This is what pacman -Syu is giving me:

kan de metadata voor het pakket linux-firmware-20181214.8aa9e3e-1 niet volledig laden
fout:fout bij het voorbereiden van transactie (ongeldig of corrupt pakket)

(Can’t load metadata for linux-firmware-20181214.8aa9e3e-1)


#104

You may want to update to a synced mirror:

sudo pacman-mirrors -f3
sudo pacman -Syyu


#105

That did not work, Phil, same error.

:: Volledige systeemsupgrade starten…
waarschuwing:lib32-systemd: lokaal (239.303-1) is nieuwer dan multilib (239.6-2)
waarschuwing:libsystemd: lokaal (239.303-1) is nieuwer dan core (239.6-2)
fout:kan bestand /var/lib/pacman/local/linux-firmware-20181214.8aa9e3e-1/desc: Bestand of map bestaat niet niet openen
waarschuwing:systemd: lokaal (239.303-1) is nieuwer dan core (239.6-2)
waarschuwing:systemd-sysvcompat: lokaal (239.303-1) is nieuwer dan core (239.6-2)
afhankelijkheden oplossen…
zoeken naar conflicterende pakketten…
waarschuwing:kan de metadata voor het pakket linux-firmware-20181214.8aa9e3e-1 niet volledig laden
fout:fout bij het voorbereiden van transactie (ongeldig of corrupt pakket)


#106

That is not the current linux-firmware package anymore. Please update to a synced mirror like repo.manjaro.org.uk.

sudo pacman-mirrors -f3
sudo pacman -Syy
sudo pacman -Syyuu

The latest firmware package you can also install manually:

sudo pacman -U http://repo.manjaro.org.uk/pool/sync/linux-firmware-20181218.0f22c85-1-any.pkg.tar.xz