[Stable Update] 2018-12-31 - Kernels, KDE Apps, KDE Frameworks, VirtualBox, LibreOffice, Deepin, ZFS

update
stable

#61

Thanks and all the best for all contributors to manjaro! :slight_smile:
All good here, although i also got the appstream-error. Is there any action to be taken? I can’t see any negative effect on first glance?


#62

Manjaro-KDE. Everything fine but…

The AppStream system cache was updated, but some errors were detected, which might lead to missing metadata. Refer to the verbose log for more information.
error: command failed to execute correctly

#63

Smooth update :slight_smile:

Finally Xfce notification icons are fixed. Thanks.

notification


#64

Butting in, but for convenience it’s After December 31 Update Deepin Dock not showing


#65

Thank you
Can someone tell me how to update everything but archlinux-appstream-data please?
Happy New Year
Thanks


#66

#68

This user recommends downgrading fmt to previous version. The newer version seems to break mkvtoolnix-cli package which also breaks the mkvtoolnix-gui package.


#69
==> Unable to install module digimend-kernel-drivers/8.r37.gea507e2 for kernel 4.14.91-1-MANJARO: Missing kernel headers.
==> Unable to install module digimend-kernel-drivers/8.r37.gea507e2 for kernel 4.19.13-1-MANJARO: Missing kernel headers.

Should I be worried about this? It seems like the digimend-drivers haven’t correctly installed. Is this a problem I’d be able to fix, or this is software-sided, outside my control?

Additionally:

The AppStream system cache was updated, but some errors were detected, which might lead to missing metadata. Refer to the verbose log for more information.
error: command failed to execute correctly

What does this mean? Would this also be a problem?


#70

Updated using Yakuake! No issues.


#71

Everything was updated well.
Great job.
Happy New Year


#72

As far as I know, this is a extra module that isn’t included by default on Manjaro, did you install it by yourself?

The “Missing kernel headers” message speaks for itself: it is most likely that you don’t have kernel headers installed on your system, which are required to compile modules with DKMS. Do you have linuxNNN-headers installed on your system? (NNN stands for your kernel version, for example 419 for Linux 4.19 or 414 for Linux 4.14).


#73

Yes, it’s an extra module, compiled from github actually. It allows for Drawing Tablet compatibility.

I thought I might be missing kernel headers as well, but when I tried to pacman -S them, I got a ‘reinstalling’ notice, which means they are definitely installed. Both linux414 and linux419 had their headers. Perhaps it’s just a bug, im not sure


#74

Hm. that’s strange! I’m investigating - trying to find out what the problem can be there …


#75

No issues noticed. XFCE kernel 4.19 :+1:


#76

Happy New Year!
Manjaro Mate Stable Version User here.
[ha@ha-ha ~]$ inxi -S
System: Host: ha-ha Kernel: 4.19.13-1-MANJARO x86_64 bits: 64 Desktop: MATE 1.20.4 Distro: Manjaro Linux
[ha@ha-ha ~]$
Selecting a file with a .rar extension now tries to open with Atril Document Viewer and gives “Unable to open document, File type RAR archive ( application/vnd.rar ) is not supported.”
The work around is right click RAR Files and open with Engrampa Archive Manager.


#78

Right Click > Properties > File Type Options > Application Preference Order: Move Engrampa Archive Manager to the top.


#79

This is how notification icons look like on Manjaro Budgie after the upgrade -

Screenshot%20-%202019-01-01-11-50


#80

Are you sure it is not your theme? I have updated both my PC and laptop running Budgie and no icon issue here.


#81

Yup. Tried default theme and icons as well as a few themes. Even multiple reboots. This isn’t a temporary glitch.


#82

For consolation

budgie-picon-sgs

Happy New Year :slight_smile:


Sorry, was just on your website.
I am only an amateur :slight_smile: