[Stable Update] 2018-12-04 - Systemd


#21

I always have a rescue DVD as my first boot option (and I pick boot from HD there if I do not want to “rescue”)
With this update I got a lot of IO error on sr0 (which is not that surprising since it is a DVD) the update almost stopped there with eternal error messages.

I (barely) managed to eject my DVD (it ejected after a long time so I could remove the DVD) and the update finished normally.


#22

Don’t you think that Kernel 4.19.7 is urgent enough to be pushed into stable updates?


#23

but it needs some testing


#24

Not sure if it is related with this update or previous ones but I am experiencing a lot of issue with Thunar and Nemo (I know I know it is not a fully supported FM in XFCE but it was working fine before). Strange temporary hang up, degrade performance. Nemo is now unusable in XFCE. Not sure if it is related to the new systemd updates.


#25

Maybe reinstall them. If that doesn’t work, then make a thread.


#26

Ok I did. Thanks

OK Update : found the problem. Nothing to do with Manjaro updates. Fixed.


#27

After the update virtualbox did not work.
Turns out the dkms modules did not update correctly.
Reinstalling them fixed this.

sudo pacman -S virtualbox-host-dkms
sudo systemctl restart systemd-modules-load
``

#28

Don’t forget to mention the fixes. Remember Stack Overflow?


#30

I’m not having issues with the newer packages but xfce did crash when updating cinnamon i think as that’s what was corrupted when i rebooted to restart updates so had to rip out and reinstall although vlc is still bugged in manjaro.


#31

I thought that I don’t have any problems with the newer version of Systemd but after encountering a lot of known crashes and lags. I decided to go with the older version, and my system is back to normal again. I use Manjaro KDE BTW @philm


#32

virtualbox, which was running fine right up until the update, refused to run after update.

Looked on the forums and tried all the solutions I could find… The erro message if I run virtualbox from terminal is

rich[~]$ virtualbox
VirtualBox: Error -610 in supR3HardenedMainInitRuntime!
VirtualBox: dlopen("/usr/lib/virtualbox/VBoxRT.so",) failed: <NULL>

VirtualBox: Tip! It may help to reinstall VirtualBox.

My inxi is here: Dump your inxi -Fxzc0 here and bookmark it

I removed all Virtualbox programs using pacman -Rn, rebooted, and tried reinstalling, first vbox and the host additions for 4.19 and reboot. same error. remove host additions and replace with dkms, reboot, same error. Oh, and I renamed `~/.config.VirtualBox in order to start fresh there.

Kind of a bummer, as I was trying to work in it today.

Otherwise upgrade was smooth.


#33

lol, my bad. wonky non-repo install changed owner of /usr I was working on that at the same time as the update.


#34

Since the upgrade auto screen lock / screen saver doesn’t work any more. I currently have to lock the screen and switch off the monitor manually. I do have KDE as desktop. I kept 239.303 as it’s currently a minor issue for me

Everything else works smoothly.


#35

Everything works fine with this new version (so I want to keep it). However, how can I get rid of this warning? Its popping up every time I want to update or install some package. It drives me nuts.


#36

Please be more specific. Quote the warning, or take a screenshot. Then include the warning in your post, or, reply.


#37

Similar errors here:
Warning: lib32-systemd: local (239.303-1) is newer than multilib (239.6-2)
Warning: libsystemd: local (239.303-1) is newer than core (239.6-2)
Warning: systemd: local (239.303-1) is newer than core (239.6-2)
Warning: systemd-sysvcompat: local (239.303-1) is newer than core (239.6-2)
Error: could not open file /var/lib/pacman/local/ecryptfs-utils-111-3/desc: No such file

Is there a step-by-step solution?


#38

Read “Known Issues” in this Topic:

“warning: systemd: local (239.303-1) is newer than core (239.6-2)” What do I do?


#39

#40

I have the same issue. Another issue which seems to be related is that an AUR package, visual-studio-code-insiders, which I use for development work, is not the latest, but is newer than AUR:

[jray@jr-dl ~]$ yay
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Searching databases for updates...
:: Searching AUR for updates...
 -> lib32-systemd: local (239.303-1) is newer than multilib (239.6-2)
 -> libsystemd: local (239.303-1) is newer than core (239.6-2)
 -> systemd: local (239.303-1) is newer than core (239.6-2)
 -> systemd-sysvcompat: local (239.303-1) is newer than core (239.6-2)
 -> visual-studio-code-insiders: local (1545373195-1) is newer than AUR (1544768411-3)
 -> Missing AUR Packages:  ocenaudio  qt-assistant-compat
 -> Out Of Date AUR Packages:  turtl  visual-studio-code-bin
:: Starting full system upgrade...
warning: lib32-systemd: local (239.303-1) is newer than multilib (239.6-2)
warning: libsystemd: local (239.303-1) is newer than core (239.6-2)
warning: systemd: local (239.303-1) is newer than core (239.6-2)
warning: systemd-sysvcompat: local (239.303-1) is newer than core (239.6-2)
 there is nothing to do

Version: 1.31.0-insider
Commit: e02e44464c02d617b98d0a3265bf5efef7794436
Date: 2018-12-21T06:15:51.434Z
Electron: 3.0.10
Chrome: 66.0.3359.181
Node.js: 10.2.0
V8: 6.6.346.32
OS: Linux x64 4.19.13-1-MANJARO

I did install this package via yay, so I’m not sure how to update it to the latest version.


closed #41

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.


[Stable Update] 2019-02-19 - Kernels, KDE, LibreOffice, Systemd, VirtualBox, Deepin, Qt, Firmwares, Wine