[Stable Update] 2018-12-02 - Kernels, Plasma, Mesa, Cinnamon, Gnome, Deepin, XFCE, Vulkan



Just did the stable upgrade using “pacman -Syu” in TTY in an X session with Cinnamon Edition. Rebooted ok. No issues found yet.
One thing though that bothers me after the upgrade of the kernel is that the IO scheduler got changed from “cfq” to “mq-deadline”. The cfq scheduler option is removed. As I have only classic spinning HDD drives I would like to return to “cfq” but it is not available anymore.


but it will be like how windows updates work just when to download update and upgrade is in the hands of user


Simply do all upgrades in TTY and be done with it…


If you’re that paranoid, start with nosmt=force or better with l1tf=full boot parameter, both should disable SMT.

EDIT: Lots of spectre/speculation related patches incoming to 4.19.7.


And thats OK for you. But by default we should choose a save way to update. Manjaros update right now is a guessing game and at some point you will lose. Thats simply not a OS I want to use/support. Would this happen to ubuntu the trolling would be great.

Nothing is wrong with that. As long as it works without a big risk like “stop your Xsession or you will maybe lose your OS” many users will not care if its like Windows or Mac or whatever. GNOME chooses this path not because they are bad or want to make you suffer, but because it’s more save to update this way.


You probably have a recent kernel with multi-queue activated, there’s no cfq scheduler for multi-queue.


For what it’s worth, I updated my laptop in normal terminal emulator from within xfce-gtk3 (not tty) as I didn’t read the announcements for 2nd Dec updates. I only updated my laptop last night to grab the end November updates, and the 2 Dec forum notice hadn’t dropped yet. So instead of just getting the latest Nov updates, I got the 2 Dec updates as well.

No problem with the update itself, no crashes. Just have the “usual” reversion of theming in Thunar-gtk3 and panel in my laptop, post-update.

Haven’t updated PC yet as I didn’t expect it, but I will do it via tty.


I have the 4.19.6 kernel now after the update. Before I had the v4.19.4 with cfq. Before the upgrade I did not activate the multi-queue.


It’s activated by default since 4.19.5
Available schedulers are mq-deadline, bfq, kyber, and none.
You can change them either with elevator=name-of-scheduler boot parameter (for all drives) or with a udev rule (for specific drives).

Or you can go back to single queue (not recommended!) with scsi_mod.use_blk_mq=0 boot parameter.


ok thanks I will stick with mq-deadline and see how it goes …


Again time to think about backups :slight_smile:


Ready :slight_smile:

Timeshift - 01

Deepin Clone app does not open

I am in two minds here. On one hand, I posted this on 5 October 2018 (and I’m sure I have posted similar stuff over the years here):

I really believe that newcomers to Manjaro need to understand the nature of the distro they are moving to. You want rolling and access to a huge number of packages (via native repos or AUR)? There are things you need to do in return. Because even if you could update safely all the time via graphical updater or within graphical environment, what about regular package maintenance?

On the other hand, I also made a feature request in Sep 2017:

So I have thought about how newcomers can be helped to help themselves, from within pamac.

Integrating backup utility in pamac

Issues with Manjaro Deepin Edition. After update, it boots into an empty GUI. Attempts to open deepin-menu or deepin-control-center from a terminal-window throw up the following message:

error while loading shared libraries: libdtkcore.so.2: cannot open shared object file: No such file or directory

dtkcore-1: is installed and up to date.

I am not sure where to go from here. Has anybody else this issue?


Any other drastic changes between kernel 4.19.4 und 4.19.6 that come to mind?

My problem with broken suspend on 4.19.6 is not related to the scheduler but something else definitely has changed causing the issue here with my laptop not able to suspend anymore, which was working just fine up to 4.19.4.


The suspend issue is definitely related to recent kernel updates. I simply downgraded to kernel 4.14. The is no need to be on the most recent kernel (unless your hardware is brand new).


xps9550,KDE,linux44, update OK


No further big changes between .4 and .6, except the addition of the patch for Raven Ridge.
See Manjaro’s gitlab page for history.


How would I install cinnamon again with --overwrite? Would this work:

pamac install cinnamon pacman --overwrite



had to restart computer as it froze about halfway through updates xfce and deepin both but ok after reboot finished install


I successfully updated my XFCE with yay. no problems detected.