[Stable Update] 2018-11-02 - Pamac, ICU, XFCE, Deepin, Gnome

update
stable

#102

Regarding rd.udev.log-priority=3 This is just my experience, so like so much in life YMMV.


#103

Everything went fine on my Thinkpad T470 with KDE and 4.19


#104

Hi there.

I still have the same two details present since beta and rc. They were (are) on two testing computers with 4.19 and now my main computer after upgrade to 18 (kernel 4.14):

  • Can’t set an external monitor (VGA or HDMI) to the left side. It always “steals” the Whisker menu and desktop icons, even when you set it as Secondary screen. I’m pretty sure it worked fine on 17.x

  • The battery and wireless icons, for example, I must now right click on them in order to see their status as the tooltip is printed below the screen edge.

The rest seems to be fine :slightly_smiling_face:


#105

Maybe we are in the same boat, @M0nst3r. Manjaro 18 with Xfce 4.12 and Kernel 4.19 on my side.

I had posted on a new Xfce problem with this update somewhere above in this thread:

You posted this (what’s your desktop?):

I don’t see any mouse-over tooltip info from the notification icons mentioned above. Maybe they are below the screen edge on my system, too.

So, please, dear @philm and dear developers, take at look at that. Thanks a lot in advance!

And, as I did ask above: I still have Xfce 4.12 on a Manjaro 18 system that came along from 17. Is it recommendable to switch to the “developmental” Xfce 4.13? If so, what is an up-to-date recipe to install Xfce 4.13?

Time and again, thanks for all the hard and great work!


#106

This update broke my system, but I think it might NOT be the update’s fault after all…

I ran pacman -Syu under gnome-terminal, and it suggests that core is up to date (apparently it was not :joy: ) The update concluded with error:

/usr/bin/update-mime-database: error while loading shared libraries: libicuuc.so.63: cannot open shared object file: No such file or directory

This looked suspicious to me, and indeed I could not reboot into GNOME. But I was able to login to a fully functional tty, and after some googling I found that libicuuc is provided by the icu
package, which should get updated (but apparently did not :joy: ). I then manually downloaded the latest package and used pacman -U to install it. After that I ran pacman -Syu again, and a few more packages popped up; then I completed the updates and rebooted, and everything works perfectly! :yum:

The thing is, how can I avoid this problem in the future? :thinking: I strongly suspects that it is caused by my repo mirror - is it possible that extra / community / multilib is synced already, but core is not (yet)? Thanks!


#107

All went smoothly from TTY. Kernel 4.19, XFCE 4.12.

(Tooltips are working properly for me on my panel. @111MilesToGo Maybe creating a new panel at a different position of your desktop worth a try for you?)

I did the silent boot configuration with this update, went smoothly as described. One little thing is that on my Asus motherboard I had to make sure to turn the “fast boot” back to “normal boot” in my “BIOS”.

Thanks!


#108

See here
https://forum.manjaro.org/t/stable-update-2018-10-28-systemd-nvidia-pamac-bootsplash-deepin-firefox/63403/34?u=linuxkumpel


#109

better pacman -Syyu


#110

Hi.

All my computers run on XFCE. Can tell about the tooltips because I actually see the white thing showing off behind the toolbar.


#111

@M0nst3r: Okay, I got the Xfce (4.12 here) panel “issue” regarding mouse-over displays from notification area icons sorted out. The Xfce panel seems to be programmed a bit strange: When the panel height is greater than or equal to 30 pixels, the notification mouse-overs are displayed below the icons, even causing them to “disappear”. At panel heights less than or equal to 29 pixels, the mouse-overs show up above the icons. You might need to try for yourself whether this “30” depends on monitor pixel number. I had been playing with the panel height just before doing this update, but their disappearing was just coincidental.

@philm, no need to worry. Sorry for flooding you with “@'s”.

@doomee, thanks for your hinting at trying a new panel in another position. This showed me what was going on.


#112

Nice catch :sunglasses:

And yes, I normally set the toolbar height manually. It never was an issue, at least, not in 17.x.

The external monitor problem is still pending. :+1:


#113

No visible issues on KDE, kernel 4.19.


#114

On KDE, plasmashell use 80% of one CPU (of 4)
I follow my own advice:
To check, this time I rename just one file: ~/.config/plasma-org.kde.plasma.desktop-appletsrc

  • log out - log on
  • reconfigure my desktop

It’s working, but plasmashell stays between %40 and %50


Well, crossing fingers for the new stable update to fix things :wink:


#115

gimp-gtk3 seems to have a new unlisted dependency: appstream-glib.


#116

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.