[Stable Update] 2018-11-02 - Pamac, ICU, XFCE, Deepin, Gnome

update
stable

#82

Yes thx is ok on my laptop don’t have pamac-dev !
Is on my pc :smiley:


#83

hi philm

I am an Asustek computer M3N78 of the year 2007, I do not have artificial intelligence … the 512kb of my cache does not reach me at the end of the month, I must tell you that the update of my xfce has been as smooth as always, you treat me with as much affection as my owner, who brushes me often … I’m older and there’s hardly any dust left, although I’m annoyed that I caught him looking at a certain Bladebook - Fall 2018, I suspect he intends to deceive me, I try to convince him that he’s too young for him (and maybe a little thing, will be the jealousy?), also does not know anything of bios uefis and I’m not going to retire until the end of the kernel 4.4

Sincerely, a bios award updated to 2010 … thanks and biterian hugs, that you have a good day

PD: I’m the user … I’m sorry philm, I can not control it since I’ve set it up.


#84

For the most part, this update on Manjaro-18.0 with Xfce 4.12 and kernel 4.19 went well.

However, I do have some issues with Xfce 4.12 now. The notification area in the Xfce bar (“Benachrichtigungsfläche” in “Leiste”) does NOT show any tooltip-type information any more, i.e. when hovering the mouse over the icons of network manager applet, pacman, battery indicator (energy) and maybe others. It’s really annoying to not see these computer data like “connected to network xy”, “you have x updates”, battery percentage.

What can be done to recover that information display in Xfce 4.12? Thanks for your help. The other tooltip infos like desktop switcher, volume control, calendar, shutdown button have survived.

Furthermore, from what I understand, it is still debated whether one should switch to Xfce 4.13 gtk3 or stick to 4.12, since 4.13 is sort of a development version ultimately leading up to 4.14. Any recommendations? (Yes, I searched and did find e.g. the thread here on the forum which even had a voting.)

If it is recommendable by now to switch to Xfce 4.13, is there a good and updated recipe on how to do this? Thanks, too.

Edit wrt the 4.12 notification issue: I should add that simultaneously with this update I installed dbus-x11 instead of dbus, since I wanted Thunar Root to have the same functionality as some time ago (remember my preferences, thanks to @banjo for this). Going back to dbus does not return the notification displays, though.


#85

Well, I can’t tell for sure what went wrong for you. But, please allow me to point out that it is generally accepted best practice to NOT refer to disk partitions by their device names /dev/sdaN, but by UUIDs. For example, my /etc/udev/rules.d/99-hide-partitions.rule is:

# Hide Windows 8.1 Pro physical machine partitions on Samsung SSD 850 EVO 2 TB from Linux
# System-reserved partition
SUBSYSTEM=="block", ENV{ID_FS_UUID}=="AA2E818E2E81546B", ENV{UDISKS_IGNORE}="1"
# Windows 8.1 Pro PM C: partition
SUBSYSTEM=="block", ENV{ID_FS_UUID}=="A014B01E14AFF606", ENV{UDISKS_IGNORE}="1"

Hope that helps.


#86

You’re right and yes that helped.

I knew /dev/sdaN is not a good practice to refer partitions,
and I though it will only cause problem if partition name will change due to some partition structure modification.

But no, referring the partition using UUID instead of name, solved the issue. :+1:
Thank you very much… :slightly_smiling_face:


#87

FS_UUID is nice. PART_UUID not so much… when your crapdos decides to change them after upgrade :wink:


#88

@LA-MJ, thanks for pointing that out. My udev rule is fine, my wording in the post wasn‘t precise enough.

BTW: Will never upgrade to Win 10 before the last day of Win 8.1 … But then either Linux does all I want (e.g. AccurateRip CDs), or I‘ll have a Mac, or there are no more CDs to rip … :smile:


#89

I guess with this method you get less system crash. Rolling also claim user friendly ditros should care this solutions; but with last system snapshot to prevent black screen :slight_smile:


#90

My issue is with grub:
using kernel 4.14 and openbox

After the update, my grub was changed, both fonts and background image.
I used grub_customizer to get back my fonts and background image, but after rebooting to see that changes via grub_customizer affected, I still see some new grub, which is different then my own.

I didn’t use the .pacnew.
What do I need to do to get my config back?
Thanks


#91

Never. Ever. Ever. Use. This. Thing.


#92

Can you tell me how to get back my original configuration?


#93

Timeshift backup.


#94

what?


#95

but I don’t have a backup to restore from.
I have a new grub-look.

I can see my old configuration in /boot/grub/grub.cfg but that is not what I see in the actual boot.
How do I get my configuration back?


#96

Read post #1


#97

Well of course, everything is designed to update painless. But bugs do happen. If you are updating inside GUI and the whole GUI crashes for whatever reason, your system will probably not be completely updated.

Depends of when/where crash occurred, which system file was at that time being overwritten… at next boot GUI may not load and you would need to switch to TTY or even chroot from live system to update completely your system. It can happen.

So, if you are updating your system outside GUI, you don’t have to worry on those very rare occasions if GUI would crash during system update.

I think sudo pacman -Syyuw then switching to TTY then sudo pacman -Su is just safer for beginners.

Bonus :wink:
Ever happened to you, that you started with large system update, during update something went wrong, and system update got canceled? When you restart system update, you have to go through large download again. There is still problem with that dependency? Well start downloading all system update files yet again…

Not with sudo pacman -Syyuw , all needed files are already on your computer before you ever start updating your system. This is especially beneficiary for those with slower internet speed :wink:


#98

I did read post #1, and as far as I understand, it’s not about my configuration:
I don’t have kernel/s 4.18 or 4.19
I don’t want to activate the hidden menus.
I did sudo grub-editenv - unset menu_auto_hide anyway, but that didn’t change anything.

Help?


#99

@Monro, as far as I understand you, you would like to do the same things I was asking for somewhere up in this thread. Anyway, what I wanted to do is return to the previous grub boot procedure and output as from Manjaro 17, i.e. make Manjaro 18 look like 17 in that respect only. I did arrive at that for my purposes.

What I did:

  1. The only thing that has to be modified in the current Manjaro /etc/grub.d/ script files is 10_linux. I edited the line quiet_boot="1"to be quiet_boot="0", i.e. change this hard-wired behavior. I did not yet figure out yet whether I could make that automatically depend on the grub environment variable menu_auto_hide.
  2. Then modify the /etc/default/grub file to your needs, e.g. regarding a background image. Maybe one would like more personalization in this file.
  3. The one thing I am really not sure about is whether /etc/default/grub should have rd.udev.log-priority=3 in the GRUB_CMDLINE_LINUX_DEFAULT. This addition was mentioned in a couple of explanatory notes to a number of prior Stable Update threads.
  4. Thereafter, I did what the explanatory note at the top of this thread said, unset menu_auto_hide, regenerate the initcpio’s, and update-grub.

That’s it AFAIK. Hope that helps you a bit - no warranty implied …

Please, dear Manjaro developers, forgive me for striving to revert a part of your recent development work. I do like it a lot in a Manjaro virtual machine, but - as mentioned in my post above - it makes Manjaro look too different from my Tumbleweed boot process in a multi-boot environment.


#100

Obviously put your fonts and background back again and do a sudo update-grub. I guess you initially did the same to achieve your goal. I don’t quite understand your problem however, my English is not good enough.


#101

Thank you @111MilesToGo.
your “tutorial” solved my issue.
I found in /etc/default/grub file that the theme line was un-commented, and that caused the problem

I skipped your #3 point, and now I have my previous (Manjaro 17-like) grub back.

Thank you for taking the time and helping me.