[Stable Update] 2018-11-02 - Pamac, ICU, XFCE, Deepin, Gnome

update
stable

#41

Lutris is Seg Faulting for me on this update when i attempt to install a game

AUR searches in the package manager also take ages


#42

Can you explain? I am just curious.


#43

For example:

  1. [Testing Update] 2018-10-31 - Freetype, ICU, XFCE, Deepin, Gnome
  2. How do i troubleshoot kernel lockups
  3. My own unhappy experience since 26/10/18 has been 5 total system freezes [even REISUB couldn’t help], & which possible smoking gun i tracked down after the most recent one yesterday [the timestamp is exactly when The Freeze occurred]:
[kdemeoz@GA-Z97-HD3-Tower ~]$ sudo journalctl _BOOT_ID=ee0b48702a6a4c53bfd3f57bf2db7bd7 | grep kernel
Nov 02 21:00:49 GA-Z97-HD3-Tower kernel: kernel BUG at block/bfq-sq-iosched.c:1849!
[kdemeoz@GA-Z97-HD3-Tower ~]$

Hence i was v happy to be able to apply the latest Stable Update today, after which:

 [kdemeoz@GA-Z97-HD3-Tower ~]$ sudo tlp-stat -d|grep Sch
[sudo] password for kdemeoz: 
  Scheduler = cfq
  Scheduler = cfq
  
  
[kdemeoz@GA-Z97-HD3-Tower ~]$ cat /sys/block/sd*/queue/scheduler
noop deadline [cfq] bfq-sq 
noop deadline [cfq] bfq-sq

Fingers crossed CFQ will be the magic elixir.


#44

i had before some issues in shutdown causing my laptop to block but now it’s fixed (kernel 4.19)
a smooth update generally
thank you team manjaro


#45

Update went fine on 2 laptops, both Xfce, 4.18.


#46

It’s the maintainer of wine-stable which forgot to update the .SRCINFO file, it misses the validpgpkeys values.


#47

All its fine today, i startet with the lts kernel 414, update via pamac in terminal pamac checkupdates and pamac update, that works very well. Now i am back on the 4.19.4 Kernel. I hope the Biosupdate yesterday fixed all my problems with freezing, we will see. Thank you for your dayli work on manjaro, for help all the time, if someone need it.


#48
error: failed to prepare transaction (could not satisfy dependencies)
:: installing icu (63.1-2) breaks dependency 'icu<63.0' required by manjaro-settings-manager


#49

Hi,
I get the same message, then did that

  • update only the pacman-mirror package, cancelling others
  • update mirrors
  • refresh databases
  • update system
    It fixed that.
    good luck

#50

Keep the ‘resume=UUID=…’ parameter.


#51
sudo pacman -Syyu

This resolve my problem.


#52

There are reports in different places that to some extent it is difficult/not possible to compile firefox with the openSuse patches. While I see the problems/difficulties concerning compile time, amount of memory required to successfully apply the patch set, completely removing/discontinuing the firefox-kde-opensuse isn’t a solution IMO.
I hope we will see this package again in the official repos, because honestly I can’t stand that GTK-file-chooser/save dialog.


#53

You possibly didn’t do a full update. Firefox was/is compiled against the new icu 63.1-2 which provides libicui18n.so.63


#54

No, firefox-kde-opensuse 63.0-3 is only available in the unstable branch, it did not migrate with the other firefox packages.

This is OK though, I just compiled 63.0.1-1 myself for the netrunner repository:


#55

:+1: thx changed /etc/default/grub works


#56

Hold it

If I double boot - should I be concerned about this update?

KDE/ Win 10


#57

Crashed my Whisker also but only on my virtualbox GTK3 copy, on GTK2 everything ok.

Pressing execute also allowed me to carry on


#58

Läuft bei mir / All good w. Gnome DE :slight_smile:
Thanks!


#59

While following the 2. How to enable hidden GRUB menu?-Guide I encountered a stumbling block:

Running this will get me sed: couldn't open temporary file /etc/sedjw2tmO: Permission denied. Is there a typo in the command? Should I just add a sudo before the sed command or is this a symptom of a larger problem.

Any help and explanation would be appreciated as I don’t fully understand the purpose of the first part of the joined command. Thank you in advance!

And by the way: Thank you for maintaining this great distro! It’s the one that got me into GNU/Linux and I have you to thank for that. :slight_smile:


#60

This is needed in order to remove fsck from initramfs HOOKS. You can use any text editor you like, too. And yes, sudo is necessary because /etc/mkinitcpio.conf is a system (root) file.