[Stable Update] 2018-10-28 - Systemd, Nvidia, Pamac, Bootsplash, Deepin, Firefox

Hi, for a strange reason, the Manjaro Deepin version does not show output on one monitor when using two external monitors. On the login, both works ok, but after it, just one monitor is working

Can you not set them up in Monitor Settings? Is the external monitor present in settings?

Everything fine on xfce just updated from a 18.0rc install. After the original install I did have some weird graphic flicker that occurred at login. Happened on the 4.16 kernel that was default on the rc and (though slightly different) on the 4.19 LTS kernel that’s now out. No other issues, everything else worked fine so I ignored it. Tonight I went back to the 4.14 kernel and no flicker, so it’s just this older hardware.

Thank you! Your suggestion of modprobe worked like charm!

1 Like

I’ve (re)installed 18.0 from scratch, as I wanted to do a cleanup of my system.

18.0 looks and feels really nice — great job Manjaro team!!

The only minor inconvenience I found is that in Settings Manager, as I open any of the categories, my mouse scroll stops working. This only happens there, scroll works everywhere else.
(If it matters, my mouse is Logitech MX518)

The other thing I noticed is that the Application Finder’s search seem too fuzzy! (It was not like this before)
For example:

  • if I type code, the first result is About Me, then after that is Code (VS Code, what I’m looking for), and after that is Compton, and Mouse and Touchpad
  • typing viv brings a lot of result, with Vivaldi in the last place, adding one more letter (viva), shortens the list, but the first item is Avahi Zeroconf Browser

Is there a way to tune down this fuzzyness and/or to make results not alphabetical but sorted by the best match?

so you do not have these anymore after update 2018-10-28: loglevel=3 rd.systemd.show_status=auto rd.udev.log-priority=3, and it’s still working?

1 Like

I would try it if you wanted to clean up /etc/default/grub. Just remember to run sudo update-grub afterwards then reboot. The worst that would happen is that you would need to add loglevel=3 rd.systemd.show_status=auto rd.udev.log-priority=3 back again, then sudo update-grub and reboot, but the latest from @philm shows that only quiet is needed now. Good luck!

1 Like

yes, will try when back home.

so you don’t have them in grub anymore?

1 Like

So, how to report kernel hang? Or what is the way to resolve the issue?

For starters, create your own thread and try to give as much detail about your system and setup as possible.

Also doing some testing and research of your own might answer questions by itself.

3 Likes

So far so good! :wink: Thank you Team Manjaro.

2 posts were split to a new topic: ROS melodic package - python issues

Hi!!!
Good installation of Manjaro Gnome on my laptop, although I had to install haveged to fix the boot time
Thanks for Manjaro

CPU:
  Topology: Dual Core model: Intel Core i3 M 350 bits: 64 type: MT MCP 
  L2 cache: 3072 KiB 
  Speed: 1463 MHz min/max: 933/2266 MHz Core speeds (MHz): 1: 1463 2: 1463 
  3: 1463 4: 1463 
Graphics:
  Device-1: Intel Core Processor Integrated Graphics driver: i915 v: kernel 
  Device-2: AMD Park [Mobility Radeon HD 5430/5450/5470] driver: radeon 


The issue may still exist. My quick fix however seems to be working. Thx to @korealinux who was testing it like a soldier even she new that it may delete data. Also the issue exists since 2016 for all ISOs we had released. Which is therefore no new regression and also no showstopper not to release it.

2 Likes
  1. Will this smooth-boot, fully flickerfree ever be available for LTS kernels?
    I have default:
    4.14.78-1-MANJARO #1 SMP PREEMPT Sun Oct 21 07:57:51 UTC 2018 x86_64 GNU/Linux

  2. If I install 4.19 will it change to 4.20 automatically when it is released or I will have to do it with command?

Kernels are updated (4.19.1 to 4.19.2) like other packages, but not upgraded (4.19 to 4.20). You will need to install it yourself – you have mhwd for doing so, including the graphical way.

1 Like

Kernel 4.19 willl be assigned LTS status at some point or maybe it is already done?

4.19 will automatically replace black screen of the qiet grub option (if you have it enabled) for vendor logo. However, there are more things to do for flicker free experience. There are some intel parameters and others to set to avoid loading certain screens at boot. I believe there is a link to those additional things on the guide above.

And like @maycne.sonahoz said, kernel is updated but never automatically upgraded to newer number. That is something you must do yourself from manjaro settings menu. Besides, you can have multiple kernels installed. It’s a good practice to have at least one LTS kernel and some newer one (if you want it). For example, I had 4.14 and used 4.18. Now when 4.19 is made official I installed it so I have 3 kernels but the newest is used. At some point I will uninstall 4.18 (it will be EOL) and will have 4.14 and 4.19. When 4.20 or 5.x will come, I will switch to it, uninstall older LTS 4.14 and will have only 4.19 LTS and whatever the newest kernel is. Or maybe I will uninstall 4.14 sooner? Probably ;). Anyway, we have choice and easy tool to manage kernels so that’s great.

This is however only my choice. You can sit on LTS kernel and don’t switch. It depends on hardware you have. Oftentimes newer kernel don’t offer any visible improvement but sometimes it introduce important features as better power management (which TLP can use), better memory handling, etc.

I got this when I use Linux 4.14:

[drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=1863239 end=1863240) time 1879 us, min 763, max 767, scanline start 732, end 37

I’m using Qtile + Compton now.

Try install ttf-dejavu font
sudo pacman -S ttf-dejavu

1 Like

Yeah, I get that too on various kernels. Not sure if that is doing something bad thou.

Forum kindly sponsored by Bytemark