[Stable Update] 2018-10-28 - Systemd, Nvidia, Pamac, Bootsplash, Deepin, Firefox



Fortunately non-free works for Live USB. Hopefully the free one is able to catch up and support RTX soon. Will reslot and follow the wiki tomorrow and edit back here with the results. Should get the GPU to work even on KDE 17.1 since the nvidia driver would be 410.66 and support for 2080 Ti was added in the version prior. Thanks so much for getting me past the first hurdle!

Edit: Said wiki link didn’t work because card has to be plugged in to detect and install drivers and you can’t get to the GUI w/o the drivers, so somewhat of a chicken and egg situation. Tried installing nvidia-beta but the build failed and upon reboot I couldn’t boot into the partition. Ended up just doing a reinstall via Live USB and fortunately it seems smart enough to use non-free for the install and now everything is running nicely thus far.


Will manjaro architect 17 install xfce 4.13? I don’t see any architect installer 18.0.


same issue here :confused:


is there any official list of laptops those are running manjaro with out problems ?
also list for those laptops where people getting issues installing manjaro ( not all distro are same).
i faced problems to install manjaro in hp laptop.but ubuntu installs fine.


Thanks for your great efforts. All is well on my Asus Zenbook and old Acer Inspire laptop with kernel 414.
I tried to switch to kernel 419 on Asus Zenbook Ux410UQ but I had some issues.
Some systemd services stopped and I had to restart manually
Some termal sensors won’t recognized (wifi, motherboard…)
A little more temperature then kernel 414.
Because of those reasons I switch to kernel 414 again.
BTW what is the icon set for new release.


New installation of Manjaro Gnome 18 without problems.

Machine: Type: Desktop Mobo: ASRock model: FM2A78M Pro4+ serial:
BIOS: American Megatrends v: P1.20 date: 12/23/2013
CPU: Topology: Quad Core model: AMD A10-7700K APU with Radeon R7 Graphics bits: 64

Thanks Manjaro Team!!


Fresh install 18.0 and 17 update to 18, theme are different?
I am update from 17, and Xfce still on 4.12
How do I switch to new Adapta-Maia theme?


See this:

I can’t confirm it tho, as i don’t use Deepin.


good update, except for this new error in systemlog:

systemd-udevd Specified group ‘plugdev’ unknown


Zero problems on KDE with 4.19 and Nvidia 4.10 , system is smooth as silk . Great job on 18 !


Great success in the battle towards Manjaro 18! Congrats and thanks.

Still holding back on this 2018-10-28 Update. Last one taken was 10-25 for Xfce with transition to 4.19. AFAIK successful, no flaws encountered yet.

Nevertheless, I would like to see a recipe here that gives back the prior bootscreen with ”… kernel version …“. Reason: I have Tumbleweed and Manjaro multi-boot from UEFI, with Tumbleweed being the first OS. Initial grub menu and bootloader grubx64.efi are Tumbleweed‘s, and from that grub menu I fork to Manjaro‘s grub menu. Manjaro now boots without bootscreen, i.e. it doesn‘t show the ”Linux 4.19…“ message unlike the Manjaro 17 default setup. The next messages, however, still do show up on screen, i.e. I see the systemd 239 and fsck messages as in the Manjaro 17 default setup.

Since I would like all messages from Manrajo’s boot process back as before, in order to make it similar to Tumbleweed again: What would I have to modify in the new Manjaro? Thanks in advance for a recipe.

(Currently not at my computer.)


Same question. XFCE still 4.12 after update.


AwEsOmE SaUcE Still loving Manjaro!


I hope i am seriously misunderstanding something, but knowingly releasing an operating system installer that can randomly nuke some of your partitions sounds like an april fool’s release.

Last time manjaro was widely in the news was when it was suggested to access the website by turning system clock back. I have a feeling this release announcement will make us an order of magnitude more famous, and not in a good way.


@Cye3s @nrw

You can install the new Xfce themes and Xfce Gtk3 with the following (optional):

sudo pacman -S --needed xfce4-gtk3 manjaro-xfce-gtk3-settings manjaro-wallpapers-18.0 matcha-gtk-theme

(it will prompt you to replace quite a few packages; type “y” for each)
Once you’ve installed those, make the following changes:
-Style: Adapta-Eta-Maia (dark: Adapta-Nokto-Eta-Maia)
-Icons: Papirus-Maia (dark: Papirus-Dark-Maia)

-Image: illyria-default.jpg (in /usr/share/backgrounds)

LightDM GTK+ Greeter settings:
-Theme: (same as above)
-Icons: (same as above)
-Image: illyria-default-lockscreen.jpg (in /usr/share/backgrounds)

NOTE: If you are using xscreensaver, you’ll have to reset the lock command with:

xfconf-query -c xfce4-session -p /general/LockCommand -s ""

Log out and log back in for all changes to take effect

He’s not joking when he says it is “really rare”. The code that seems to cause this was added to the stock Calamares installer clear back in 2016, and would potentially effect every distro currently using Calamares. Considering all the times Calamares has probably been used to install a distro over the past 2 years, and the fact it’s taken this long to realize there is a data-erasing bug, shows just how rare it is.

Additionally, it looks like Philm has already implemented a workaround for the 18.0 release that appears to negate this particular issue.

[Stable Update] 2018-11-02 - Pamac, ICU, XFCE, Deepin, Gnome
[Stable Update] 2018-11-02 - Pamac, ICU, XFCE, Deepin, Gnome
[Stable Update] 2018-11-07 - Kernels, Calamares, LibreOffice, Cinnamon, Deepin, Pamac

Is it in the release image? Why is OP claiming that a known bug exists?


This is a Calamares bug. Calamares is an independent project that many distros use. To blame this on Manjaro is a little unjustafiable.


Sorry to post a second post. I thought my problem is the same as above. They are both related to partition. But then I realize it’s not.

Ok I had the same bug that I posted in the previous update thread. Except this time is in a newly installed vm.

Here’s what happened.
The grub decrypt my boot partition as usual. And then it ask me for my root partition password which should not happen. After giving it the password, comes the grub menu.
Unfortunately, I don’t know how to debug early boot process. If anyone can enlighten me, I’ll be grateful.
Tell me if you need more info. BTW, I use manjaro architect in my vm. I just don’t know which program was asking me my root partition password.

PPPS: Ok I managed to find the problem. I have separated encrypted boot and root partition. And the Grub requires manjaro theme in root partition and ask for root partition password. Is this normal?


Smooth and great update, thanks


This update still hasn’t resolved the issue with 4.19 kernel panic. I have encrypted SSD (using Manjaro installer).

4.18 still boots without problems.