[Stable Update] 2018-10-28 - Systemd, Nvidia, Pamac, Bootsplash, Deepin, Firefox

update
stable

#1

Hi community,

Welcome to another stable update. So what do we have with this one?

  • We updated systemd to set loglevel notice when quiet is set
  • Calamares got updated accordingly incl. an important bug-fix
  • Some more Deepin updates
  • We updated firefox to v64b4
  • Nvidia drivers are now at 410.73
  • Some more bootsplash themes
  • Added jdk 11
  • Plane theme got updated
  • We updated linux419 once more. Now we support more Netbooks
  • Pamac got updated to 7.2.1
  • Some more translations to manjaro-hello, still missing French and Dansk
  • The usual upstream updates incl. python

We hope with all these changes Manjaro to be more efficient for you all.


Current supported Kernels

  • linux316 3.16.59
  • linux318 3.18.124 [EOL]
  • linux44 4.4.162
  • linux49 4.9.135
  • linux414 4.14.78
  • linux417 4.17.19 [EOL]
  • linux418 4.18.16
  • linux419 4.19.0
  • linux414-rt 4.14.71_rt44
  • linux416-rt 4.16.18_rt11
  • linux418-rt 4.18.12_rt7-1

Package Updates (Sun Oct 28 17:44:24 CET 2018)

  • stable community x86_64: 236 new and 233 removed package(s)
  • stable core x86_64: 13 new and 10 removed package(s)
  • stable extra x86_64: 108 new and 101 removed package(s)
  • stable multilib x86_64: 8 new and 8 removed package(s)

A detailed list of all changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


The Iconic Spitfire: Now Quad-Core!

jpg%3Alarge

Visit StationX now!


Manjaro v18.0 released!

We finally made it. Manjaro-Illyria 18.0 got released.

The Xfce edition remains our flagship offering and has received the attention it deserves. Few can claim to offer such a polished, integrated and leading-edge Xfce experience. We ship Xfce 4.13 with this release of Manjaro.

We mainly focused on polishing the user experience on the desktop and window manager, and on updating some components to take advantage of newly available technologies such as switching to a new theme we call Adapta-Maia. The new feature Display-Profiles allows you to store one or more profiles for a particular display configuration that you may be using. To make the deal a little sweeter we implemented auto-applying of profiles when new displays are connected.

Our KDE edition continues to deliver this powerful, mature and feature-rich desktop environment with a unique look-and-feel, and with the perks of Manjaro’s latest tools. We ship now Plasma 5.14 desktop in combination with the latest KDE-Apps 18.08. There’s a new Display Configuration widget for screen management which is useful for presentations. Switching primary monitor when plugging in or unplugging monitors is now smoother. The Network widget now works for SSH VPN tunnels again. The Audio Volume widget now has a built in speaker test feature moved from Phonon settings and Plasma now warns on logout when other users are logged in.

Kernel 4.19 LTS is used for this release, such as the latest drivers available to date. Relative to the last installation media release, our tools have been improved and polished.

The Manjaro Settings Manager (MSM) now provides an easy-to-use graphical interface for installing and removing the many series of kernels we offer. Manjaro’s selection of readily available kernels remains the most extensive of all Linux distribution we know of. At the time of this release, eight kernel-series are available directly from our binary repositories, ranging from the mature & rock-solid 3.16 series to the latest 4.19 release. Additionally we offer three realtime kernel series. Such a wide array of available kernel options results in extensive hardware support, getting the most out of your system for you, be it old or new.

With Pamac v7.2 we fixed known issues and added new functions. Followed features you can expect:

  • pamac-gtk: add edit build files support
  • pamac-cli: add edit build files support
  • pamac-cli: add clone action
  • pamac-cli: build action now has an --no-clone option to only use local build files
  • pamac-cli: build action without argument now tries to build from the PKGBUILD in the current dir
  • pamac-cli: added a CLI mode to pamac, which acts similar to apt-get

With Manjaro Hello we added new functions. Followed features you can expect:

  • you can now maintain suggested packages by the community directly in the welcome screen under the applications option
  • UI enhancements
  • updated translations

We hope you enjoy this release and let us know what you think of Illyria.

Known issues with v18.0 release

  • XFCE: In the settings Manager, the mouse fails to scroll apps in settings manager (GTK+ 3 regression)
  • Calamares: may delete partitions during disk-probe in really rare conditions. bug, talk

Download

XFCE, KDE, GNOME


Changes made to pamac

With v7.2.1, Pamac has the ability to edit build files in both pamac-gtk and pamac-cli.

But it’s not the only one improvement, pamac-cli is now a complete AUR helper and an advanced build tool:

  • Tracking build files:
    It now keeps all build files in the configured pamac build dir that is now
    /var/tmp/pamac-build-<username> by default.
    This way it can track when a new version is available from AUR or if changes were made by yourself and propose you to view the diff.

  • Build tool:
    Pamac now has a clone action and build has a --no-clone option. They permit to ease building a package when you want to do important manual modifications.
    How to use it ?
    If a standard pamac build foo does all automatically you can do it step by step:
    Clone the build files with all dependencies : pamac clone --recurse foo
    Edit them as you want, then : pamac build --no-clone foo
    Or go the foo directory and run: pamac build --no-clone

  • Development tool:
    You can even create your own PKGBUILD files and build them with:
    pamac build --no-clone --builddir /my/build/dir <pkgname>
    or in the PKGBUILD directory:
    pamac build --no-clone
    If there are dependencies to build, all files must be in the same directory with one subdir per package.
    All dependencies will be checked and the correct build order will be found.

Changes made to grub package

1. What is the GRUB hidden menu change?

The main motivation for adding this is, to get to a fully flickerfree boot.

2. How to enable hidden GRUB menu?

On new Manjaro v18.0 installs this will be enabled by default. If your system has been upgraded to v18.0 from an older release, you can enable it by running these commands:

  • update your system to get latest systemd
  • install linux418 or linux419: sudo pacman -S linux41[x]
  • check that you have quiet in /etc/default/grub under GRUB_CMDLINE_LINUX_DEFAULT or GRUB_CMDLINE_LINUX and comment out any GRUB_BACKGROUND settings.
  • sed -i -e 's|fsck||g' /etc/mkinitcpio.conf && sudo pacman -S systemd-fsck-silent
  • You may want to consider early kms and fastboot for intel hardware
  • sudo mkinitcpio -P
  • sudo grub-editenv - set menu_auto_hide=1
  • sudo update-grub
  • reboot your system

Note the grub-update will overwrite any manual changes you’ve made to your grub.cfg (normally no manually changes are done to this file).

If your system has Windows on it, but you boot it only once a year so you would still like to hide the GRUB menu, you can tell GRUB to ignore the presence of Windows by running:

sudo grub-editenv - set menu_auto_hide=2

3. How to disable hidden GRUB menu

To permanently disable the auto-hide feature run:

sudo grub-editenv - unset menu_auto_hide

That is it.

4.How to access the GRUB menu when hidden

If for some reason you need to access the GRUB menu while it is hidden there are multiple ways to get to it:

  1. While booting keep SHIFT pressed, usually you need to first press SHIFT when the vendor logo is shown by the firmware / when the firmware says e.g. “Press F2 to enter setup” if you press it earlier it may not be seen. Note this may not work on some machines.

  2. During boot press ESC or F8 while GRUB loads (simply press the key repeatedly directly after power on until you are in the menu).

  3. Force the previous boot to be considered failed:

    1. Press CTRL + ALT + DEL while booting so that the system reboots before hitting the display manager (lightdm, gdm, sddm)

    2. Press CTRL + ALT + F6 to switch away from your display manager, followed by CTRL + ALT + DEL.

    3. Press the power-button for 4 seconds to force the machine off. Either of these will cause the boot_success grub_env flag to not get set and the menu will show the next boot.

    4. Manually set the menu show once flag by running: "grub-set-bootflag menu_show_once" This will cause the menu to show for 60 seconds before continuing with the default boot-option.

4. When is a boot considered successful ?

The boot_success grub_env flag gets set when you login as a normal user and your session lasts at least 2 minutes.

So if you e.g. login, do something and then within 30 seconds type reboot in a terminal (instead of doing the reboot from the menu) then this will not count as a successful boot and the menu will show the next boot.


[Bootsplash] Provided by the kernel
#3

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Kernel v4.19 crashes a lot lately

Some people might have issues with the default enabled BFQ scheduler. You may pass elevator=cfq as kernel cmd to use CFQ instead. You can add it to GRUB_CMDLINE_LINUX= in your /etc/default/grub file and do a sudo update-grub.

I can’t open Nemo with elevated privileges (as root)

Workaround found: Use the dbus-x11 package instead of the regular dbus package. This package is available in the official repositories and provides dbus compiled without the --without-x option.

To replace dbus with dbus-x11 package, simply install dbus-x11 with your favorite package manager: dbus will be replaced by dbus-x11.

Pamac: “Failed to commit transaction - Transaction not prepared” at the end

So far, it has only been a false alarm: updates are applied successfully.


Items from previous update sets

AMD-Ucode introduction

Unless you’ve already done this previously, All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.


Rebuilding fontconfig cache: failed to write cache

Please ignore this message. Upstream already works on a solution. More about the issue here.


LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn’t work for you, you may use gtk instead of gtk3_kde5 as UI framework.


Installing glibc (2.28-4) breaks the dependency “glibc=2.27” required by lib32-glibc

Install the update either:

  • from terminal: sudo pacman -Syu or;
  • with Octopi instead of Pamac.

Something using Perl/Python/glibc broke

Rebuilds needed!

  • If it’s an AUR package, try to reinstall it from AUR. It most likely needs to be rebuilt.
  • If it’s a repo package, please report and check back regularly for updates.

I’ve lost a Thunderbird addon/feature

Thunderbird 60 disables incompatible addons by default. There’s an about:config switch should you want to force-enable the addon, but many addons simply will not work with the newer Quantum-based Thunderbird.

Read more about Thunderbird 60 here: Thunderbird 60


Firefox - WebGL not working anymore

You may try the following solution:

Open about:config and set security.sandbox.content.read_path_whitelist to /sys/.


libutf8proc>=2.1.1-3 update may require manual intervention

This should normally be automatically fixed via manjaro-system update.

The libutf8proc package prior to version 2.1.1-3 had an incorrect soname link. This has been fixed in 2.1.1-3, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libutf8proc: /usr/lib/libutf8proc.so.2 exists in filesystem

when updating, use


pacman -Suy --overwrite usr/lib/libutf8proc.so.2

to perform the upgrade.


Pamac: “Invalid or corrupted package.”

If you receive an “Invalid or corrupted package.” error message with Pamac and if the details contains an output similar to the following:

Details
Synchronizing package databases...
Starting full system upgrade...

Preparing...
Resolving dependencies...
Checking inter-conflicts...
Downloading...
Downloading manjaro-system-20180716-1-any.pkg.tar.xz...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Upgrading manjaro-system (20180702-1 -> 20180716-1)...
==> Fix libutf8proc upgrade ...
resolving dependencies...
looking for conflicting packages...

Packages (1) libutf8proc-2.1.1-4

Total Download Size:   0.05 MiB
Total Installed Size:  0.32 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading libutf8proc-2.1.1-4-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
upgrading libutf8proc...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
Running post-transaction hooks...
Arming ConditionNeedsUpdate...
Warning: lock file missing /var/lib/pacman/db.lck
Starting full system upgrade...
Resolving dependencies...
Checking inter-conflicts...
Error: could not open file /var/lib/pacman/local/libutf8proc-2.1.1-2/files: No such file or directory
Warning: could not fully load metadata for package libutf8proc-2.1.1-2

Failed to prepare transaction:
invalid or corrupted package

Try the following steps: close Pamac window first, then launch it again and start the update procedure again. It should continue from where it left off.


Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you’re able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.

icon-kde-513

Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if ‘default.pa’ has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.


#4

Woo, Nice!


#5

XFCE, 4.19.0-3

Everything went smoothly! Thanks for the hard work.


#6

Ich zitiere mich mal selbst: “Immer noch das gleiche Problem (wie ich nach dem letzten Update schon anmerkte): Momentan ist es nicht möglich, bei KDE Programm- oder Fensterregeln (Individuelles Fensterverhalten) festzulegen. Die Einstellungen lassen sich nicht speichern.
Systemklänge (Warnmeldungen etc.) stumm, obwohl der Sound wie gewohnt funktioniert.”

Ansonsten alles im Grün, Danke für die gute Arbeit!


#7

Er? adapta-maia-theme isn’t new and hasn’t been updated for over a month.


#8

Release announcements are always in context of the last release, which was 17.1.


#9

Oh, I see. What’s the default theme on the 18.0 ISO’s? Perhaps Arc or Matcha?


#10

XFCE and Gnome have Adapta and KDE Breath. The newer themes are not finished yet for wider usage …


#11

(previous message edited out)

After re-downloading and re-testing, all looks good!

Tested booting and installing on Legacy and UEFI on the following:
VirtualBox
Latitude E7440
Thinkpad X260


#12

Is it just me or are the torrents for the 18.0 ISO’s not live? The tracker (udp://mirror.strits.dk:6969) is not working using qBittorrent 4.1.3. I’ve never had an issue with previous ISO’s with the same client and tracker.

EDIT: Nevermind, they’re working today.


#13

thank you! Since there will be a new OpenJDK release every 6 month and old versions won’t get security updates for long after a new release, it might be wise to have a meta package openjdk-current (or similar) which would just switch to the latest release version and install it. Sticking with old versions after 8 isn’t a good idea anymore - since they are not going to get updates.

some builds from https://adoptopenjdk.net/ might get longer support from the community. Oracle OpenJDK builds from https://jdk.java.net/ have 6 month expiration dates (basically rolling release).

(release model is now similar to the linux kernel)

edit: haha, I should have checked the new packages first before commenting. jdk-openjdk now installs the latest release - awesome :smiley:


#14

Tried KDE 18.0 stable. Despite Nvidia drivers now being 410.73 my EVGA 2080 TI FTW3 Ultra (11G-P4-2487-KR) doesn’t seem to be supported despite GeForce 2080 Ti allegedly being supported several driver rev’s prior. Live USB gets stuck on during boot sequence on Started TLP system startup/shutdown. Gnome 18-rc4 (didn’t bother with 18 stable) gets stuck on Stopped /run/user/1000 mount wrapper.

Anyone have a 11G-P4-2487-KR that is working with KDE 18 (don’t care for Gnome, just figured I’d see if other versions worked)? Is this a bug/enhancement issue someone from the community that has weight should file with Nvidia?

Edit: For what it’s worth Ubuntu 18.10 Live USB works fine and get to desktop w/o issues…so I know there is a *nix distro out there that does support 11G-P4-2487-KR…


#15

Deepin status bar plugin functionality was somewhat borked with the latest deepin dock update. Left clicking on the volume or network icon no longer opens the respective overlay.


#16

Did you try booting via non free or free drivers


#17

I booted with stock KDE 18 stable, so non-free I presume since the official Nvidia drivers are proprietary and that’s what Manjaro KDE 18 stable ships with(?) I can unslot my 11G-P4-2487-KR and use Manjaro just fine. So if there’s a driver package I need to install before slotting my GPU I can do it, it’s just a serious pain to do so with my case, so I’d prefer to be a one reslotting and done.

On my currently inaccessible because my GPU is slotted Manjaro partition I have KDE 17.1 w/ mhwd-nvidia (410.66-1), *-34xx, and *-390xx installed. Is there a recommended package to install that would likely support 11G-P4-2487-KR or some config to modify?


#18

While booting manjaro from live USB u have to select non free drivers,its default selected as free drivers, so try again.in many cases non free don’t work but free works.


#19

By default

GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=9b08d386-3171-4a6d-bf14-4c63c463679c"
GRUB_CMDLINE_LINUX=""

Is it advisable only if there is no initialization? Or some other specific issue? I would recommend downgrade to 4.14 and it is still early to upgrade to 4.19. Demonstrates performance issues as constant crash during use.


#20

Fortunately non-free works for Live USB. Hopefully the free one is able to catch up and support RTX soon. Will reslot and follow the wiki tomorrow and edit back here with the results. Should get the GPU to work even on KDE 17.1 since the nvidia driver would be 410.66 and support for 2080 Ti was added in the version prior. Thanks so much for getting me past the first hurdle!

Edit: Said wiki link didn’t work because card has to be plugged in to detect and install drivers and you can’t get to the GUI w/o the drivers, so somewhat of a chicken and egg situation. Tried installing nvidia-beta but the build failed and upon reboot I couldn’t boot into the partition. Ended up just doing a reinstall via Live USB and fortunately it seems smart enough to use non-free for the install and now everything is running nicely thus far.


#21

Hello.
Will manjaro architect 17 install xfce 4.13? I don’t see any architect installer 18.0.