[Stable Update] 2018-10-25 - Linux 4.19, KDE Plasma 5.14.2, Xorg 1.20.3, Gnome 3.30.2, Deepin, Grub



All good but the speakers stop working (laptop).


Me and several users had same problems with freeze during update and kernel panic after reboot. Are you sure that mark it as release is good idea?


Sorry @c00ter, must disagree. This was an upgrade to a full Release from an rc.
@philm Thanks for the hard work, everything went well on xfce 18.0


With update of yesterday


LOL! Updated packages and artwork. Some new stuff. The release–any release–is just a snapshot. What version number do you want? You can change it to any number, since it is meaningless. @philm can assign it any number, and so can you.

There is no corollary in Arch, BTW. Not for a long time. :slight_smile:

But here we are arguing apples & apples. :smiley:


after the 4.19.0-3 update, I’m having an issue with grub.
update-grub is no longer working. I’m having the Manjaro default grub menu. I’m also having some decryption problem. I deleted /boot/grub and /boot/efi and reinstall grub. But it didn’t help.
When booting up, it asks me the boot partition password, then ask me to decrypt master key for root partition. Then comes the default grub menu with my custom linux_cmd in the entry.

I have no clue…


After a day and a half of reading everything I could find in the Manjaro and Arch wikis as well as two threads with @philm (who has helped me several times over the past 5+ years) I was left with chrooting using a current 18-beta USB stick, copying my /home directory to a backup drive and doing a complete reinstall over my original 2013 install of Manjaro.

I wish I could have found an answer, but this was the 2nd time I had a freeze during an update, and although I was able to restore it before, this time it seemed like too many files and links were destroyed. Guess it was bound to happen :slight_smile:

If you find a way to restore your machine, please post it as there are several of us over the past 3 updates that had a freeze during update which resulted in a non-bootable machine.

The only common denominator with this issue seems to be XFCE, Nvidia 340 drivers and the 4.19 kernel. Machines with Nouveau and 4.18 so far have not exhibited a freeze during a pacman update.

Best of luck :+1:


If you are experiencibg issues updating because of your video drivers perhaps updating from a TTY might be advisable.


I agree, so I have always updated from a TTY. Really the safest way.


There have been several reports now of kernel panic on 4.19 associated with the Atheros QCA9377 adapter. This has happened even after performing the firmware update. Just thought you might want to know.



Seems BFQ scheduler of Linux419 has some issues. Have to see about that. Other kernel series I didn’t update yet in that regard. Maybe changing to another scheduler might help.


There is now a dedicated thread:


After upgrade to 4.19 kernel panic happened to me on both my home laptop and work PC, I was able to downgrade without any problems, later on booting to 4.19 worked too.


Worked fine. Reconfigured Grub to be silent (my install is nearing 2 years old) also worked great on my Dell Precision 5520.


LOL make mine yellow, sweet and juicy. To each his own opinion.


Hi!! When updating Manjaro Gnome with pamac it gives error of conflict between manjaro-gnome-settings 17 and 18. When updating with terminal, it asks you to delete manjaro-gnomne-settings 17, it updates but the desktop does not load well when restarting after the update


Edit: Problem solved with the iso Manjaro 18


actually I’m copyng my /home directory (over 130 GB) to a backup drive. also I will reinstall a fresh new version of manjaro… no way to repair the old version

my DE is KDE, and the kernel were 4.18 and 4.14, both corrupted. Nvidia driver was 340.
i start thinking that my mystake was to upgrade the whole system with octopy while browsing internet and not within a TTY.
I never had a problem, so i feel confident. bad mistake.


Cinnamon 4.19, all yesterday afternoon updates work OK. Question - is it (or will it be) necessary to enable smooth bootup? I’d be happy not to risk enabling it.


Currently, it isn’t necessary. (Personnaly, I haven’t done the change yet and I don’t plan to apply this change anytime soon since I don’t care that much about that.)

Doubt it will be mandatory in the future.


It’s really not that big of a deal, just a couple of words in grub config. But if you don’t know what you’re doing… it is just an aesthetic change after all