[Stable Update] 2018-10-25 - Linux 4.19, KDE Plasma 5.14.2, Xorg 1.20.3, Gnome 3.30.2, Deepin, Grub

update
stable

#124

my grub says now manajro 18.0.0 without RC


#125

EDIT: Created new topic due to Kernel upgrade 4.19: Lightdm won't fully boot - Linux kernel 4.19.0-3


#126

Been using 18.0-rc(s) for the last weeks too (XFCE). What I found so far:

  • A very small detail with some elements in the tool bar (ie. Battery and Wireles). If you hover the mouse over them the info is printed “below” the screen edge instead of “up” like, say, the Date/Time. This happened on every version of 18.0 so far, including main computer.

  • Not sure about the cause, could be the video driver or the kernel but one of the laptops with integrated Intel graphic card refuse to set it’s own display as Primary if I hook up an external monitor in the VGA port. The monitor is detected fine but every time I try to configure it as Secondary, the Panel, Whisker and desktop icons end up in the external display. Also, it doesn’t save -or sets- the order (right or left) of the external monitor; is always stuck at the right position.


#127

Specified group ‘plugdev’ unknown i found like post from @Anatoliy

I have some updates too, but i don´t know if i should wait, because i don’t need any more freeze.
Is the Udate tested?


Pakete (36) alsa-plugins-1.1.7-3  android-udev-20181026-1  brotli-1.0.7-1  cpupower-4.19-1  file-5.35-1  gconf-3.2.6+11+g07808097-4  ghostscript-9.25-4  hdparm-9.57-1
            lib32-systemd-239.3-1  libinput-1.12.2-1  libmtp-1.1.16-1  libsystemd-239.3-1  libvoikko-4.2-1  linux-firmware-20181026.1cb4e51-0.1  linux419-4.19.0-3  manjaro-hello-0.6.1-1
            manjaro-release-18.0.0-1.1  manjaro-settings-manager-0.5.5-1  manjaro-settings-manager-kcm-0.5.5-1  manjaro-settings-manager-knotifier-0.5.5-1  mhwd-nvidia-1:410.73-1
            noto-fonts-20181024-1  pamac-7.2.1-2  pamac-tray-appindicator-7.2.1-2  perl-clone-0.41-1  perl-libwww-6.36-1  plasma-pa-5.14.2-2  python-setuptools-1:40.5.0-1  qca-2.1.3-2
            qt5-base-5.11.2-2.1  systemd-239.3-2  systemd-sysvcompat-239.3-1  xf86-video-intel-1:2.99.917+853+g0932a6b3-1  xmlsec-1.2.27-1  xorg-server-1.20.3-1
            xorg-server-common-1.20.3-1

Gesamtgröße des Downloads:           206,69 MiB
Gesamtgröße der installierten Pakete:  789,82 MiB
Größendifferenz der Aktualisierung:   13,15 MiB


#128

59 additional updates on one machine, 49 on another seem to have gone through fine. No discernible issues at this time.
THX
Linux419.0-3


#129

Just applied latest updates and tried 4.19 LTS. System didn’t boot and saw kernel panic. attaching screenshot -


#130

Hello,

I had the same problem. Startet again with 4.14. Shutdown. Retried 4.19 and now 4.19 is working fine!


#131

Same here. I had to restart and then everything went back to normal.


#132

Originally I planned to release v18.0 yesterday, but had to deal with the following bug:

Will announce the update later today as a regular one and hope to find a proper solution for it. If you have issues with linux419 let me know.


#133

Just updated everything (including the new update set) and all is fine!
xfce on 4.19

FYI, I still have to tooltips on gtk3 apps…


#134

Thanks, booted 4.14, did a shutdown and started 4.19… Worked !


#135

After update i get this boot messages and it does NOT recognize wifi:

ath10k_pci 0000:03:00.0: unable to read from the device
ath10k_pci 0000:03:00.0: could not execute otp for board id check: -110
ath10k_pci 0000:03:00.0: failed to get board id from otp: -110
ath10k_pci 0000:03:00.0: could not probe fw (-110)

Its on linux414
And inxi -Fx output for network is:

Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8168 v: 8.045.08-NAPI 
           port: d000 bus ID: 02:00.0 
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: 18:31:bf:71:53:29 
           Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: AzureWave driver: ath10k_pci v: kernel 
           port: d000 bus ID: 03:00.0

What is the problem?


#136

I also get this. It comes from the file /lib/udev/rules.d/51-android.rules which belongs to the package android-udev.

[mbb@mbb-laptop ~]$ cat /lib/udev/rules.d/51-android.rules | grep plugdev
ACTION=="add", SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ENV{ID_USB_INTERFACES}=="*:ff420?:*", MODE="0666", GROUP="plugdev", SYMLINK+="android/$env{ID_SERIAL_SHORT}"
[mbb@mbb-laptop ~]$ pacman -Qo /lib/udev/rules.d/51-android.rules
/usr/lib/udev/rules.d/51-android.rules is owned by android-udev 20181026-1

Some discussion here and here.

Not sure what I should be doing. Maybe alter the rules file? Create plugdev group instead? Do nothing and wait for a fix?


#137

Qualcomm has some issues with firmware. Search the forums for a solution.


#139

If that (*) was calamares too, then you can use TestDisk 7.0 (extra).

In gparted the partitions look empty/deleted but can be restored with TestDisk 7.0.

For those who don’t have a backup, a possible solution.

(*)

Wird die Installation durchlaufen? Manjaro Linux 18.0-alpha-2 Illyria
Wird die Installation durchlaufen? Manjaro Linux 18.0-alpha-2 Illyria
sda leer
Die Beiträge von mir sehen ziemlich konfus aus :slight_smile: , es war spät und meine Daten weg :smiley: .
Ich bin kein Fachmann aber es wird wohl nur das Verzeichnis/Pfade gelöscht.
TestDisk erkennt die (nicht vorhandene) Partitionseinteilung und stellt sie wieder her. Dauert keine zwei Sekunden.
Ich bin damals davon ausgegangen, dass ich grub-install auf die falsche Festplatte geschrieben habe.
Mir hat auch keiner geglaubt, das es durch die Installation (calamares) passiert wäre :wink: .


#140

https://www.cgsecurity.org/wiki/TestDisk_Step_By_Step

Quick Search for partitions
TestDisk displays the first results in real time.
quick search

During the Quick Search, TestDisk has found two partitions including the missing logical partition labeled Partition 3.

All directories and data are correctly listed.

Press Enter to proceed.

#141

got an update this morning, seems I’m already on 18.0

OS: Manjaro 18.0.0 Illyria
██████████████████  ████████     Kernel: x86_64 Linux 4.19.0-3-MANJARO

#142

Yes Version 18.0.0 here too. The update yesterday afternoon seems to have been the upgrade to 18.0.0.


#143

Did you find a solution?

I have the same problem: a freeze during the update and now no boot at all, with kernel panic for a TSC (time_stamp_counter?).

with manjaro-chroot I was able to remove kernel, but i can’t install a new one.

with pacman -Syu I obtained “there is nothing to do”, because the system is uptodate

removing some of the file listed as empty or uninstalling the packages is possible, but I can’t reinstall them. removing xorg, mesa or other core package seems to me not the right way :frowning:


#144

That’s just a number, arbitrary, and means nothing on rolling-releases systems. You are simply up to date.

regards